revive package

This commit is contained in:
Tom "spot" Callaway 2011-10-12 16:26:01 -04:00
parent 985dd39d64
commit 69ab1b6edb
5 changed files with 131 additions and 1 deletions

View File

@ -1 +0,0 @@
This package was retired on 2011-07-25 due to it being unable to build this package for multiple releases (FTBFS).

View File

@ -0,0 +1,34 @@
diff -ur lwp-2.6~/src/lwp_ucontext.c lwp-2.6/src/lwp_ucontext.c
--- lwp-2.6~/src/lwp_ucontext.c 2010-03-17 16:32:51.000000000 -0400
+++ lwp-2.6/src/lwp_ucontext.c 2010-04-01 11:38:55.495718223 -0400
@@ -21,9 +21,6 @@
#include <string.h>
#include <unistd.h>
-/* avoid breaking longjmp stack switching */
-#undef _FORTIFY_SOURCE
-#define _FORTIFY_SOURCE 0
#include "lwp_ucontext.h"
/* Some architectures have a stack that grows up instead of down */
diff -ur lwp-2.6~/src/lwp_ucontext.h lwp-2.6/src/lwp_ucontext.h
--- lwp-2.6~/src/lwp_ucontext.h 2008-12-09 15:13:12.000000000 -0500
+++ lwp-2.6/src/lwp_ucontext.h 2010-04-01 11:38:36.160841037 -0400
@@ -21,7 +21,17 @@
#include <config.h>
#endif
+/* work around longjmp_chk */
+#ifdef __USE_FORTIFY_LEVEL
+#define LWP_SAVE_USE_FORTIFY_LEVEL __USE_FORTIFY_LEVEL
+#undef __USE_FORTIFY_LEVEL
#include <setjmp.h>
+#define __USE_FORTIFY_LEVEL LWP_SAVE_USE_FORTIFY_LEVEL
+#undef LWP_SAVE_USE_FORTIFY_LEVEL
+#else
+#include <setjmp.h>
+#endif
+
#include <signal.h>
#include "lwp_stacktrace.h"

8
lwp-2.6.tar.gz.asc Normal file
View File

@ -0,0 +1,8 @@
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)
Comment: See http://www.coda.cs.cmu.edu/signature.html for info
iD8DBQBLqQpHzg1+EJlwB6IRAu97AKCIgEgUQ5QavOJXif/aP91br6gW+ACgsZwj
fhg8xC7LV6/EcJmpWk4jCjM=
=HLXx
-----END PGP SIGNATURE-----

88
lwp.spec Normal file
View File

@ -0,0 +1,88 @@
Name: lwp
Version: 2.6
Release: 4%{?dist}
Summary: C library for user-mode threading
Group: System Environment/Libraries
License: LGPLv2
URL: http://www.coda.cs.cmu.edu/
Source0: ftp://ftp.coda.cs.cmu.edu/pub/lwp/src/%{name}-%{version}.tar.gz
Source1: ftp://ftp.coda.cs.cmu.edu/pub/lwp/src/%{name}-%{version}.tar.gz.asc
Patch0: lwp-2.6-no-longjmp_chk.patch
%description
The LWP user-space threads library. The LWP threads library is used by the Coda
distributed file-system, RVM (a persistent VM library), and RPC2/SFTP (remote
procedure call library).
%package devel
Summary: Development files for %{name}
Group: Development/Libraries
Requires: %{name}%{?_isa} = %{version}-%{release}
%description devel
The %{name}-devel package contains libraries and header files for
developing applications that use %{name}.
%prep
%setup -q
%patch0 -p1 -b .nolongjmpchk
%build
%configure --disable-static
make %{?_smp_mflags}
%install
make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
%check
./src/testlwp 2
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files
%doc AUTHORS COPYING NEWS README
%{_libdir}/*.so.*
%files devel
%{_includedir}/%{name}
%{_libdir}/*.so
%{_libdir}/pkgconfig/%{name}.pc
%changelog
* Wed Oct 12 2011 Tom Callaway <spot@fedoraproject.org> - 2.6-4
- fix subpackage requires
- add .asc signature file
* Tue Oct 11 2011 Tom Callaway <spot@fedoraproject.org> - 2.6-3
- revived
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.6-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
* Thu Apr 1 2010 Adam Goode <adam@spicenitz.org> - 2.6-1
- New upstream release
+ Fix fortify failure whenever a new thread is started (not really)
+ ARM thumb2 assembly fix
- Update longjmp patch, upstream is not quite right yet
* Thu Aug 20 2009 Adam Goode <adam@spicenitz.org> - 2.5-3
- Add check to specfile
- Patch around lwp's creative use of longjmp that fails with fortify
* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
* Fri Feb 27 2009 Adam Goode <adam@spicenitz.org> - 2.5-1
- New upstream release
+ Correct license on a few files
+ Add valgrind support
+ Adjust API (not ABI) for const correctness
+ Increase context switch performance
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
* Mon May 12 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 2.4-1
- Initial Fedora package

1
sources Normal file
View File

@ -0,0 +1 @@
65ba6faddf2c9741d4a481b0e9661a34 lwp-2.6.tar.gz