lucenepp/lucene++-3.0.6-fix_installi...

45 lines
1.6 KiB
Diff

From 994f03cf736229044a168835ae7387696041658f Mon Sep 17 00:00:00 2001
From: rezso <rezso@example.com>
Date: Mon, 19 May 2014 09:20:40 +0100
Subject: [PATCH] fix installing lucene++ headers in 3.0.6
Upstream: committed
References: https://github.com/luceneplusplus/LucenePlusPlus/commit/994f03cf736229044a168835ae7387696041658f
---
CMakeLists.txt | 8 ++++++++
src/core/CMakeLists.txt | 2 +-
2 files changed, 9 insertions(+), 1 deletion(-)
Index: LucenePlusPlus-rel_3.0.6/CMakeLists.txt
===================================================================
--- LucenePlusPlus-rel_3.0.6.orig/CMakeLists.txt 2014-04-19 19:26:40.000000000 +0100
+++ LucenePlusPlus-rel_3.0.6/CMakeLists.txt 2014-10-18 10:54:14.000000000 +0100
@@ -138,6 +138,14 @@ if(NOT WIN32)
DESTINATION ${LIB_DESTINATION}/pkgconfig)
endif()
+#################################
+# install Config.h
+#################################
+install(
+ FILES
+ "${CMAKE_CURRENT_BINARY_DIR}/include/Config.h"
+ DESTINATION include/lucene++)
+
####################################
# custom targets
####################################
Index: LucenePlusPlus-rel_3.0.6/src/core/CMakeLists.txt
===================================================================
--- LucenePlusPlus-rel_3.0.6.orig/src/core/CMakeLists.txt 2014-04-19 19:26:40.000000000 +0100
+++ LucenePlusPlus-rel_3.0.6/src/core/CMakeLists.txt 2014-10-18 10:54:14.000000000 +0100
@@ -20,7 +20,7 @@ file(GLOB_RECURSE lucene_internal_header
)
file(GLOB_RECURSE lucene_headers
- include/*.h
+ "${lucene++_SOURCE_DIR}/include/*.h"
)
add_definitions(-DLPP_BUILDING_LIB)