This commit is contained in:
Rex Dieter 2014-11-18 10:40:05 -06:00
parent d59ff91459
commit a0d595fb3f
6 changed files with 231 additions and 0 deletions

1
.gitignore vendored
View File

@ -0,0 +1 @@
/lucene++-3.0.6.tar.gz

View File

@ -0,0 +1,44 @@
From 994f03cf736229044a168835ae7387696041658f Mon Sep 17 00:00:00 2001
From: rezso <rezso@example.com>
Date: Mon, 19 May 2014 09:20:40 +0100
Subject: [PATCH] fix installing lucene++ headers in 3.0.6
Upstream: committed
References: https://github.com/luceneplusplus/LucenePlusPlus/commit/994f03cf736229044a168835ae7387696041658f
---
CMakeLists.txt | 8 ++++++++
src/core/CMakeLists.txt | 2 +-
2 files changed, 9 insertions(+), 1 deletion(-)
Index: LucenePlusPlus-rel_3.0.6/CMakeLists.txt
===================================================================
--- LucenePlusPlus-rel_3.0.6.orig/CMakeLists.txt 2014-04-19 19:26:40.000000000 +0100
+++ LucenePlusPlus-rel_3.0.6/CMakeLists.txt 2014-10-18 10:54:14.000000000 +0100
@@ -138,6 +138,14 @@ if(NOT WIN32)
DESTINATION ${LIB_DESTINATION}/pkgconfig)
endif()
+#################################
+# install Config.h
+#################################
+install(
+ FILES
+ "${CMAKE_CURRENT_BINARY_DIR}/include/Config.h"
+ DESTINATION include/lucene++)
+
####################################
# custom targets
####################################
Index: LucenePlusPlus-rel_3.0.6/src/core/CMakeLists.txt
===================================================================
--- LucenePlusPlus-rel_3.0.6.orig/src/core/CMakeLists.txt 2014-04-19 19:26:40.000000000 +0100
+++ LucenePlusPlus-rel_3.0.6/src/core/CMakeLists.txt 2014-10-18 10:54:14.000000000 +0100
@@ -20,7 +20,7 @@ file(GLOB_RECURSE lucene_internal_header
)
file(GLOB_RECURSE lucene_headers
- include/*.h
+ "${lucene++_SOURCE_DIR}/include/*.h"
)
add_definitions(-DLPP_BUILDING_LIB)

View File

@ -0,0 +1,28 @@
From fcdcf1945f0325c8dfdcdfa03ae8af5247602e6e Mon Sep 17 00:00:00 2001
From: Gianfranco Costamagna <costamagnagianfranco@yahoo.it>
Date: Wed, 2 Jul 2014 17:20:57 +0200
Subject: [PATCH] enable multiarch lib location
References: https://github.com/luceneplusplus/LucenePlusPlus/commit/4c533e7f87ce6032284c44d12e022dc2498b49df
Uptream: committed
Cherry picked from ubuntu lucene++ package
---
CMakeLists.txt | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6ae96b7..4b74427 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -75,9 +75,10 @@ set(lucene_boost_libs
include(Lucene++Docs)
include(TestCXXAcceptsFlag)
+include(GNUInstallDirs)
set(LIB_DESTINATION
- "lib" CACHE STRING "Define lib output directory name"
+ "${CMAKE_INSTALL_FULL_LIBDIR}" CACHE STRING "Define lib output directory name"
)
if(ENABLE_CYCLIC_CHECK)

View File

@ -0,0 +1,71 @@
From c5ed014df578f2be4c48ac8e6f09d6450d1a2a03 Mon Sep 17 00:00:00 2001
From: rezso <rezso@example.com>
Date: Mon, 19 May 2014 09:23:35 +0100
Subject: [PATCH] lucene++ .pc files fix
Upstream: Committed:
References: https://github.com/luceneplusplus/LucenePlusPlus/commit/c5ed014df578f2be4c48ac8e6f09d6450d1a2a03
Without this patch, liblucene++-contrib.pc contains:
> Requires: liblucene++=3.0.6
Which breaks pkg-config:
> $ pkg-config --libs liblucene++-contrib
> Package liblucene++=3.0.6 was not found in the pkg-config search path.
> Perhaps you should add the directory containing `liblucene++=3.0.6.pc'
> to the PKG_CONFIG_PATH environment variable
> Package 'liblucene++=3.0.6', required by 'liblucene++-contrib', not found
The correct line is:
> Requires: liblucene++ = 3.0.6
Which returns correctly:
> $ pkg-config --libs liblucene++-contrib
> -L/usr/lib/ -llucene++-contrib -llucene++
---
liblucene++-contrib.pc.cmake | 7 +++----
liblucene++.pc.cmake | 5 ++---
2 files changed, 5 insertions(+), 7 deletions(-)
Index: LucenePlusPlus-rel_3.0.6/liblucene++-contrib.pc.cmake
===================================================================
--- LucenePlusPlus-rel_3.0.6.orig/liblucene++-contrib.pc.cmake 2014-10-19 19:13:45.000000000 +0100
+++ LucenePlusPlus-rel_3.0.6/liblucene++-contrib.pc.cmake 2014-10-19 19:18:37.000000000 +0100
@@ -1,14 +1,13 @@
prefix=@CMAKE_INSTALL_PREFIX@
exec_prefix=${prefix}/bin
-libdir=@LIB_DESTINATION@
+libdir=@LIB_INSTALL_DIR@
includedir=${prefix}/include/lucene++
lib=lucene++-contrib
Name: liblucene++-contrib
Description: Contributions for Lucene++ - a C++ search engine, ported from the popular Apache Lucene
Version: @lucene++_VERSION@
-Libs: -L@LIB_DESTINATION@/ -l${lib}
+Libs: -L@LIB_INSTALL_DIR@ -l${lib}
Cflags: -I${includedir}
-Requires: liblucene++=@lucene++_VERSION@
-~
+Requires: liblucene++ = @lucene++_VERSION@
Index: LucenePlusPlus-rel_3.0.6/liblucene++.pc.cmake
===================================================================
--- LucenePlusPlus-rel_3.0.6.orig/liblucene++.pc.cmake 2014-10-19 19:13:45.000000000 +0100
+++ LucenePlusPlus-rel_3.0.6/liblucene++.pc.cmake 2014-10-19 19:18:19.000000000 +0100
@@ -1,13 +1,12 @@
prefix=@CMAKE_INSTALL_PREFIX@
exec_prefix=${prefix}/bin
-libdir=@LIB_DESTINATION@
+libdir=@LIB_INSTALL_DIR@
includedir=${prefix}/include/lucene++
lib=lucene++
Name: liblucene++
Description: Lucene++ - a C++ search engine, ported from the popular Apache Lucene
Version: @lucene++_VERSION@
-Libs: -L@LIB_DESTINATION@ -l${lib}
+Libs: -L@LIB_INSTALL_DIR@ -l${lib}
Cflags: -I${includedir}
-~

86
lucene++.spec Normal file
View File

@ -0,0 +1,86 @@
Name: lucene++
Summary: A high-performance, full-featured text search engine written in C++
Version: 3.0.6
Release: 1%{?dist}
License: ASL 2.0 or LGPLv3+
Url: https://github.com/luceneplusplus/LucenePlusPlus
Source: https://github.com/luceneplusplus/LucenePlusPlus/archive/rel_%{version}.tar.gz#/%{name}-%{version}.tar.gz
Patch1: lucene++-3.0.6-pc_files_fix.patch
Patch2: lucene++-3.0.6-fix_installing_headers.patch
Patch3: lucene++-3.0.6-multiarch.patch
BuildRequires: boost-devel
BuildRequires: cmake >= 2.8.6
BuildRequires: pkgconfig
BuildRequires: subversion
%description
An up to date C++ port of the popular Java Lucene library, a high-performance, full-featured text search engine.
%package devel
Summary: Development files for lucene++
Requires: %{name}%{?_isa} = %{version}-%{release}
%description devel
Development files for lucene++, a high-performance, full-featured text search engine written in C++
%prep
%setup -q -n LucenePlusPlus-rel_%{version}
%patch1 -p1 -b .pc_files_fix
%patch2 -p1 -b .fix_installing_headers
%patch3 -p1 -b .multiarch
%build
mkdir %{_target_platform}
pushd %{_target_platform}
%cmake .. \
-DCMAKE_BUILD_TYPE:String="release"
make %{?_smp_mflags} lucene++ lucene++-contrib
popd
%install
make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files
%doc COPYING APACHE.license LGPL.license
%doc AUTHORS README* REQUESTS
%{_libdir}/liblucene++.so.0*
%{_libdir}/liblucene++.so.%{version}
%{_libdir}/liblucene++-contrib.so.0*
%{_libdir}/liblucene++-contrib.so.%{version}
%files devel
%{_includedir}/lucene++/
%{_libdir}/liblucene++.so
%{_libdir}/liblucene++-contrib.so
%{_libdir}/pkgconfig/liblucene++.pc
%{_libdir}/pkgconfig/liblucene++-contrib.pc
%changelog
* Wed Nov 05 2014 Rex Dieter <rdieter@fedoraproject.org> 3.0.6-1
- fedora-ize opensuse .spec
* Sun Oct 19 2014 andreas.stieger@gmx.de
- fixes for .pc files in lucene++-3.0.6-pc_files_fix.patch
- add upstream patch lucene++-3.0.6-multiarch.patch to work with
%%cmake makro
- fix build for openSUSE 12.3
* Sat Oct 18 2014 andreas.stieger@gmx.de
- lucene++ 3.0.6, a high-performance, full-featured text search
engine written in C++,
- upstream patches:
* lucene++-3.0.6-pc_files_fix.patch - fix pkgconfig files
* lucene++-3.0.6-fix_installing_headers.patch fix header install

View File

@ -0,0 +1 @@
80f38e7faf88472b5f2ac82320a9b920 lucene++-3.0.6.tar.gz