5.3.4
This commit is contained in:
parent
53e62ec64e
commit
b7447739b8
2
.gitignore
vendored
2
.gitignore
vendored
@ -11,3 +11,5 @@ lua-5.1.4/
|
||||
/lua-5.3.2.tar.gz
|
||||
/lua-5.3.3.tar.gz
|
||||
/lua-5.3.3-tests.tar.gz
|
||||
/lua-5.3.4.tar.gz
|
||||
/lua-5.3.4-tests.tar.gz
|
||||
|
@ -1,25 +0,0 @@
|
||||
diff -up lua-5.3.3/src/lparser.c.crashfix lua-5.3.3/src/lparser.c
|
||||
--- lua-5.3.3/src/lparser.c.crashfix 2016-07-25 16:00:14.206121141 -0400
|
||||
+++ lua-5.3.3/src/lparser.c 2016-07-25 16:00:51.910865872 -0400
|
||||
@@ -323,6 +323,8 @@ static void adjust_assign (LexState *ls,
|
||||
luaK_nil(fs, reg, extra);
|
||||
}
|
||||
}
|
||||
+ if (nexps > nvars)
|
||||
+ ls->fs->freereg -= nexps - nvars; /* remove extra values */
|
||||
}
|
||||
|
||||
|
||||
@@ -1160,11 +1162,8 @@ static void assignment (LexState *ls, st
|
||||
int nexps;
|
||||
checknext(ls, '=');
|
||||
nexps = explist(ls, &e);
|
||||
- if (nexps != nvars) {
|
||||
+ if (nexps != nvars)
|
||||
adjust_assign(ls, nvars, nexps, &e);
|
||||
- if (nexps > nvars)
|
||||
- ls->fs->freereg -= nexps - nvars; /* remove extra values */
|
||||
- }
|
||||
else {
|
||||
luaK_setoneret(ls->fs, &e); /* close last expression */
|
||||
luaK_storevar(ls->fs, &lh->v, &e);
|
@ -1,13 +0,0 @@
|
||||
diff -up lua-5.3.3/src/loslib.c.readpast lua-5.3.3/src/loslib.c
|
||||
--- lua-5.3.3/src/loslib.c.readpast 2016-07-25 16:04:13.916465061 -0400
|
||||
+++ lua-5.3.3/src/loslib.c 2016-07-25 16:04:19.756423878 -0400
|
||||
@@ -260,7 +260,8 @@ static int getfield (lua_State *L, const
|
||||
static const char *checkoption (lua_State *L, const char *conv, char *buff) {
|
||||
const char *option;
|
||||
int oplen = 1;
|
||||
- for (option = LUA_STRFTIMEOPTIONS; *option != '\0'; option += oplen) {
|
||||
+ int convlen = (int)strlen(conv);
|
||||
+ for (option = LUA_STRFTIMEOPTIONS; *option != '\0' && oplen <= convlen; option += oplen) {
|
||||
if (*option == '|') /* next block? */
|
||||
oplen++; /* next length */
|
||||
else if (memcmp(conv, option, oplen) == 0) { /* match? */
|
13
lua.spec
13
lua.spec
@ -8,8 +8,8 @@
|
||||
|
||||
|
||||
Name: lua
|
||||
Version: %{major_version}.3
|
||||
Release: 4%{?dist}
|
||||
Version: %{major_version}.4
|
||||
Release: 1%{?dist}
|
||||
Summary: Powerful light-weight programming language
|
||||
Group: Development/Languages
|
||||
License: MIT
|
||||
@ -34,10 +34,6 @@ Patch6: %{name}-5.2.2-idsize.patch
|
||||
Patch7: %{name}-5.2.2-luac-shared-link-fix.patch
|
||||
Patch8: %{name}-5.2.2-configure-compat-module.patch
|
||||
%endif
|
||||
# https://www.lua.org/bugs.html#5.3.3-1
|
||||
Patch9: lua-5.3.3-upstream-bug-1.patch
|
||||
# https://www.lua.org/bugs.html#5.3.3-2
|
||||
Patch10: lua-5.3.3-upstream-bug-2.patch
|
||||
|
||||
BuildRequires: automake autoconf libtool readline-devel ncurses-devel
|
||||
Provides: lua(abi) = %{major_version}
|
||||
@ -90,8 +86,6 @@ mv src/luaconf.h src/luaconf.h.template.in
|
||||
#%% patch2 -p1 -z .luac-shared
|
||||
%patch3 -p1 -z .configure-linux
|
||||
%patch4 -p1 -z .configure-compat-all
|
||||
%patch9 -p1 -b .crashfix
|
||||
%patch10 -p1 -b .readpast
|
||||
autoreconf -i
|
||||
|
||||
%if 0%{?bootstrap}
|
||||
@ -208,6 +202,9 @@ popd
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Feb 9 2017 Tom Callaway <spot@fedoraproject.org> 5.3.4-1
|
||||
- update to 5.3.4
|
||||
|
||||
* Thu Jan 12 2017 Igor Gnatenko <ignatenko@redhat.com> - 5.3.3-4
|
||||
- Rebuild for readline 7.x
|
||||
|
||||
|
6
sources
6
sources
@ -1,3 +1,3 @@
|
||||
dc7f94ec6ff15c985d2d6ad0f1b35654 lua-5.2.3.tar.gz
|
||||
703f75caa4fdf4a911c1a72e67a27498 lua-5.3.3.tar.gz
|
||||
76f4fb07f2a4970d554645ac26df86df lua-5.3.3-tests.tar.gz
|
||||
SHA512 (lua-5.2.3.tar.gz) = 264bb7c8db2f190ef0ca38584ec81999ab588f54e03119c5214c40bb8925b0eb407fac483a03e40cc8a220f6748ddff7d3a7392da3803418276b0d263b866449
|
||||
SHA512 (lua-5.3.4.tar.gz) = 739e31f82e6a60fa99910c2005e991b3a1e21339af52847f653cb190b30842054d189ca116ffcfdf9b36e07888c9ce5642b1dd2988cc7eff9f8789f9a2e34997
|
||||
SHA512 (lua-5.3.4-tests.tar.gz) = 79575d100a2efabc8243f55b55d912443e09ef7e8b0219cb93541d85c2ba802fb9538015e1228703f09ca57bdb28a640a8f1fa0735716ba1e4bca2179c712dfb
|
||||
|
Loading…
Reference in New Issue
Block a user