fix merge
This commit is contained in:
commit
b33e237d80
2
.gitignore
vendored
2
.gitignore
vendored
@ -7,3 +7,5 @@ lua-5.1.4/
|
||||
/lua-5.2.2.tar.gz
|
||||
/lua-5.2.3.tar.gz
|
||||
/lua-5.3.0.tar.gz
|
||||
/lua-5.3.2-tests.tar.gz
|
||||
/lua-5.3.2.tar.gz
|
||||
|
21
Makefile
21
Makefile
@ -1,21 +0,0 @@
|
||||
# Makefile for source rpm: lua
|
||||
# $Id$
|
||||
NAME := lua
|
||||
SPECFILE = $(firstword $(wildcard *.spec))
|
||||
|
||||
define find-makefile-common
|
||||
for d in common ../common ../../common ; do if [ -f $$d/Makefile.common ] ; then if [ -f $$d/CVS/Root -a -w $$d/Makefile.common ] ; then cd $$d ; cvs -Q update ; fi ; echo "$$d/Makefile.common" ; break ; fi ; done
|
||||
endef
|
||||
|
||||
MAKEFILE_COMMON := $(shell $(find-makefile-common))
|
||||
|
||||
ifeq ($(MAKEFILE_COMMON),)
|
||||
# attept a checkout
|
||||
define checkout-makefile-common
|
||||
test -f CVS/Root && { cvs -Q -d $$(cat CVS/Root) checkout common && echo "common/Makefile.common" ; } || { echo "ERROR: I can't figure out how to checkout the 'common' module." ; exit -1 ; } >&2
|
||||
endef
|
||||
|
||||
MAKEFILE_COMMON := $(shell $(checkout-makefile-common))
|
||||
endif
|
||||
|
||||
include $(MAKEFILE_COMMON)
|
@ -1,204 +0,0 @@
|
||||
diff --git a/Makefile.am b/Makefile.am
|
||||
new file mode 100644
|
||||
index 0000000..8d968c4
|
||||
--- /dev/null
|
||||
+++ b/Makefile.am
|
||||
@@ -0,0 +1,3 @@
|
||||
+SUBDIRS = src doc
|
||||
+
|
||||
+EXTRA_DIST = README
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
new file mode 100644
|
||||
index 0000000..3af6625
|
||||
--- /dev/null
|
||||
+++ b/configure.ac
|
||||
@@ -0,0 +1,69 @@
|
||||
+AC_PREREQ(2.59)
|
||||
+AC_INIT([lua], [5.2.2], [https://bugzilla.redhat.com/], [lua-at], [http://www.lua.org])
|
||||
+AC_SUBST([MAJOR_VERSION], [5.2])
|
||||
+
|
||||
+AC_CONFIG_HEADERS([config.h])
|
||||
+AC_CONFIG_SRCDIR([src/lapi.c])
|
||||
+
|
||||
+AM_INIT_AUTOMAKE([1.9 foreign])
|
||||
+
|
||||
+AC_PROG_CC
|
||||
+AC_PROG_LIBTOOL
|
||||
+
|
||||
+AC_ARG_WITH(
|
||||
+ [readline],
|
||||
+ [AC_HELP_STRING([--with-readline], [Use readline for interpreter input [default=yes]])],
|
||||
+ [use_readline=$withval],
|
||||
+ [use_readline=yes]
|
||||
+)
|
||||
+
|
||||
+LUA_LIBS="-lm"
|
||||
+
|
||||
+# Check for readline
|
||||
+READLINE_DEFS="#undef LUA_USE_READLINE"
|
||||
+if test "x$use_readline" == "xyes"; then
|
||||
+ AC_CHECK_LIB([readline], [readline], [:], [use_readline=no], [-lncurses])
|
||||
+ AC_CHECK_HEADERS([readline/readline.h readline/history.h], [], [use_readline=no])
|
||||
+ if test "x$use_readline" == "xno"; then
|
||||
+ AC_MSG_WARN([readline headers could not be found, disabling readline support])
|
||||
+ else
|
||||
+ READLINE_DEFS="#define LUA_USE_READLINE"
|
||||
+ READLINE_LIBS="-lreadline -lncurses"
|
||||
+ fi
|
||||
+fi
|
||||
+AC_SUBST(READLINE_DEFS)
|
||||
+AC_SUBST(READLINE_LIBS)
|
||||
+
|
||||
+case "$host" in
|
||||
+ *-mingw*) use_os=win32 ;;
|
||||
+ *-darwin*) use_os=macosx ;;
|
||||
+ *) use_os=posix ;;
|
||||
+esac
|
||||
+
|
||||
+POSIX_DEFS="#undef LUA_USE_POSIX"
|
||||
+LUA_DL_DEFS="#undef LUA_USE_DLOPEN"
|
||||
+LUA_BUILD_AS_DLL_DEFS="#undef LUA_BUILD_AS_DLL"
|
||||
+
|
||||
+if test "x$use_os" == "xwin32"; then
|
||||
+ LUA_BUILD_AS_DLL_DEFS="#define LUA_BUILD_AS_DLL"
|
||||
+elif test "x$use_os" == "xmacosx"; then
|
||||
+ POSIX_DEFS="#define LUA_USE_POSIX"
|
||||
+ LUA_DL_DEFS="#define LUA_DL_DYLD"
|
||||
+elif test "x$use_os" == "xposix"; then
|
||||
+ POSIX_DEFS="#define LUA_USE_POSIX"
|
||||
+ LUA_DL_DEFS="#define LUA_DL_DLOPEN"
|
||||
+ LUA_LIBS="$LUA_LIBS -ldl"
|
||||
+fi
|
||||
+AC_SUBST(POSIX_DEFS)
|
||||
+AC_SUBST(LUA_DL_DEFS)
|
||||
+AC_SUBST(LUA_BUILD_AS_DLL_DEFS)
|
||||
+
|
||||
+AC_SUBST(LUA_LIBS)
|
||||
+
|
||||
+AC_CONFIG_FILES([Makefile
|
||||
+ src/Makefile
|
||||
+ src/lua.pc
|
||||
+ src/luaconf.h.template
|
||||
+ doc/Makefile
|
||||
+])
|
||||
+AC_OUTPUT
|
||||
diff --git a/doc/Makefile.am b/doc/Makefile.am
|
||||
new file mode 100644
|
||||
index 0000000..3705696
|
||||
--- /dev/null
|
||||
+++ b/doc/Makefile.am
|
||||
@@ -0,0 +1,4 @@
|
||||
+man1_MANS = lua.1 luac.1
|
||||
+
|
||||
+EXTRA_DIST = \
|
||||
+ contents.html logo.gif lua.1 luac.1 lua.css manual.css manual.html osi-certified-72x60.png readme.html
|
||||
diff --git a/src/.gitignore b/src/.gitignore
|
||||
new file mode 100644
|
||||
index 0000000..0abd9dd
|
||||
--- /dev/null
|
||||
+++ b/src/.gitignore
|
||||
@@ -0,0 +1,5 @@
|
||||
+lua
|
||||
+lua.pc
|
||||
+luac
|
||||
+luaconf.h
|
||||
+luaconf.h.template
|
||||
diff --git a/src/Makefile.am b/src/Makefile.am
|
||||
new file mode 100644
|
||||
index 0000000..6c7c79f
|
||||
--- /dev/null
|
||||
+++ b/src/Makefile.am
|
||||
@@ -0,0 +1,46 @@
|
||||
+AM_CFLAGS = -Wall
|
||||
+
|
||||
+include_HEADERS = lua.h lualib.h lauxlib.h lua.hpp
|
||||
+
|
||||
+nodist_include_HEADERS = luaconf.h
|
||||
+
|
||||
+lib_LTLIBRARIES = liblua.la
|
||||
+liblua_la_LDFLAGS = -release @MAJOR_VERSION@
|
||||
+liblua_la_SOURCES = \
|
||||
+ lapi.c lauxlib.c lbaselib.c lbitlib.c lcode.c lcorolib.c lctype.c ldblib.c \
|
||||
+ ldebug.c ldo.c ldump.c lfunc.c lgc.c linit.c liolib.c llex.c lmathlib.c lmem.c \
|
||||
+ loadlib.c lobject.c lopcodes.c loslib.c lparser.c lstate.c lstring.c lstrlib.c \
|
||||
+ ltable.c ltablib.c ltm.c lundump.c lvm.c lzio.c \
|
||||
+ lapi.h lcode.h lctype.h ldebug.h ldo.h lfunc.h lgc.h llex.h llimits.h \
|
||||
+ lmem.h lobject.h lopcodes.h lparser.h lstate.h lstring.h ltable.h ltm.h \
|
||||
+ lundump.h lvm.h lzio.h
|
||||
+
|
||||
+pkgconfigdir = $(libdir)/pkgconfig
|
||||
+pkgconfig_DATA = lua.pc
|
||||
+
|
||||
+bin_PROGRAMS = lua luac
|
||||
+
|
||||
+lua_SOURCES = lua.c
|
||||
+lua_LDADD = liblua.la @LUA_LIBS@ @READLINE_LIBS@
|
||||
+lua_DEPENDENCIES = liblua.la
|
||||
+
|
||||
+luac_SOURCES = luac.c
|
||||
+# Statically link liblua against luac since luac uses symbols not exported in liblua
|
||||
+luac_LDADD = .libs/liblua.a @LUA_LIBS@
|
||||
+luac_DEPENDENCIES = liblua.la
|
||||
+
|
||||
+EXTRA_DIST = luaconf.h.template
|
||||
+BUILT_SOURCES = luaconf.h
|
||||
+CLEANFILES = luaconf.h luaconf.h.template
|
||||
+
|
||||
+readline_defs = @READLINE_DEFS@
|
||||
+
|
||||
+edit = sed \
|
||||
+ -e 's,%prefix%,$(prefix),g' \
|
||||
+ -e 's,%lua_datadir%,$(datadir),g' \
|
||||
+ -e 's,%lua_libdir%,$(libdir),g'
|
||||
+
|
||||
+luaconf.h : luaconf.h.template
|
||||
+ rm -f $@ $@.tmp
|
||||
+ $(edit) $< >$@.tmp
|
||||
+ mv $@.tmp $@
|
||||
diff --git a/src/lua.pc.in b/src/lua.pc.in
|
||||
new file mode 100644
|
||||
index 0000000..25faa8d
|
||||
--- /dev/null
|
||||
+++ b/src/lua.pc.in
|
||||
@@ -0,0 +1,13 @@
|
||||
+V= @MAJOR_VERSION@
|
||||
+R= @VERSION@
|
||||
+prefix= @prefix@
|
||||
+exec_prefix=${prefix}
|
||||
+libdir= @libdir@
|
||||
+includedir=${prefix}/include
|
||||
+
|
||||
+Name: Lua
|
||||
+Description: An Extensible Extension Language
|
||||
+Version: ${R}
|
||||
+Requires:
|
||||
+Libs: -llua @LUA_LIBS@
|
||||
+Cflags: -I${includedir}
|
||||
diff --git a/src/luaconf.h b/src/luaconf.h.template.in
|
||||
--- a/src/luaconf.h.template.in
|
||||
+++ b/src/luaconf.h.template.in
|
||||
@@ -11,6 +11,11 @@
|
||||
#include <limits.h>
|
||||
#include <stddef.h>
|
||||
|
||||
+@POSIX_DEFS@
|
||||
+@LUA_DL_DEFS@
|
||||
+@LUA_BUILD_AS_DLL_DEFS@
|
||||
+@READLINE_DEFS@
|
||||
+
|
||||
|
||||
/*
|
||||
** ==================================================================
|
||||
@@ -100,9 +105,9 @@
|
||||
#else /* }{ */
|
||||
|
||||
#define LUA_VDIR LUA_VERSION_MAJOR "." LUA_VERSION_MINOR "/"
|
||||
-#define LUA_ROOT "/usr/local/"
|
||||
-#define LUA_LDIR LUA_ROOT "share/lua/" LUA_VDIR
|
||||
-#define LUA_CDIR LUA_ROOT "lib/lua/" LUA_VDIR
|
||||
+#define LUA_ROOT "@prefix@/"
|
||||
+#define LUA_LDIR "@pkgdatadir@/lua/" LUA_VDIR
|
||||
+#define LUA_CDIR "@libdir@/lua/" LUA_VDIR
|
||||
#define LUA_PATH_DEFAULT \
|
||||
LUA_LDIR"?.lua;" LUA_LDIR"?/init.lua;" \
|
||||
LUA_CDIR"?.lua;" LUA_CDIR"?/init.lua;" "./?.lua"
|
@ -1,12 +0,0 @@
|
||||
diff -up lua-5.2.3/src/lgc.c.ephemeronfix lua-5.2.3/src/lgc.c
|
||||
--- lua-5.2.3/src/lgc.c.ephemeronfix 2014-12-10 16:15:14.482402404 -0500
|
||||
+++ lua-5.2.3/src/lgc.c 2014-12-10 16:15:49.715167635 -0500
|
||||
@@ -403,7 +403,7 @@ static int traverseephemeron (global_Sta
|
||||
reallymarkobject(g, gcvalue(gval(n))); /* mark it now */
|
||||
}
|
||||
}
|
||||
- if (prop)
|
||||
+ if (g->gcstate != GCSatomic || prop)
|
||||
linktable(h, &g->ephemeron); /* have to propagate again */
|
||||
else if (hasclears) /* does table have white keys? */
|
||||
linktable(h, &g->allweak); /* may have to clean white keys */
|
@ -1,54 +0,0 @@
|
||||
diff -up lua-5.3.0/src/lopcodes.c.luac-shared lua-5.3.0/src/lopcodes.c
|
||||
--- lua-5.3.0/src/lopcodes.c.luac-shared 2015-01-05 08:48:33.000000000 -0500
|
||||
+++ lua-5.3.0/src/lopcodes.c 2015-01-15 10:24:16.014509744 -0500
|
||||
@@ -17,7 +17,7 @@
|
||||
|
||||
/* ORDER OP */
|
||||
|
||||
-LUAI_DDEF const char *const luaP_opnames[NUM_OPCODES+1] = {
|
||||
+LUA_API const char *const luaP_opnames[NUM_OPCODES+1] = {
|
||||
"MOVE",
|
||||
"LOADK",
|
||||
"LOADKX",
|
||||
@@ -71,7 +71,7 @@ LUAI_DDEF const char *const luaP_opnames
|
||||
|
||||
#define opmode(t,a,b,c,m) (((t)<<7) | ((a)<<6) | ((b)<<4) | ((c)<<2) | (m))
|
||||
|
||||
-LUAI_DDEF const lu_byte luaP_opmodes[NUM_OPCODES] = {
|
||||
+LUA_API const lu_byte luaP_opmodes[NUM_OPCODES] = {
|
||||
/* T A B C mode opcode */
|
||||
opmode(0, 1, OpArgR, OpArgN, iABC) /* OP_MOVE */
|
||||
,opmode(0, 1, OpArgK, OpArgN, iABx) /* OP_LOADK */
|
||||
diff -up lua-5.3.0/src/lopcodes.h.luac-shared lua-5.3.0/src/lopcodes.h
|
||||
--- lua-5.3.0/src/lopcodes.h.luac-shared 2014-10-25 07:50:46.000000000 -0400
|
||||
+++ lua-5.3.0/src/lopcodes.h 2015-01-15 10:24:16.015509738 -0500
|
||||
@@ -276,7 +276,7 @@ enum OpArgMask {
|
||||
OpArgK /* argument is a constant or register/constant */
|
||||
};
|
||||
|
||||
-LUAI_DDEC const lu_byte luaP_opmodes[NUM_OPCODES];
|
||||
+LUA_API const lu_byte luaP_opmodes[NUM_OPCODES];
|
||||
|
||||
#define getOpMode(m) (cast(enum OpMode, luaP_opmodes[m] & 3))
|
||||
#define getBMode(m) (cast(enum OpArgMask, (luaP_opmodes[m] >> 4) & 3))
|
||||
@@ -285,7 +285,7 @@ LUAI_DDEC const lu_byte luaP_opmodes[NUM
|
||||
#define testTMode(m) (luaP_opmodes[m] & (1 << 7))
|
||||
|
||||
|
||||
-LUAI_DDEC const char *const luaP_opnames[NUM_OPCODES+1]; /* opcode names */
|
||||
+LUA_API const char *const luaP_opnames[NUM_OPCODES+1]; /* opcode names */
|
||||
|
||||
|
||||
/* number of list items to accumulate before a SETLIST instruction */
|
||||
diff -up lua-5.3.0/src/lundump.h.luac-shared lua-5.3.0/src/lundump.h
|
||||
--- lua-5.3.0/src/lundump.h.luac-shared 2015-01-15 10:24:16.015509738 -0500
|
||||
+++ lua-5.3.0/src/lundump.h 2015-01-15 10:25:12.651209770 -0500
|
||||
@@ -27,7 +27,7 @@ LUAI_FUNC LClosure* luaU_undump (lua_Sta
|
||||
const char* name);
|
||||
|
||||
/* dump one chunk; from ldump.c */
|
||||
-LUAI_FUNC int luaU_dump (lua_State* L, const Proto* f, lua_Writer w,
|
||||
+LUA_API int luaU_dump (lua_State* L, const Proto* f, lua_Writer w,
|
||||
void* data, int strip);
|
||||
|
||||
#endif
|
67
lua.spec
67
lua.spec
@ -8,7 +8,7 @@
|
||||
|
||||
|
||||
Name: lua
|
||||
Version: %{major_version}.0
|
||||
Version: %{major_version}.2
|
||||
Release: 2%{?dist}
|
||||
Summary: Powerful light-weight programming language
|
||||
Group: Development/Languages
|
||||
@ -16,20 +16,23 @@ License: MIT
|
||||
URL: http://www.lua.org/
|
||||
Source0: http://www.lua.org/ftp/lua-%{version}.tar.gz
|
||||
# copied from doc/readme.html on 2014-07-18
|
||||
Source1: mit.txt
|
||||
Source1: mit.txt
|
||||
%if 0%{?bootstrap}
|
||||
Source2: http://www.lua.org/ftp/lua-%{bootstrap_version}.tar.gz
|
||||
Source2: http://www.lua.org/ftp/lua-%{bootstrap_version}.tar.gz
|
||||
%endif
|
||||
Source3: http://www.lua.org/tests/lua-%{version}-tests.tar.gz
|
||||
# multilib
|
||||
Source4: luaconf.h
|
||||
Patch0: %{name}-5.3.0-autotoolize.patch
|
||||
Patch1: %{name}-5.3.0-idsize.patch
|
||||
Patch2: %{name}-5.3.0-luac-shared-link-fix.patch
|
||||
#Patch2: %%{name}-5.3.0-luac-shared-link-fix.patch
|
||||
Patch3: %{name}-5.2.2-configure-linux.patch
|
||||
Patch4: %{name}-5.3.0-configure-compat-module.patch
|
||||
Patch4: %{name}-5.3.0-configure-compat-module.patch
|
||||
%if 0%{?bootstrap}
|
||||
Patch5: %{name}-5.2.3-autotoolize.patch
|
||||
Patch6: %{name}-5.2.2-idsize.patch
|
||||
Patch7: %{name}-5.2.2-luac-shared-link-fix.patch
|
||||
Patch8: %{name}-5.2.2-configure-compat-module.patch
|
||||
Patch5: %{name}-5.2.3-autotoolize.patch
|
||||
Patch6: %{name}-5.2.2-idsize.patch
|
||||
Patch7: %{name}-5.2.2-luac-shared-link-fix.patch
|
||||
Patch8: %{name}-5.2.2-configure-compat-module.patch
|
||||
%endif
|
||||
|
||||
BuildRequires: automake autoconf libtool readline-devel ncurses-devel
|
||||
@ -64,12 +67,12 @@ This package contains the static version of liblua for %{name}.
|
||||
|
||||
|
||||
%prep
|
||||
%setup -q -a 2
|
||||
%setup -q -a 2 -a 3
|
||||
cp %{SOURCE1} .
|
||||
mv src/luaconf.h src/luaconf.h.template.in
|
||||
%patch0 -p1 -E -z .autoxxx
|
||||
%patch1 -p1 -z .idsize
|
||||
%patch2 -p1 -z .luac-shared
|
||||
#%% patch2 -p1 -z .luac-shared
|
||||
%patch3 -p1 -z .configure-linux
|
||||
%patch4 -p1 -z .configure-compat-all
|
||||
autoreconf -i
|
||||
@ -96,7 +99,8 @@ sed -i 's|@pkgdatadir@|%{_datadir}|g' src/luaconf.h.template
|
||||
|
||||
# hack so that only /usr/bin/lua gets linked with readline as it is the
|
||||
# only one which needs this and otherwise we get License troubles
|
||||
make %{?_smp_mflags} LIBS="-lm -ldl" luac_LDADD="liblua.la -lm -ldl"
|
||||
make %{?_smp_mflags} LIBS="-lm -ldl"
|
||||
# only /usr/bin/lua links with readline now #luac_LDADD="liblua.la -lm -ldl"
|
||||
|
||||
%if 0%{?bootstrap}
|
||||
pushd lua-%{bootstrap_version}
|
||||
@ -112,12 +116,36 @@ make %{?_smp_mflags} LIBS="-lm -ldl" luac_LDADD="liblua.la -lm -ldl"
|
||||
popd
|
||||
%endif
|
||||
|
||||
%check
|
||||
cd ./lua-%{version}-tests/
|
||||
|
||||
# Dont skip the fully portable or ram-hungry tests:
|
||||
# sed -i.orig -e '
|
||||
# /attrib.lua/d;
|
||||
# /files.lua/d;
|
||||
# /db.lua/d;
|
||||
# /errors.lua/d;
|
||||
# ' all.lua
|
||||
# LD_LIBRARY_PATH=$RPM_BUILD_ROOT/%{_libdir} $RPM_BUILD_ROOT/%{_bindir}/lua all.lua
|
||||
|
||||
# Removing tests that fail under mock/koji
|
||||
sed -i.orig -e '
|
||||
/db.lua/d;
|
||||
/errors.lua/d;
|
||||
' all.lua
|
||||
LD_LIBRARY_PATH=$RPM_BUILD_ROOT/%{_libdir} $RPM_BUILD_ROOT/%{_bindir}/lua -e"_U=true" all.lua
|
||||
|
||||
%install
|
||||
make install DESTDIR=$RPM_BUILD_ROOT
|
||||
rm $RPM_BUILD_ROOT%{_libdir}/*.la
|
||||
mkdir -p $RPM_BUILD_ROOT%{_libdir}/lua/%{major_version}
|
||||
mkdir -p $RPM_BUILD_ROOT%{_datadir}/lua/%{major_version}
|
||||
|
||||
# Rename luaconf.h to luaconf-<arch>.h to avoid file conflicts on
|
||||
# multilib systems and install luaconf.h wrapper
|
||||
mv %{buildroot}%{_includedir}/luaconf.h %{buildroot}%{_includedir}/luaconf-%{_arch}.h
|
||||
install -p -m 644 %{SOURCE4} %{buildroot}%{_includedir}/luaconf.h
|
||||
|
||||
%if 0%{?bootstrap}
|
||||
pushd lua-%{bootstrap_version}
|
||||
mkdir $RPM_BUILD_ROOT/installdir
|
||||
@ -159,9 +187,22 @@ popd
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Mar 20 2015 Kalev Lember <kalevlember@gmail.com> - 5.3.0-2
|
||||
* Fri Dec 11 2015 Tom Callaway <spot@fedoraproject.org> - 5.3.2-2
|
||||
- fix multilib support (#1229992)
|
||||
|
||||
* Fri Dec 11 2015 "D. Johnson" <fenris02@fedoraproject.org> - 5.3.2-1
|
||||
- Update to 5.3.2 (#1039249,1173984)
|
||||
|
||||
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.0-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Fri Mar 20 2015 Kalev Lember <kalevlember@gmail.com> - 5.3.0-3
|
||||
- Define LUA_COMPAT_5_2 in addition to LUA_COMPAT_5_1 (#1204129)
|
||||
|
||||
* Sat Feb 21 2015 Till Maas <opensource@till.name> - 5.3.0-2
|
||||
- Rebuilt for Fedora 23 Change
|
||||
https://fedoraproject.org/wiki/Changes/Harden_all_packages_with_position-independent_code
|
||||
|
||||
* Thu Jan 15 2015 Tom Callaway <spot@fedoraproject.org> - 5.3.0-1
|
||||
- update to 5.3.0
|
||||
- add bootstrapping glue
|
||||
|
59
luaconf.h
Normal file
59
luaconf.h
Normal file
@ -0,0 +1,59 @@
|
||||
/*
|
||||
* This luaconf.h is a wrapper include file for the original luaconf.h,
|
||||
* which has been renamed to luaconf-<arch>.h. There are conflicts for the
|
||||
* original luaconf.h on multilib systems, which result from arch-specific
|
||||
* configuration options. Please do not use the arch-specific file directly.
|
||||
*
|
||||
* Copyright (C) 2015 Tom Callaway <spot@fedoraproject.org>
|
||||
*/
|
||||
|
||||
/**
|
||||
* \file luaconf.h
|
||||
*/
|
||||
|
||||
#ifdef luaconf_wrapper_h
|
||||
#error "luaconf_wrapper_h should not be defined!"
|
||||
#endif
|
||||
#define luaconf_wrapper_h
|
||||
|
||||
#if defined(__i386__)
|
||||
#include "luaconf-i386.h"
|
||||
#elif defined(__ia64__)
|
||||
#include "luaconf-ia64.h"
|
||||
#elif defined(__powerpc64__)
|
||||
# if __BYTE_ORDER__ == __ORDER_BIG_ENDIAN__
|
||||
#include "luaconf-ppc64.h"
|
||||
# else
|
||||
#include "luaconf-ppc64le.h"
|
||||
# endif
|
||||
#elif defined(__powerpc__)
|
||||
#include "luaconf-ppc.h"
|
||||
#elif defined(__s390x__)
|
||||
#include "luaconf-s390x.h"
|
||||
#elif defined(__s390__)
|
||||
#include "luaconf-s390.h"
|
||||
#elif defined(__x86_64__)
|
||||
#include "luaconf-x86_64.h"
|
||||
#elif defined(__arm__)
|
||||
#include "luaconf-arm.h"
|
||||
#elif defined(__alpha__)
|
||||
#include "luaconf-alpha.h"
|
||||
#elif defined(__sparc__) && defined (__arch64__)
|
||||
#include "luaconf-sparc64.h"
|
||||
#elif defined(__sparc__)
|
||||
#include "luaconf-sparc.h"
|
||||
#elif defined(__aarch64__)
|
||||
#include "luaconf-aarch64.h"
|
||||
#elif defined(__mips64) && defined(__MIPSEL__)
|
||||
#include "luaconf-mips64el.h"
|
||||
#elif defined(__mips64)
|
||||
#include "luaconf-mips64.h"
|
||||
#elif defined(__mips) && defined(__MIPSEL__)
|
||||
#include "luaconf-mipsel.h"
|
||||
#elif defined(__mips)
|
||||
#include "luaconf-mips.h"
|
||||
#else
|
||||
#error "The lua-devel package is not usable with the architecture."
|
||||
#endif
|
||||
|
||||
#undef luaconf_wrapper_h
|
Loading…
Reference in New Issue
Block a user