5.2.3
This commit is contained in:
parent
f76e1fe1c7
commit
80674c8fe9
12
lua-5.2.3-ephemeronfix.patch
Normal file
12
lua-5.2.3-ephemeronfix.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -up lua-5.2.3/src/lgc.c.ephemeronfix lua-5.2.3/src/lgc.c
|
||||
--- lua-5.2.3/src/lgc.c.ephemeronfix 2014-12-10 16:15:14.482402404 -0500
|
||||
+++ lua-5.2.3/src/lgc.c 2014-12-10 16:15:49.715167635 -0500
|
||||
@@ -403,7 +403,7 @@ static int traverseephemeron (global_Sta
|
||||
reallymarkobject(g, gcvalue(gval(n))); /* mark it now */
|
||||
}
|
||||
}
|
||||
- if (prop)
|
||||
+ if (g->gcstate != GCSatomic || prop)
|
||||
linktable(h, &g->ephemeron); /* have to propagate again */
|
||||
else if (hasclears) /* does table have white keys? */
|
||||
linktable(h, &g->allweak); /* may have to clean white keys */
|
20
lua.spec
20
lua.spec
@ -1,8 +1,8 @@
|
||||
%global major_version 5.2
|
||||
|
||||
Name: lua
|
||||
Version: %{major_version}.2
|
||||
Release: 8%{?dist}
|
||||
Version: %{major_version}.3
|
||||
Release: 1%{?dist}
|
||||
Summary: Powerful light-weight programming language
|
||||
Group: Development/Languages
|
||||
License: MIT
|
||||
@ -10,11 +10,13 @@ URL: http://www.lua.org/
|
||||
Source0: http://www.lua.org/ftp/lua-%{version}.tar.gz
|
||||
# copied from doc/readme.html on 2014-07-18
|
||||
Source1: mit.txt
|
||||
Patch0: %{name}-%{version}-autotoolize.patch
|
||||
Patch1: %{name}-%{version}-idsize.patch
|
||||
Patch2: %{name}-%{version}-luac-shared-link-fix.patch
|
||||
Patch3: %{name}-%{version}-configure-linux.patch
|
||||
Patch4: %{name}-%{version}-configure-compat-module.patch
|
||||
Patch0: %{name}-5.2.2-autotoolize.patch
|
||||
Patch1: %{name}-5.2.2-idsize.patch
|
||||
Patch2: %{name}-5.2.2-luac-shared-link-fix.patch
|
||||
Patch3: %{name}-5.2.2-configure-linux.patch
|
||||
Patch4: %{name}-5.2.2-configure-compat-module.patch
|
||||
# http://www.lua.org/bugs.html
|
||||
Patch5: lua-5.2.3-ephemeronfix.patch
|
||||
BuildRequires: automake autoconf libtool readline-devel ncurses-devel
|
||||
Provides: lua(abi) = %{major_version}
|
||||
|
||||
@ -55,6 +57,7 @@ mv src/luaconf.h src/luaconf.h.template.in
|
||||
%patch2 -p1 -z .luac-shared
|
||||
%patch3 -p1 -z .configure-linux
|
||||
%patch4 -p1 -z .configure-compat-all
|
||||
%patch5 -p1 -b .ephemeronfix
|
||||
autoreconf -i
|
||||
|
||||
|
||||
@ -101,6 +104,9 @@ mkdir -p $RPM_BUILD_ROOT%{_datadir}/lua/%{major_version}
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Dec 10 2014 Tom Callaway <spot@fedoraproject.org> - 5.2.3-1
|
||||
- update to 5.2.3
|
||||
|
||||
* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.2.2-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user