be655c46e5
- update to 3.3 - enable compiler-rt compilation, enables ASAN - add lldb sources (LLVM debugger) - clean up documentation - remove patches applied upstream - remove unused patches and snapshot scripts - place all documentation files in %install (%files seems to have some limit on number of files matched by * wildcard)
23 lines
651 B
Diff
23 lines
651 B
Diff
Preserve timestamps when installing data files
|
|
|
|
---
|
|
Makefile.rules | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/Makefile.rules b/Makefile.rules
|
|
index f0c542b..0ff92bb 100644
|
|
--- a/Makefile.rules
|
|
+++ b/Makefile.rules
|
|
@@ -773,7 +773,7 @@ BCCompile.CXX = $(LLVMCXX) $(CPP.Flags) $(CXX.Flags) $(CXXFLAGS) $(CPPFLAGS) \
|
|
|
|
ProgInstall = $(INSTALL) $(Install.StripFlag) -m 0755
|
|
ScriptInstall = $(INSTALL) -m 0755
|
|
-DataInstall = $(INSTALL) -m 0644
|
|
+DataInstall = $(INSTALL) -p -m 0644
|
|
|
|
# When compiling under Mingw/Cygwin, the tblgen tool expects Windows
|
|
# paths. In this case, the SYSPATH function (defined in
|
|
--
|
|
1.8.3.1
|
|
|