8150742540
Signed-off-by: Adam Jackson <ajax@redhat.com>
86 lines
2.9 KiB
Diff
86 lines
2.9 KiB
Diff
From e47eb279d50f38374a3f5b95a8c4bcc2112ed408 Mon Sep 17 00:00:00 2001
|
|
From: Tom Stellard <thomas.stellard@amd.com>
|
|
Date: Thu, 15 May 2014 00:15:27 +0000
|
|
Subject: [PATCH 2/5] Merging r208721:
|
|
|
|
------------------------------------------------------------------------
|
|
r208721 | thomas.stellard | 2014-05-13 15:37:03 -0400 (Tue, 13 May 2014) | 11 lines
|
|
|
|
autoconf: Fix soname for libLLVM-Major.Minor.so (2nd try)
|
|
|
|
We were using libLLVM-Major.Minor.Patch.so for the soname, but we
|
|
need the soname to stay consistent for all Major.Minor.* releases
|
|
otherwise operating system distributors will need to rebuild all
|
|
packages that link with LLVM every time there is a new point release.
|
|
|
|
This patch also reverses the compatibility symlink, so
|
|
libLLVM-Major.Minor.Patch.so is now a symlink that points
|
|
to libLLVM-Major-Minor.so.
|
|
|
|
------------------------------------------------------------------------
|
|
|
|
git-svn-id: https://llvm.org/svn/llvm-project/llvm/branches/release_34@208829 91177308-0d34-0410-b5e6-96231b3b80d8
|
|
---
|
|
Makefile.rules | 15 ++++++++++++---
|
|
tools/llvm-shlib/Makefile | 4 ++--
|
|
2 files changed, 14 insertions(+), 5 deletions(-)
|
|
|
|
diff --git a/Makefile.rules b/Makefile.rules
|
|
index 210abda..18882fa 100644
|
|
--- a/Makefile.rules
|
|
+++ b/Makefile.rules
|
|
@@ -1027,8 +1027,9 @@ ifeq ($(HOST_OS), $(filter $(HOST_OS), Cygwin MingW))
|
|
LLVMLibsOptions += -Wl,--enable-auto-import,--enable-runtime-pseudo-reloc \
|
|
-L $(SharedLibDir)
|
|
endif
|
|
-LLVMLibsOptions += -lLLVM-$(LLVMVersion)
|
|
-LLVMLibsPaths += $(SharedLibDir)/$(SharedPrefix)LLVM-$(LLVMVersion)$(SHLIBEXT)
|
|
+LLVM_SO_NAME = LLVM-$(LLVM_VERSION_MAJOR).$(LLVM_VERSION_MINOR)$(LLVM_VERSION_SUFFIX)
|
|
+LLVMLibsOptions += -l$(LLVM_SO_NAME)
|
|
+LLVMLibsPaths += $(SharedLibDir)/$(SharedPrefix)$(LLVM_SO_NAME)$(SHLIBEXT)
|
|
else
|
|
|
|
ifndef NO_LLVM_CONFIG
|
|
@@ -1144,7 +1145,12 @@ LibName.O := $(LibDir)/$(LIBRARYNAME).o
|
|
#---------------------------------------------------------
|
|
ifdef SHARED_LIBRARY
|
|
|
|
-all-local:: $(LibName.SO)
|
|
+all-local:: $(AliasName.SO)
|
|
+
|
|
+$(AliasName.SO): $(LibName.SO)
|
|
+ifdef SHARED_ALIAS
|
|
+ $(Verb) $(AliasTool) $(BaseLibName.SO) $(AliasName.SO)
|
|
+endif
|
|
|
|
ifdef EXPORTED_SYMBOL_FILE
|
|
$(LibName.SO): $(NativeExportsFile)
|
|
@@ -1202,6 +1208,9 @@ endif
|
|
uninstall-local::
|
|
$(Echo) Uninstalling $(BuildMode) Shared Library $(DestSharedLib)
|
|
-$(Verb) $(RM) -f $(DestSharedLib)
|
|
+ifdef SHARED_ALIAS
|
|
+ -$(Verb) $(RM) -f $(DestSharedAlias)
|
|
+endif
|
|
endif
|
|
endif
|
|
|
|
diff --git a/tools/llvm-shlib/Makefile b/tools/llvm-shlib/Makefile
|
|
index 4a0c2ea..b912ea6 100644
|
|
--- a/tools/llvm-shlib/Makefile
|
|
+++ b/tools/llvm-shlib/Makefile
|
|
@@ -9,8 +9,8 @@
|
|
|
|
LEVEL := ../..
|
|
|
|
-LIBRARYNAME = LLVM-$(LLVMVersion)
|
|
-LIBRARYALIASNAME = LLVM-$(LLVM_VERSION_MAJOR).$(LLVM_VERSION_MINOR)$(LLVM_VERSION_SUFFIX)
|
|
+LIBRARYNAME = LLVM-$(LLVM_VERSION_MAJOR).$(LLVM_VERSION_MINOR)$(LLVM_VERSION_SUFFIX)
|
|
+LIBRARYALIASNAME = LLVM-$(LLVMVersion)
|
|
|
|
NO_BUILD_ARCHIVE := 1
|
|
LINK_LIBS_IN_SHARED := 1
|
|
--
|
|
1.9.3
|
|
|