add fix for lldb out-of-tree build

This commit is contained in:
Dave Airlie 2016-10-26 10:47:35 +10:00
parent 44886631c9
commit f943e7f14b
2 changed files with 45 additions and 1 deletions

View File

@ -0,0 +1,39 @@
From fdda55bb968b2c39da76baa85a29114f53154944 Mon Sep 17 00:00:00 2001
From: Chris Bieneman <beanz@apple.com>
Date: Thu, 25 Aug 2016 20:53:00 +0000
Subject: [PATCH] cmake: Install CheckAtomic.cmake (needed by lldb)
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Summary:
Install CheckAtomic.cmake along with other LLVM modules, therefore making it possible for other projects to use it. This file is needed for LLDB to be built standalone, and installing it was suggested in https://reviews.llvm.org/D23881.
Patch by: Michał Górny
Reviewers: krytarowski, zturner, eugenis, jyknight, labath, beanz
Subscribers: beanz, llvm-commits
Differential Revision: https://reviews.llvm.org/D23887
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@279777 91177308-0d34-0410-b5e6-96231b3b80d8
---
cmake/modules/CMakeLists.txt | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/cmake/modules/CMakeLists.txt b/cmake/modules/CMakeLists.txt
index 826dd36..d2510b8 100644
--- a/cmake/modules/CMakeLists.txt
+++ b/cmake/modules/CMakeLists.txt
@@ -91,6 +91,5 @@ if (NOT LLVM_INSTALL_TOOLCHAIN_ONLY)
PATTERN LLVMConfig.cmake EXCLUDE
PATTERN LLVMConfigVersion.cmake EXCLUDE
PATTERN LLVM-Config.cmake EXCLUDE
- PATTERN GetHostTriple.cmake EXCLUDE
- PATTERN CheckAtomic.cmake EXCLUDE)
+ PATTERN GetHostTriple.cmake EXCLUDE)
endif()
--
2.5.5

View File

@ -7,7 +7,7 @@
Name: llvm
Version: 3.9.0
Release: 3%{?dist}
Release: 4%{?dist}
Summary: The Low Level Virtual Machine
License: NCSA
@ -23,6 +23,8 @@ Patch1: 0001-This-code-block-breaks-the-docs-build-http-lab.llvm..patch
Patch2: 0001-fix-docs-2.patch
Patch3: 0001-fix-docs-3.patch
Patch4: 0001-docs-fix-cmake-code-block-warning.patch
# backport from upstream to fix lldb out of tree
Patch5: 0001-cmake-Install-CheckAtomic.cmake-needed-by-lldb.patch
# backports cribbed from https://github.com/rust-lang/llvm/
Patch47: rust-lang-llvm-pr47.patch
@ -206,6 +208,9 @@ make check-all || :
%{_libdir}/*.a
%changelog
* Wed Oct 26 2016 Dave Airlie <airlied@redhat.com> - 3.9.0-4
- add fix for lldb out-of-tree build
* Mon Oct 17 2016 Josh Stone <jistone@redhat.com> - 3.9.0-3
- Apply backports from rust-lang/llvm#47, #48, #53, #54