- Update to final 2.7 release
This commit is contained in:
parent
36e6bc7ca8
commit
f2c3edf563
@ -1,2 +1,2 @@
|
||||
llvm-2.6.tar.gz
|
||||
clang-2.6.tar.gz
|
||||
clang-2.7.tgz
|
||||
llvm-2.7.tgz
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- llvm-2.5/configure.tclsh_check 2009-02-03 00:29:49.000000000 -0500
|
||||
+++ llvm-2.5/configure 2009-09-05 12:25:54.761389908 -0400
|
||||
@@ -8032,7 +8032,7 @@
|
||||
else
|
||||
|
||||
if test x"${with_tclinclude}" != x ; then
|
||||
- if test -f ${with_tclinclude}/tclsh ; then
|
||||
+ if test -f ${with_tclinclude}/tcl.h ; then
|
||||
ac_cv_path_tclsh=`(cd ${with_tclinclude}; pwd)`
|
||||
elif test -f ${with_tclinclude}/src/tclsh ; then
|
||||
ac_cv_path_tclsh=`(cd ${with_tclinclude}/src; pwd)`
|
@ -1,99 +0,0 @@
|
||||
From 01c48a60e0a3bcd2e4d6829f2f0186d4ee6ef504 Mon Sep 17 00:00:00 2001
|
||||
From: Erick Tryzelaar <erickt@pixar.com>
|
||||
Date: Fri, 21 Aug 2009 12:37:18 -0700
|
||||
Subject: [PATCH] Use LLVM's new DESTDIR-less PROJ_* variables.
|
||||
MIME-Version: 1.0
|
||||
Content-Type: multipart/mixed; boundary="------------1.6.4"
|
||||
|
||||
This is a multi-part message in MIME format.
|
||||
--------------1.6.4
|
||||
Content-Type: text/plain; charset=UTF-8; format=fixed
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
---
|
||||
docs/Makefile | 18 +++++++++---------
|
||||
docs/tools/Makefile | 6 +++---
|
||||
tools/clang-cc/Makefile | 2 +-
|
||||
3 files changed, 13 insertions(+), 13 deletions(-)
|
||||
|
||||
|
||||
--------------1.6.4
|
||||
Content-Type: text/x-patch; name="0001-Use-LLVM-s-new-DESTDIR-less-PROJ_-variables.patch"
|
||||
Content-Transfer-Encoding: 8bit
|
||||
Content-Disposition: attachment; filename="0001-Use-LLVM-s-new-DESTDIR-less-PROJ_-variables.patch"
|
||||
|
||||
diff --git docs/Makefile docs/Makefile
|
||||
index 9b706c7..e9bbb28 100644
|
||||
--- docs/Makefile
|
||||
+++ docs/Makefile
|
||||
@@ -48,11 +48,11 @@ generated:: doxygen
|
||||
|
||||
install-html: $(PROJ_OBJ_DIR)/html.tar.gz
|
||||
$(Echo) Installing HTML documentation
|
||||
- $(Verb) $(MKDIR) $(PROJ_docsdir)/html
|
||||
- $(Verb) $(MKDIR) $(PROJ_docsdir)/html/img
|
||||
- $(Verb) $(DataInstall) $(HTML) $(PROJ_docsdir)/html
|
||||
-# $(Verb) $(DataInstall) $(IMAGES) $(PROJ_docsdir)/html/img
|
||||
- $(Verb) $(DataInstall) $(PROJ_OBJ_DIR)/html.tar.gz $(PROJ_docsdir)
|
||||
+ $(Verb) $(MKDIR) $(DESTDIR)$(PROJ_docsdir)/html
|
||||
+ $(Verb) $(MKDIR) $(DESTDIR)$(PROJ_docsdir)/html/img
|
||||
+ $(Verb) $(DataInstall) $(HTML) $(DESTDIR)$(PROJ_docsdir)/html
|
||||
+# $(Verb) $(DataInstall) $(IMAGES) $(DESTDIR)$(PROJ_docsdir)/html/img
|
||||
+ $(Verb) $(DataInstall) $(PROJ_OBJ_DIR)/html.tar.gz $(DESTDIR)$(PROJ_docsdir)
|
||||
|
||||
$(PROJ_OBJ_DIR)/html.tar.gz: $(HTML)
|
||||
$(Echo) Packaging HTML documentation
|
||||
@@ -63,11 +63,11 @@ $(PROJ_OBJ_DIR)/html.tar.gz: $(HTML)
|
||||
|
||||
install-doxygen: doxygen
|
||||
$(Echo) Installing doxygen documentation
|
||||
- $(Verb) $(MKDIR) $(PROJ_docsdir)/html/doxygen
|
||||
- $(Verb) $(DataInstall) $(PROJ_OBJ_DIR)/doxygen.tar.gz $(PROJ_docsdir)
|
||||
+ $(Verb) $(MKDIR) $(DESTDIR)$(PROJ_docsdir)/html/doxygen
|
||||
+ $(Verb) $(DataInstall) $(PROJ_OBJ_DIR)/doxygen.tar.gz $(DESTDIR)$(PROJ_docsdir)
|
||||
$(Verb) cd $(PROJ_OBJ_DIR)/doxygen && \
|
||||
$(FIND) . -type f -exec \
|
||||
- $(DataInstall) {} $(PROJ_docsdir)/html/doxygen \;
|
||||
+ $(DataInstall) {} $(DESTDIR)$(PROJ_docsdir)/html/doxygen \;
|
||||
|
||||
doxygen: regendoc $(PROJ_OBJ_DIR)/doxygen.tar.gz
|
||||
|
||||
@@ -94,4 +94,4 @@ $(LLVM_SRC_ROOT)/docs/userloc.html:
|
||||
|
||||
uninstall-local::
|
||||
$(Echo) Uninstalling Documentation
|
||||
- $(Verb) $(RM) -rf $(PROJ_docsdir)
|
||||
+ $(Verb) $(RM) -rf $(DESTDIR)$(PROJ_docsdir)
|
||||
diff --git docs/tools/Makefile docs/tools/Makefile
|
||||
index 90eb776..8107754 100644
|
||||
--- docs/tools/Makefile
|
||||
+++ docs/tools/Makefile
|
||||
@@ -81,9 +81,9 @@ EXTRA_DIST := $(POD)
|
||||
clean-local::
|
||||
$(Verb) $(RM) -f pod2htm*.*~~ $(HTML) $(MAN) $(PS)
|
||||
|
||||
-HTML_DIR := $(PROJ_docsdir)/html/clang
|
||||
-MAN_DIR := $(PROJ_mandir)/man1
|
||||
-PS_DIR := $(PROJ_docsdir)/ps
|
||||
+HTML_DIR := $(DESTDIR)$(PROJ_docsdir)/html/clang
|
||||
+MAN_DIR := $(DESTDIR)$(PROJ_mandir)/man1
|
||||
+PS_DIR := $(DESTDIR)$(PROJ_docsdir)/ps
|
||||
|
||||
install-html:: $(HTML)
|
||||
$(Echo) Installing HTML Clang Tools Documentation
|
||||
diff --git tools/clang-cc/Makefile tools/clang-cc/Makefile
|
||||
index 874a42f..7c31f37 100644
|
||||
--- tools/clang-cc/Makefile
|
||||
+++ tools/clang-cc/Makefile
|
||||
@@ -27,6 +27,6 @@ USEDLIBS = clangFrontend.a clangCodeGen.a clangAnalysis.a \
|
||||
|
||||
# clang-cc lives in a special location; we can get away with this
|
||||
# because nothing else gets installed from here.
|
||||
-PROJ_bindir := $(DESTDIR)$(PROJ_prefix)/libexec
|
||||
+PROJ_bindir := $(PROJ_prefix)/libexec
|
||||
|
||||
include $(LLVM_SRC_ROOT)/Makefile.rules
|
||||
|
||||
--------------1.6.4--
|
||||
|
||||
|
@ -1,361 +0,0 @@
|
||||
From 5a380ce5d1c8d5a1474764a7a54a1e2072fddb03 Mon Sep 17 00:00:00 2001
|
||||
From: Erick Tryzelaar <idadesub@users.sourceforge.net>
|
||||
Date: Fri, 21 Aug 2009 11:59:01 -0700
|
||||
Subject: [PATCH] Rewrite makefiles to explicitly reference DESTDIR so we can not bake DESTDIR
|
||||
into the O'Caml symlinks.
|
||||
MIME-Version: 1.0
|
||||
Content-Type: multipart/mixed; boundary="------------1.6.4"
|
||||
|
||||
This is a multi-part message in MIME format.
|
||||
--------------1.6.4
|
||||
Content-Type: text/plain; charset=UTF-8; format=fixed
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
---
|
||||
Makefile.config.in | 16 +++++++-------
|
||||
Makefile.rules | 46 ++++++++++++++++++++++----------------------
|
||||
docs/CommandGuide/Makefile | 6 ++--
|
||||
docs/Makefile | 24 +++++++++++-----------
|
||||
docs/tutorial/Makefile | 2 +-
|
||||
lib/VMCore/Makefile | 4 +-
|
||||
tools/gccas/Makefile | 4 +-
|
||||
tools/gccld/Makefile | 4 +-
|
||||
tools/llvm-config/Makefile | 4 +-
|
||||
9 files changed, 55 insertions(+), 55 deletions(-)
|
||||
|
||||
|
||||
--------------1.6.4
|
||||
Content-Type: text/x-patch; name="0001-Rewrite-makefiles-to-explicitly-reference-DESTDIR-so.patch"
|
||||
Content-Transfer-Encoding: 8bit
|
||||
Content-Disposition: attachment; filename="0001-Rewrite-makefiles-to-explicitly-reference-DESTDIR-so.patch"
|
||||
|
||||
diff --git Makefile.config.in Makefile.config.in
|
||||
index ecd0595..73656f7 100644
|
||||
--- Makefile.config.in
|
||||
+++ Makefile.config.in
|
||||
@@ -76,14 +76,14 @@ endif
|
||||
|
||||
LLVMMAKE := $(LLVM_SRC_ROOT)/make
|
||||
|
||||
-PROJ_bindir := $(DESTDIR)$(PROJ_prefix)/bin
|
||||
-PROJ_libdir := $(DESTDIR)$(PROJ_prefix)/lib
|
||||
-PROJ_datadir := $(DESTDIR)$(PROJ_prefix)/share
|
||||
-PROJ_docsdir := $(DESTDIR)$(PROJ_prefix)/docs/llvm
|
||||
-PROJ_etcdir := $(DESTDIR)$(PROJ_prefix)/etc/llvm
|
||||
-PROJ_includedir := $(DESTDIR)$(PROJ_prefix)/include
|
||||
-PROJ_infodir := $(DESTDIR)$(PROJ_prefix)/info
|
||||
-PROJ_mandir := $(DESTDIR)$(PROJ_prefix)/share/man
|
||||
+PROJ_bindir := $(PROJ_prefix)/bin
|
||||
+PROJ_libdir := $(PROJ_prefix)/lib
|
||||
+PROJ_datadir := $(PROJ_prefix)/share
|
||||
+PROJ_docsdir := $(PROJ_prefix)/docs/llvm
|
||||
+PROJ_etcdir := $(PROJ_prefix)/etc/llvm
|
||||
+PROJ_includedir := $(PROJ_prefix)/include
|
||||
+PROJ_infodir := $(PROJ_prefix)/info
|
||||
+PROJ_mandir := $(PROJ_prefix)/share/man
|
||||
|
||||
# Determine if we're on a unix type operating system
|
||||
LLVM_ON_UNIX:=@LLVM_ON_UNIX@
|
||||
diff --git Makefile.rules Makefile.rules
|
||||
index 5556684..08965f3 100644
|
||||
--- Makefile.rules
|
||||
+++ Makefile.rules
|
||||
@@ -720,7 +720,7 @@ ObjectsBC := $(BaseNameSources:%=$(ObjDir)/%.bc)
|
||||
# in the file so they get built before dependencies
|
||||
#---------------------------------------------------------
|
||||
|
||||
-$(PROJ_bindir) $(PROJ_libdir) $(PROJ_includedir) $(PROJ_etcdir)::
|
||||
+$(DESTDIR)$(PROJ_bindir) $(DESTDIR)$(PROJ_libdir) $(DESTDIR)$(PROJ_includedir) $(DESTDIR)$(PROJ_etcdir)::
|
||||
$(Verb) $(MKDIR) $@
|
||||
|
||||
# To create other directories, as needed, and timestamp their creation
|
||||
@@ -842,22 +842,22 @@ install-local::
|
||||
uninstall-local::
|
||||
$(Echo) UnInstall circumvented with NO_INSTALL
|
||||
else
|
||||
-install-local:: $(PROJ_etcdir) $(CONFIG_FILES)
|
||||
- $(Echo) Installing Configuration Files To $(PROJ_etcdir)
|
||||
+install-local:: $(DESTDIR)$(PROJ_etcdir) $(CONFIG_FILES)
|
||||
+ $(Echo) Installing Configuration Files To $(DESTDIR)$(PROJ_etcdir)
|
||||
$(Verb)for file in $(CONFIG_FILES); do \
|
||||
if test -f $(PROJ_OBJ_DIR)/$${file} ; then \
|
||||
- $(DataInstall) $(PROJ_OBJ_DIR)/$${file} $(PROJ_etcdir) ; \
|
||||
+ $(DataInstall) $(PROJ_OBJ_DIR)/$${file} $(DESTDIR)$(PROJ_etcdir) ; \
|
||||
elif test -f $(PROJ_SRC_DIR)/$${file} ; then \
|
||||
- $(DataInstall) $(PROJ_SRC_DIR)/$${file} $(PROJ_etcdir) ; \
|
||||
+ $(DataInstall) $(PROJ_SRC_DIR)/$${file} $(DESTDIR)$(PROJ_etcdir) ; \
|
||||
else \
|
||||
$(ECHO) Error: cannot find config file $${file}. ; \
|
||||
fi \
|
||||
done
|
||||
|
||||
uninstall-local::
|
||||
- $(Echo) Uninstalling Configuration Files From $(PROJ_etcdir)
|
||||
+ $(Echo) Uninstalling Configuration Files From $(DESTDIR)$(PROJ_etcdir)
|
||||
$(Verb)for file in $(CONFIG_FILES); do \
|
||||
- $(RM) -f $(PROJ_etcdir)/$${file} ; \
|
||||
+ $(RM) -f $(DESTDIR)$(PROJ_etcdir)/$${file} ; \
|
||||
done
|
||||
endif
|
||||
|
||||
@@ -944,7 +944,7 @@ endif
|
||||
ifdef BYTECODE_DESTINATION
|
||||
ModuleDestDir := $(BYTECODE_DESTINATION)
|
||||
else
|
||||
-ModuleDestDir := $(PROJ_libdir)
|
||||
+ModuleDestDir := $(DESTDIR)$(PROJ_libdir)
|
||||
endif
|
||||
|
||||
ifdef NO_INSTALL
|
||||
@@ -1023,17 +1023,17 @@ install-local::
|
||||
uninstall-local::
|
||||
$(Echo) Uninstall circumvented with NO_INSTALL
|
||||
else
|
||||
-DestSharedLib = $(PROJ_libdir)/lib$(LIBRARYNAME)$(SHLIBEXT)
|
||||
+DestSharedLib = $(DESTDIR)$(PROJ_libdir)/lib$(LIBRARYNAME)$(SHLIBEXT)
|
||||
|
||||
install-local:: $(DestSharedLib)
|
||||
|
||||
-$(DestSharedLib): $(LibName.SO) $(PROJ_libdir)
|
||||
+$(DestSharedLib): $(LibName.SO) $(DESTDIR)$(PROJ_libdir)
|
||||
$(Echo) Installing $(BuildMode) Shared Library $(DestSharedLib)
|
||||
$(Verb) $(INSTALL) $(LibName.SO) $(DestSharedLib)
|
||||
|
||||
uninstall-local::
|
||||
$(Echo) Uninstalling $(BuildMode) Shared Library $(DestSharedLib)
|
||||
- -$(Verb) $(RM) -f $(PROJ_libdir)/lib$(LIBRARYNAME).*
|
||||
+ -$(Verb) $(RM) -f $(DESTDIR)$(PROJ_libdir)/lib$(LIBRARYNAME).*
|
||||
endif
|
||||
endif
|
||||
|
||||
@@ -1078,7 +1078,7 @@ endif
|
||||
ifdef BYTECODE_DESTINATION
|
||||
BytecodeDestDir := $(BYTECODE_DESTINATION)
|
||||
else
|
||||
-BytecodeDestDir := $(PROJ_libdir)
|
||||
+BytecodeDestDir := $(DESTDIR)$(PROJ_libdir)
|
||||
endif
|
||||
|
||||
DestBytecodeLib = $(BytecodeDestDir)/lib$(LIBRARYNAME).bca
|
||||
@@ -1141,13 +1141,13 @@ install-local::
|
||||
uninstall-local::
|
||||
$(Echo) Uninstall circumvented with NO_INSTALL
|
||||
else
|
||||
-DestArchiveLib := $(PROJ_libdir)/lib$(LIBRARYNAME).a
|
||||
+DestArchiveLib := $(DESTDIR)$(PROJ_libdir)/lib$(LIBRARYNAME).a
|
||||
|
||||
install-local:: $(DestArchiveLib)
|
||||
|
||||
-$(DestArchiveLib): $(LibName.A) $(PROJ_libdir)
|
||||
+$(DestArchiveLib): $(LibName.A) $(DESTDIR)$(PROJ_libdir)
|
||||
$(Echo) Installing $(BuildMode) Archive Library $(DestArchiveLib)
|
||||
- $(Verb) $(MKDIR) $(PROJ_libdir)
|
||||
+ $(Verb) $(MKDIR) $(DESTDIR)$(PROJ_libdir)
|
||||
$(Verb) $(INSTALL) $(LibName.A) $(DestArchiveLib)
|
||||
|
||||
uninstall-local::
|
||||
@@ -1225,11 +1225,11 @@ install-local::
|
||||
uninstall-local::
|
||||
$(Echo) Uninstall circumvented with NO_INSTALL
|
||||
else
|
||||
-DestTool = $(PROJ_bindir)/$(TOOLNAME)$(EXEEXT)
|
||||
+DestTool = $(DESTDIR)$(PROJ_bindir)/$(TOOLNAME)$(EXEEXT)
|
||||
|
||||
install-local:: $(DestTool)
|
||||
|
||||
-$(DestTool): $(ToolBuildPath) $(PROJ_bindir)
|
||||
+$(DestTool): $(ToolBuildPath) $(DESTDIR)$(PROJ_bindir)
|
||||
$(Echo) Installing $(BuildMode) $(DestTool)
|
||||
$(Verb) $(ProgInstall) $(ToolBuildPath) $(DestTool)
|
||||
|
||||
@@ -1824,25 +1824,25 @@ uninstall-local::
|
||||
else
|
||||
install-local::
|
||||
$(Echo) Installing include files
|
||||
- $(Verb) $(MKDIR) $(PROJ_includedir)
|
||||
+ $(Verb) $(MKDIR) $(DESTDIR)$(PROJ_includedir)
|
||||
$(Verb) if test -d "$(PROJ_SRC_ROOT)/include" ; then \
|
||||
cd $(PROJ_SRC_ROOT)/include && \
|
||||
for hdr in `find . -type f '!' '(' -name '*~' \
|
||||
-o -name '.#*' -o -name '*.in' ')' -print | grep -v CVS | \
|
||||
grep -v .svn` ; do \
|
||||
- instdir=`dirname "$(PROJ_includedir)/$$hdr"` ; \
|
||||
+ instdir=`dirname "$(DESTDIR)$(PROJ_includedir)/$$hdr"` ; \
|
||||
if test \! -d "$$instdir" ; then \
|
||||
$(EchoCmd) Making install directory $$instdir ; \
|
||||
$(MKDIR) $$instdir ;\
|
||||
fi ; \
|
||||
- $(DataInstall) $$hdr $(PROJ_includedir)/$$hdr ; \
|
||||
+ $(DataInstall) $$hdr $(DESTDIR)$(PROJ_includedir)/$$hdr ; \
|
||||
done ; \
|
||||
fi
|
||||
ifneq ($(PROJ_SRC_ROOT),$(PROJ_OBJ_ROOT))
|
||||
$(Verb) if test -d "$(PROJ_OBJ_ROOT)/include" ; then \
|
||||
cd $(PROJ_OBJ_ROOT)/include && \
|
||||
for hdr in `find . -type f -print | grep -v CVS` ; do \
|
||||
- $(DataInstall) $$hdr $(PROJ_includedir)/$$hdr ; \
|
||||
+ $(DataInstall) $$hdr $(DESTDIR)$(PROJ_includedir)/$$hdr ; \
|
||||
done ; \
|
||||
fi
|
||||
endif
|
||||
@@ -1854,10 +1854,10 @@ uninstall-local::
|
||||
$(RM) -f `find . -path '*/Internal' -prune -o '(' -type f \
|
||||
'!' '(' -name '*~' -o -name '.#*' \
|
||||
-o -name '*.in' ')' -print ')' | \
|
||||
- grep -v CVS | sed 's#^#$(PROJ_includedir)/#'` ; \
|
||||
+ grep -v CVS | sed 's#^#$(DESTDIR)$(PROJ_includedir)/#'` ; \
|
||||
cd $(PROJ_SRC_ROOT)/include && \
|
||||
$(RM) -f `find . -path '*/Internal' -prune -o '(' -type f -name '*.in' \
|
||||
- -print ')' | sed 's#\.in$$##;s#^#$(PROJ_includedir)/#'` ; \
|
||||
+ -print ')' | sed 's#\.in$$##;s#^#$(DESTDIR)$(PROJ_includedir)/#'` ; \
|
||||
fi
|
||||
endif
|
||||
endif
|
||||
diff --git docs/CommandGuide/Makefile docs/CommandGuide/Makefile
|
||||
index cf77e6a..28835ac 100644
|
||||
--- docs/CommandGuide/Makefile
|
||||
+++ docs/CommandGuide/Makefile
|
||||
@@ -71,9 +71,9 @@ EXTRA_DIST := $(POD) index.html
|
||||
clean-local::
|
||||
$(Verb) $(RM) -f pod2htm*.*~~ $(HTML) $(MAN) $(PS)
|
||||
|
||||
-HTML_DIR := $(PROJ_docsdir)/html/CommandGuide
|
||||
-MAN_DIR := $(PROJ_mandir)/man1
|
||||
-PS_DIR := $(PROJ_docsdir)/ps
|
||||
+HTML_DIR := $(DESTDIR)$(PROJ_docsdir)/html/CommandGuide
|
||||
+MAN_DIR := $(DESTDIR)$(PROJ_mandir)/man1
|
||||
+PS_DIR := $(DESTDIR)$(PROJ_docsdir)/ps
|
||||
|
||||
install-local:: $(HTML) $(MAN) $(PS)
|
||||
$(Echo) Installing HTML CommandGuide Documentation
|
||||
diff --git docs/Makefile docs/Makefile
|
||||
index 310c4bd..30cd8a7 100644
|
||||
--- docs/Makefile
|
||||
+++ docs/Makefile
|
||||
@@ -48,11 +48,11 @@ generated:: doxygen ocamldoc
|
||||
|
||||
install-html: $(PROJ_OBJ_DIR)/html.tar.gz
|
||||
$(Echo) Installing HTML documentation
|
||||
- $(Verb) $(MKDIR) $(PROJ_docsdir)/html
|
||||
- $(Verb) $(MKDIR) $(PROJ_docsdir)/html/img
|
||||
- $(Verb) $(DataInstall) $(HTML) $(PROJ_docsdir)/html
|
||||
- $(Verb) $(DataInstall) $(IMAGES) $(PROJ_docsdir)/html/img
|
||||
- $(Verb) $(DataInstall) $(PROJ_OBJ_DIR)/html.tar.gz $(PROJ_docsdir)
|
||||
+ $(Verb) $(MKDIR) $(DESTDIR)$(PROJ_docsdir)/html
|
||||
+ $(Verb) $(MKDIR) $(DESTDIR)$(PROJ_docsdir)/html/img
|
||||
+ $(Verb) $(DataInstall) $(HTML) $(DESTDIR)$(PROJ_docsdir)/html
|
||||
+ $(Verb) $(DataInstall) $(IMAGES) $(DESTDIR)$(PROJ_docsdir)/html/img
|
||||
+ $(Verb) $(DataInstall) $(PROJ_OBJ_DIR)/html.tar.gz $(DESTDIR)$(PROJ_docsdir)
|
||||
|
||||
$(PROJ_OBJ_DIR)/html.tar.gz: $(HTML)
|
||||
$(Echo) Packaging HTML documentation
|
||||
@@ -63,11 +63,11 @@ $(PROJ_OBJ_DIR)/html.tar.gz: $(HTML)
|
||||
|
||||
install-doxygen: doxygen
|
||||
$(Echo) Installing doxygen documentation
|
||||
- $(Verb) $(MKDIR) $(PROJ_docsdir)/html/doxygen
|
||||
- $(Verb) $(DataInstall) $(PROJ_OBJ_DIR)/doxygen.tar.gz $(PROJ_docsdir)
|
||||
+ $(Verb) $(MKDIR) $(DESTDIR)$(PROJ_docsdir)/html/doxygen
|
||||
+ $(Verb) $(DataInstall) $(PROJ_OBJ_DIR)/doxygen.tar.gz $(DESTDIR)$(PROJ_docsdir)
|
||||
$(Verb) cd $(PROJ_OBJ_DIR)/doxygen && \
|
||||
$(FIND) . -type f -exec \
|
||||
- $(DataInstall) {} $(PROJ_docsdir)/html/doxygen \;
|
||||
+ $(DataInstall) {} $(DESTDIR)$(PROJ_docsdir)/html/doxygen \;
|
||||
|
||||
doxygen: regendoc $(PROJ_OBJ_DIR)/doxygen.tar.gz
|
||||
|
||||
@@ -94,11 +94,11 @@ $(LLVM_SRC_ROOT)/docs/userloc.html:
|
||||
|
||||
install-ocamldoc: ocamldoc
|
||||
$(Echo) Installing ocamldoc documentation
|
||||
- $(Verb) $(MKDIR) $(PROJ_docsdir)/ocamldoc/html
|
||||
- $(Verb) $(DataInstall) $(PROJ_OBJ_DIR)/ocamldoc.tar.gz $(PROJ_docsdir)
|
||||
+ $(Verb) $(MKDIR) $(DESTDIR)$(PROJ_docsdir)/ocamldoc/html
|
||||
+ $(Verb) $(DataInstall) $(PROJ_OBJ_DIR)/ocamldoc.tar.gz $(DESTDIR)$(PROJ_docsdir)
|
||||
$(Verb) cd $(PROJ_OBJ_DIR)/ocamldoc && \
|
||||
$(FIND) . -type f -exec \
|
||||
- $(DataInstall) {} $(PROJ_docsdir)/ocamldoc/html \;
|
||||
+ $(DataInstall) {} $(DESTDIR)$(PROJ_docsdir)/ocamldoc/html \;
|
||||
|
||||
ocamldoc: regen-ocamldoc $(PROJ_OBJ_DIR)/ocamldoc.tar.gz
|
||||
|
||||
@@ -122,4 +122,4 @@ $(PROJ_OBJ_DIR)/ocamldoc.tar.gz:
|
||||
|
||||
uninstall-local::
|
||||
$(Echo) Uninstalling Documentation
|
||||
- $(Verb) $(RM) -rf $(PROJ_docsdir)
|
||||
+ $(Verb) $(RM) -rf $(DESTDIR)$(PROJ_docsdir)
|
||||
diff --git docs/tutorial/Makefile docs/tutorial/Makefile
|
||||
index 6169bb8..9082ad4 100644
|
||||
--- docs/tutorial/Makefile
|
||||
+++ docs/tutorial/Makefile
|
||||
@@ -12,7 +12,7 @@ include $(LEVEL)/Makefile.common
|
||||
|
||||
HTML := $(wildcard $(PROJ_SRC_DIR)/*.html)
|
||||
EXTRA_DIST := $(HTML) index.html
|
||||
-HTML_DIR := $(PROJ_docsdir)/html/tutorial
|
||||
+HTML_DIR := $(DESTDIR)$(PROJ_docsdir)/html/tutorial
|
||||
|
||||
install-local:: $(HTML)
|
||||
$(Echo) Installing HTML Tutorial Documentation
|
||||
diff --git lib/VMCore/Makefile lib/VMCore/Makefile
|
||||
index e9d3dc8..c4817a5 100644
|
||||
--- lib/VMCore/Makefile
|
||||
+++ lib/VMCore/Makefile
|
||||
@@ -29,5 +29,5 @@ $(GENFILE): $(ObjDir)/Intrinsics.gen.tmp
|
||||
changed significantly. )
|
||||
|
||||
install-local:: $(GENFILE)
|
||||
- $(Echo) Installing $(PROJ_includedir)/llvm/Intrinsics.gen
|
||||
- $(Verb) $(DataInstall) $(GENFILE) $(PROJ_includedir)/llvm/Intrinsics.gen
|
||||
+ $(Echo) Installing $(DESTDIR)$(PROJ_includedir)/llvm/Intrinsics.gen
|
||||
+ $(Verb) $(DataInstall) $(GENFILE) $(DESTDIR)$(PROJ_includedir)/llvm/Intrinsics.gen
|
||||
diff --git tools/gccas/Makefile tools/gccas/Makefile
|
||||
index ff84d96..594f9e4 100644
|
||||
--- tools/gccas/Makefile
|
||||
+++ tools/gccas/Makefile
|
||||
@@ -10,9 +10,9 @@ LEVEL = ../..
|
||||
|
||||
include $(LEVEL)/Makefile.common
|
||||
|
||||
-install-local:: $(PROJ_bindir)/gccas
|
||||
+install-local:: $(DESTDIR)$(PROJ_bindir)/gccas
|
||||
|
||||
-$(PROJ_bindir)/gccas : gccas.sh Makefile
|
||||
+$(DESTDIR)$(PROJ_bindir)/gccas : gccas.sh Makefile
|
||||
$(Echo) Installing gccas shell script.
|
||||
$(Verb) sed "s#@TOOLDIR@#$(PROJ_bindir)#" $< > $@
|
||||
$(Verb) chmod 0755 $@
|
||||
diff --git tools/gccld/Makefile tools/gccld/Makefile
|
||||
index b2d3f73..8ec0307 100644
|
||||
--- tools/gccld/Makefile
|
||||
+++ tools/gccld/Makefile
|
||||
@@ -11,9 +11,9 @@ LEVEL = ../..
|
||||
|
||||
include $(LEVEL)/Makefile.common
|
||||
|
||||
-install-local:: $(PROJ_bindir)/gccld
|
||||
+install-local:: $(DESTDIR)$(PROJ_bindir)/gccld
|
||||
|
||||
-$(PROJ_bindir)/gccld : gccld.sh Makefile
|
||||
+$(DESTDIR)$(PROJ_bindir)/gccld : gccld.sh Makefile
|
||||
$(Echo) Installing gccld shell script.
|
||||
$(Verb) sed "s#@TOOLDIR@#$(PROJ_bindir)#" $< > $@
|
||||
$(Verb) chmod 0755 $@
|
||||
diff --git tools/llvm-config/Makefile tools/llvm-config/Makefile
|
||||
index 6eedca0..8659681 100644
|
||||
--- tools/llvm-config/Makefile
|
||||
+++ tools/llvm-config/Makefile
|
||||
@@ -87,6 +87,6 @@ clean-local::
|
||||
$(LibDeps) GenLibDeps.out
|
||||
install-local:: all-local
|
||||
$(Echo) Installing llvm-config
|
||||
- $(Verb) $(MKDIR) $(PROJ_bindir)
|
||||
- $(Verb) $(ScriptInstall) $(ToolDir)/llvm-config $(PROJ_bindir)
|
||||
+ $(Verb) $(MKDIR) $(DESTDIR)$(PROJ_bindir)
|
||||
+ $(Verb) $(ScriptInstall) $(ToolDir)/llvm-config $(DESTDIR)$(PROJ_bindir)
|
||||
|
||||
|
||||
--------------1.6.4--
|
||||
|
||||
|
132
llvm.spec
132
llvm.spec
@ -4,22 +4,17 @@
|
||||
# The doxygen docs are HUGE, so they are not built by default.
|
||||
|
||||
Name: llvm
|
||||
Version: 2.6
|
||||
Release: 0.5.pre1%{?dist}
|
||||
Version: 2.7
|
||||
Release: 1%{?dist}
|
||||
Summary: The Low Level Virtual Machine
|
||||
|
||||
Group: Development/Languages
|
||||
License: NCSA
|
||||
URL: http://llvm.org/
|
||||
Source0: http://llvm.org/prereleases/%{version}/llvm-%{version}.tar.gz
|
||||
Source1: http://llvm.org/prereleases/%{version}/clang-%{version}.tar.gz
|
||||
# http://llvm.org/bugs/show_bug.cgi?id=3153
|
||||
Patch0: llvm-2.6-destdir.patch
|
||||
Patch1: llvm-2.6-destdir-clang.patch
|
||||
# http://llvm.org/bugs/show_bug.cgi?id=4911
|
||||
Patch2: llvm-2.5-tclsh_check.patch
|
||||
Source0: http://llvm.org/releases/%{version}/llvm-%{version}.tgz
|
||||
Source1: http://llvm.org/releases/%{version}/clang-%{version}.tgz
|
||||
# Data files should be installed with timestamps preserved
|
||||
Patch3: llvm-2.6-timestamp.patch
|
||||
Patch0: llvm-2.6-timestamp.patch
|
||||
|
||||
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
||||
|
||||
@ -53,6 +48,7 @@ Summary: Libraries and header files for LLVM
|
||||
Group: Development/Languages
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
Requires: libstdc++-devel >= 3.4
|
||||
Provides: llvm-static = %{version}-%{release}
|
||||
|
||||
|
||||
%description devel
|
||||
@ -70,7 +66,7 @@ Documentation for the LLVM compiler infrastructure.
|
||||
|
||||
|
||||
%package -n clang
|
||||
Summary: A C language family frontend for LLVM
|
||||
Summary: A C language family front-end for LLVM
|
||||
License: NCSA
|
||||
Group: Development/Languages
|
||||
|
||||
@ -82,7 +78,16 @@ clang: noun
|
||||
|
||||
The goal of the Clang project is to create a new C, C++, Objective C
|
||||
and Objective C++ front-end for the LLVM compiler. Its tools are built
|
||||
as libraries and designed to be loosely-coupled and extendable.
|
||||
as libraries and designed to be loosely-coupled and extensible.
|
||||
|
||||
|
||||
%package -n clang-devel
|
||||
Summary: Header files for clang
|
||||
Group: Development/Languages
|
||||
Requires: clang = %{version}-%{release}
|
||||
|
||||
%description -n clang-devel
|
||||
This package contains header files for the Clang compiler.
|
||||
|
||||
|
||||
%package -n clang-analyzer
|
||||
@ -137,6 +142,7 @@ Summary: Development files for %{name}-ocaml
|
||||
Group: Development/Libraries
|
||||
Requires: %{name}-devel = %{version}-%{release}
|
||||
Requires: %{name}-ocaml = %{version}-%{release}
|
||||
Requires: ocaml
|
||||
|
||||
%description ocaml-devel
|
||||
The %{name}-ocaml-devel package contains libraries and signature files
|
||||
@ -155,19 +161,19 @@ HTML documentation for LLVM's OCaml binding.
|
||||
|
||||
%prep
|
||||
%setup -q -n llvm-%{version} -a1 %{?_with_gcc:-a2}
|
||||
mv clang-2.6 tools/clang
|
||||
mv clang-%{version} tools/clang
|
||||
|
||||
%patch0 -p0 -b .destdir
|
||||
pushd tools/clang
|
||||
%patch1 -p0 -b .destdir-clang
|
||||
popd
|
||||
%patch2 -p1 -b .tclsh_check
|
||||
%patch3 -p1 -b .timestamp
|
||||
%patch0 -p1 -b .timestamp
|
||||
|
||||
# Encoding fix
|
||||
(cd tools/clang/docs && \
|
||||
iconv -f ISO88591 -t UTF8 BlockImplementation.txt \
|
||||
-o BlockImplementation.txt)
|
||||
|
||||
|
||||
%build
|
||||
# Disabling assertions now, rec. by pure and needed for OpenGTL
|
||||
# no PIC on ix86: http://llvm.org/bugs/show_bug.cgi?id=3239
|
||||
# TESTFIX no PIC on ix86: http://llvm.org/bugs/show_bug.cgi?id=3801
|
||||
mkdir obj && cd obj
|
||||
../configure \
|
||||
--prefix=%{_prefix} \
|
||||
@ -175,9 +181,7 @@ mkdir obj && cd obj
|
||||
--disable-assertions \
|
||||
--enable-debug-runtime \
|
||||
--enable-jit \
|
||||
%ifarch %{ix86}
|
||||
--enable-pic=no
|
||||
%endif
|
||||
--enable-shared
|
||||
|
||||
# FIXME file this
|
||||
# configure does not properly specify libdir
|
||||
@ -192,14 +196,10 @@ make %{_smp_mflags} \
|
||||
|
||||
|
||||
%check
|
||||
# some tests fail on PPC
|
||||
# http://www.nabble.com/LLVM-2.6-pre1%3A-test-failures-on-Fedora-11.91-%28Rawhide%29-ppc-td25334198.html
|
||||
cd obj
|
||||
%ifnarch ppc
|
||||
make check
|
||||
%endif
|
||||
# some clang tests still fail, preserve test results
|
||||
(cd tools/clang && make test 2>&1) | tee ../testlog.txt || true
|
||||
# no current unexpected failures. Use || true if they recur to force ignore
|
||||
make check 2>&1 | tee ../llvm-testlog.txt
|
||||
(cd tools/clang && make test 2>&1) | tee ../clang-testlog.txt
|
||||
|
||||
|
||||
%install
|
||||
@ -211,27 +211,23 @@ make install DESTDIR=%{buildroot} \
|
||||
PROJ_docsdir=/moredocs
|
||||
popd
|
||||
|
||||
# Create ld.so.conf.d entry
|
||||
mkdir -p %{buildroot}%{_sysconfdir}/ld.so.conf.d
|
||||
cat >> %{buildroot}%{_sysconfdir}/ld.so.conf.d/llvm-%{_arch}.conf << EOF
|
||||
%{_libdir}/llvm
|
||||
EOF
|
||||
|
||||
# Static analyzer not installed by default:
|
||||
# http://clang-analyzer.llvm.org/installation#OtherPlatforms
|
||||
mkdir -p %{buildroot}%{_libdir}/clang-analyzer/libexec
|
||||
# link clang-cc for scan-build to find
|
||||
ln -s %{_libexecdir}/clang-cc %{buildroot}%{_libdir}/clang-analyzer/libexec/
|
||||
mkdir -p %{buildroot}%{_libdir}/clang-analyzer
|
||||
# create launchers
|
||||
for f in scan-{build,view}; do
|
||||
ln -s %{_libdir}/clang-analyzer/$f %{buildroot}%{_bindir}/$f
|
||||
ln -s %{_libdir}/clang-analyzer/$f/$f %{buildroot}%{_bindir}/$f
|
||||
done
|
||||
|
||||
pushd tools/clang/utils
|
||||
cp -p ccc-analyzer %{buildroot}%{_libdir}/clang-analyzer/libexec/
|
||||
(cd tools/clang/tools && cp -pr scan-{build,view} \
|
||||
%{buildroot}%{_libdir}/clang-analyzer/)
|
||||
|
||||
for f in scan-build scanview.css sorttable.js; do
|
||||
cp -p $f %{buildroot}%{_libdir}/clang-analyzer/
|
||||
done
|
||||
popd
|
||||
|
||||
pushd tools/clang/tools/scan-view
|
||||
cp -pr * %{buildroot}%{_libdir}/clang-analyzer/
|
||||
popd
|
||||
|
||||
# Move documentation back to build directory
|
||||
#
|
||||
@ -248,17 +244,14 @@ done
|
||||
rm -rf tools/clang/docs/{doxygen*,Makefile*,*.graffle,tools}
|
||||
|
||||
|
||||
find %{buildroot} -name .dir -print0 | xargs -0r rm -f
|
||||
#find %{buildroot} -name .dir -print0 | xargs -0r rm -f
|
||||
file %{buildroot}/%{_bindir}/* | awk -F: '$2~/ELF/{print $1}' | xargs -r chrpath -d
|
||||
file %{buildroot}/%{_libdir}/llvm/*.so | awk -F: '$2~/ELF/{print $1}' | xargs -r chrpath -d
|
||||
chrpath -d %{buildroot}/%{_libexecdir}/clang-cc
|
||||
#chrpath -d %{buildroot}/%{_libexecdir}/clang-cc
|
||||
|
||||
# Get rid of erroneously installed example files.
|
||||
rm %{buildroot}%{_libdir}/%{name}/*LLVMHello.*
|
||||
|
||||
# Remove deprecated tools.
|
||||
rm %{buildroot}%{_bindir}/gcc{as,ld}
|
||||
|
||||
# FIXME file this bug
|
||||
sed -i 's,ABS_RUN_DIR/lib",ABS_RUN_DIR/%{_lib}/%{name}",' \
|
||||
%{buildroot}%{_bindir}/llvm-config
|
||||
@ -282,43 +275,38 @@ rm -rf %{buildroot}
|
||||
|
||||
%files
|
||||
%defattr(-,root,root,-)
|
||||
%doc CREDITS.TXT LICENSE.TXT README.txt
|
||||
%exclude %{_bindir}/llvm-config
|
||||
%doc CREDITS.TXT LICENSE.TXT README.txt llvm-testlog.txt
|
||||
%{_bindir}/bugpoint
|
||||
%{_bindir}/llc
|
||||
%{_bindir}/lli
|
||||
%exclude %{_bindir}/llvm-config
|
||||
%{_bindir}/llvm*
|
||||
%{_bindir}/opt
|
||||
%config(noreplace) %{_sysconfdir}/ld.so.conf.d/llvm-%{_arch}.conf
|
||||
%dir %{_libdir}/llvm
|
||||
%{_libdir}/llvm/*.so
|
||||
%exclude %{_mandir}/man1/clang.1.*
|
||||
%exclude %{_mandir}/man1/FileCheck.1.*
|
||||
%doc %{_mandir}/man1/*.1.gz
|
||||
|
||||
%if %{?_with_doxygen:1}%{!?_with_doxygen:0}
|
||||
%exclude %{_bindir}/llvm-[cg]++
|
||||
%exclude %{_bindir}/llvm-gcc
|
||||
%exclude %{_mandir}/man1/llvm-[cg]++.*
|
||||
%exclude %{_mandir}/man1/llvm-gcc.*
|
||||
%endif
|
||||
|
||||
%doc %{_mandir}/man1/*.1.*
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root,-)
|
||||
%{_bindir}/llvm-config
|
||||
%{_includedir}/%{name}
|
||||
%{_includedir}/%{name}-c
|
||||
%{_libdir}/%{name}
|
||||
%{_libdir}/%{name}/*.a
|
||||
|
||||
%files -n clang
|
||||
%defattr(-,root,root,-)
|
||||
%doc clang-docs/* testlog.txt
|
||||
%doc clang-docs/* clang-testlog.txt
|
||||
%{_bindir}/clang*
|
||||
%{_bindir}/FileCheck
|
||||
%{_bindir}/FileUpdate
|
||||
%{_bindir}/tblgen
|
||||
%{_prefix}/lib/clang
|
||||
%{_libexecdir}/clang-cc
|
||||
%doc %{_mandir}/man1/clang.1.*
|
||||
%doc %{_mandir}/man1/FileCheck.1.*
|
||||
|
||||
%files -n clang-devel
|
||||
%defattr(-,root,root,-)
|
||||
%{_includedir}/clang
|
||||
%{_includedir}/clang-c
|
||||
|
||||
%files -n clang-analyzer
|
||||
%defattr(-,root,root,-)
|
||||
@ -358,6 +346,16 @@ rm -rf %{buildroot}
|
||||
|
||||
|
||||
%changelog
|
||||
* Sun May 2 2010 Michel Salim <salimma@fedoraproject.org> - 2.7-1
|
||||
- Update to final 2.7 release
|
||||
|
||||
* Sun Mar 28 2010 Michel Salim <salimma@fedoraproject.org> - 2.7-0.1.pre1
|
||||
- Update to first 2.7 pre-release
|
||||
|
||||
* Fri Sep 18 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.6.pre2
|
||||
- Update to 2.6 pre-release2
|
||||
- -devel subpackage now virtually provides -static
|
||||
|
||||
* Wed Sep 9 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.5.pre1
|
||||
- Disable var tracking assignments on PPC
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user