Resolves: rhbz#1282645 add GCC abi_tag support
This commit is contained in:
parent
478ee5f860
commit
64695d69a2
1232
0001-add-gcc-abi_tag-support.patch
Normal file
1232
0001-add-gcc-abi_tag-support.patch
Normal file
File diff suppressed because it is too large
Load Diff
24
0002-Adapt-previous-Clang-trunk-patch-to-Clang-3.7.patch
Normal file
24
0002-Adapt-previous-Clang-trunk-patch-to-Clang-3.7.patch
Normal file
@ -0,0 +1,24 @@
|
||||
From e746af90e6aa52af6e6bb0b88ffe20dbd97a1e4d Mon Sep 17 00:00:00 2001
|
||||
From: Stephan Bergmann <sbergman@redhat.com>
|
||||
Date: Thu, 3 Dec 2015 14:53:39 +0100
|
||||
Subject: [PATCH 2/3] Adapt previous (Clang trunk) patch to Clang 3.7
|
||||
|
||||
---
|
||||
lib/AST/ItaniumMangle.cpp | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/lib/AST/ItaniumMangle.cpp b/lib/AST/ItaniumMangle.cpp
|
||||
index e32b659..19a09dc 100644
|
||||
--- a/tools/clang/lib/AST/ItaniumMangle.cpp
|
||||
+++ b/tools/clang/lib/AST/ItaniumMangle.cpp
|
||||
@@ -31,6 +31,7 @@
|
||||
#include "llvm/ADT/StringExtras.h"
|
||||
#include "llvm/Support/ErrorHandling.h"
|
||||
#include "llvm/Support/raw_ostream.h"
|
||||
+#include <set>
|
||||
|
||||
#define MANGLE_CHECKER 0
|
||||
|
||||
--
|
||||
2.4.3
|
||||
|
11
llvm.spec
11
llvm.spec
@ -35,7 +35,7 @@
|
||||
|
||||
Name: llvm
|
||||
Version: 3.7.0
|
||||
Release: 2%{?dist}
|
||||
Release: 3%{?dist}
|
||||
Summary: The Low Level Virtual Machine
|
||||
|
||||
Group: Development/Languages
|
||||
@ -72,6 +72,9 @@ Patch2: 0001-data-install-preserve-timestamps.patch
|
||||
Patch200: lldb-python.patch
|
||||
Patch202: lldb-python-module-symlink.patch
|
||||
|
||||
Patch203: 0001-add-gcc-abi_tag-support.patch
|
||||
Patch204: 0002-Adapt-previous-Clang-trunk-patch-to-Clang-3.7.patch
|
||||
|
||||
BuildRequires: bison
|
||||
BuildRequires: chrpath
|
||||
BuildRequires: flex
|
||||
@ -332,6 +335,9 @@ sed -i s/@lib@/%{_lib}/g scripts/Python/modules/readline/Makefile
|
||||
popd
|
||||
%endif
|
||||
|
||||
%patch203 -p1
|
||||
%patch204 -p1
|
||||
|
||||
# fix library paths
|
||||
sed -i 's|/lib /usr/lib $lt_ld_extra|%{_libdir} $lt_ld_extra|' configure
|
||||
sed -i 's|(PROJ_prefix)/lib|(PROJ_prefix)/%{_lib}/%{name}|g' Makefile.config.in
|
||||
@ -698,6 +704,9 @@ exit 0
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Thu Dec 03 2015 Stephan Bergmann <sbergman@redhat.com> 3.7.0-3
|
||||
- Resolves: rhbz#1282645 add GCC abi_tag support
|
||||
|
||||
* Thu Oct 29 2015 Adam Jackson <ajax@redhat.com> 3.7.0-2
|
||||
- Drop -fno-devirtualize
|
||||
- Link with -static-libstdc++ to work around bundled libstdc++ in Steam
|
||||
|
Loading…
Reference in New Issue
Block a user