fix old bogus date and drop llvm-3.2-clang-driver-secondary-arch-triplets.patch
since it didn't actually help - insufficient The triplets issue (#803433) really needs badly to be reported upstream.
This commit is contained in:
parent
c9608480ef
commit
4a3f4354c7
@ -1,26 +0,0 @@
|
||||
--- llvm-3.2.src/tools/clang/lib/Driver/ToolChains.cpp~ 2012-12-17 00:59:27.000000000 +0900
|
||||
+++ llvm-3.2.src/tools/clang/lib/Driver/ToolChains.cpp 2013-02-12 19:18:00.755164292 +0900
|
||||
@@ -1054,10 +1054,12 @@
|
||||
static const char *const ARMLibDirs[] = { "/lib" };
|
||||
static const char *const ARMTriples[] = {
|
||||
"arm-linux-gnueabi",
|
||||
- "arm-linux-androideabi"
|
||||
+ "arm-linux-androideabi",
|
||||
+ "armv5tel-redhat-linux-gnueabi",
|
||||
};
|
||||
static const char *const ARMHFTriples[] = {
|
||||
"arm-linux-gnueabihf",
|
||||
+ "armv7hl-redhat-linux-gnueabi",
|
||||
};
|
||||
|
||||
static const char *const X86_64LibDirs[] = { "/lib64", "/lib" };
|
||||
@@ -1104,7 +1106,8 @@
|
||||
"powerpc-linux-gnu",
|
||||
"powerpc-unknown-linux-gnu",
|
||||
"powerpc-suse-linux",
|
||||
- "powerpc-montavista-linuxspe"
|
||||
+ "powerpc-montavista-linuxspe",
|
||||
+ "ppc64-redhat-linux",
|
||||
};
|
||||
static const char *const PPC64LibDirs[] = { "/lib64", "/lib" };
|
||||
static const char *const PPC64Triples[] = {
|
12
llvm.spec
12
llvm.spec
@ -35,7 +35,7 @@
|
||||
|
||||
Name: llvm
|
||||
Version: 3.2
|
||||
Release: 3%{?dist}
|
||||
Release: 4%{?dist}
|
||||
Summary: The Low Level Virtual Machine
|
||||
|
||||
Group: Development/Languages
|
||||
@ -50,7 +50,6 @@ Source3: llvm-Config-llvm-config.h
|
||||
# Data files should be installed with timestamps preserved
|
||||
Patch0: llvm-2.6-timestamp.patch
|
||||
|
||||
Patch10: llvm-3.2-clang-driver-secondary-arch-triplets.patch
|
||||
Patch11: clang-hardfloat-hack.patch
|
||||
|
||||
# hack llvm-config to print -lLLVM-3.2svn instead of ALL THE THINGS
|
||||
@ -276,8 +275,7 @@ mv clang-%{version}%{?prerel}.src tools/clang
|
||||
# llvm patches
|
||||
%patch0 -p1 -b .timestamp
|
||||
|
||||
# clang triplets
|
||||
%patch10 -p1 -b .orig
|
||||
# arm hard float
|
||||
%patch11 -p1 -b .orig
|
||||
|
||||
# fix llvm-config --libs
|
||||
@ -576,6 +574,10 @@ exit 0
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Thu Apr 4 2013 Jens Petersen <petersen@redhat.com> - 3.2-4
|
||||
- fix bogus date for 2.9-0.2.rc1
|
||||
- drop insufficient llvm-3.2-clang-driver-secondary-arch-triplets.patch
|
||||
|
||||
* Sun Mar 31 2013 Dennis Gilmore <dennis@ausil.us> - 3.2-3
|
||||
- add a hack to clang defaulting arm to hardfloat
|
||||
|
||||
@ -725,7 +727,7 @@ exit 0
|
||||
* Fri Mar 25 2011 Michel Salim <salimma@fedoraproject.org> - 2.9-0.3.rc2
|
||||
- Update to 2.9rc2
|
||||
|
||||
* Thu Mar 18 2011 Michel Salim <salimma@fedoraproject.org> - 2.9-0.2.rc1
|
||||
* Thu Mar 17 2011 Michel Salim <salimma@fedoraproject.org> - 2.9-0.2.rc1
|
||||
- Split shared libraries into separate subpackage
|
||||
- Don't include test logs; breaks multilib (# 666195)
|
||||
- clang++: also search for platform-specific include files (# 680644)
|
||||
|
Loading…
Reference in New Issue
Block a user