13.0.0-rc4 Release
This commit is contained in:
parent
9e342d2430
commit
2b9d762f80
2
.gitignore
vendored
2
.gitignore
vendored
@ -112,3 +112,5 @@
|
||||
/llvm-13.0.0rc1.src.tar.xz.sig
|
||||
/llvm-13.0.0rc3.src.tar.xz
|
||||
/llvm-13.0.0rc3.src.tar.xz.sig
|
||||
/llvm-13.0.0rc4.src.tar.xz
|
||||
/llvm-13.0.0rc4.src.tar.xz.sig
|
||||
|
1635
0001-cmake-Remove-config.guess.patch
Normal file
1635
0001-cmake-Remove-config.guess.patch
Normal file
File diff suppressed because it is too large
Load Diff
41
0001-test-ExecutionEngine-Clean-up-lit.local.cfg.patch
Normal file
41
0001-test-ExecutionEngine-Clean-up-lit.local.cfg.patch
Normal file
@ -0,0 +1,41 @@
|
||||
From 160d464a192f25a7e69bf63f20bdfdffe036dd42 Mon Sep 17 00:00:00 2001
|
||||
From: Tom Stellard <tstellar@redhat.com>
|
||||
Date: Wed, 29 Sep 2021 16:20:47 -0700
|
||||
Subject: [PATCH] test/ExecutionEngine: Clean up lit.local.cfg
|
||||
|
||||
Switch to using config.root.native_target to determine if tests are
|
||||
supported. This is a canonical form of the arch from the target
|
||||
triple.
|
||||
|
||||
Differential Revision: https://reviews.llvm.org/D110788
|
||||
---
|
||||
llvm/test/ExecutionEngine/lit.local.cfg | 16 +---------------
|
||||
1 file changed, 1 insertion(+), 15 deletions(-)
|
||||
|
||||
diff --git a/llvm/test/ExecutionEngine/lit.local.cfg b/llvm/test/ExecutionEngine/lit.local.cfg
|
||||
index 88e3e9b23883..72b6a9ac269e 100644
|
||||
--- a/llvm/test/ExecutionEngine/lit.local.cfg
|
||||
+++ b/llvm/test/ExecutionEngine/lit.local.cfg
|
||||
@@ -1,18 +1,4 @@
|
||||
-if config.root.host_arch in ['Sparc', 'PowerPC', 'AArch64', 'SystemZ']:
|
||||
- config.unsupported = True
|
||||
-
|
||||
-# CMake and autoconf diverge in naming or host_arch
|
||||
-if 'powerpc64' in config.root.target_triple:
|
||||
- config.unsupported = True
|
||||
-
|
||||
-if 'aarch64' in config.root.target_triple \
|
||||
- or 'arm64' in config.root.target_triple:
|
||||
- config.unsupported = True
|
||||
-
|
||||
-if 'hexagon' in config.root.target_triple:
|
||||
- config.unsupported = True
|
||||
-
|
||||
-if 'sparc' in config.root.target_triple:
|
||||
+if config.root.native_target in ['Sparc', 'PowerPC', 'AArch64', 'SystemZ', 'Hexagon']:
|
||||
config.unsupported = True
|
||||
|
||||
# ExecutionEngine tests are not expected to pass in a cross-compilation setup.
|
||||
--
|
||||
2.31.1
|
||||
|
15
llvm.spec
15
llvm.spec
@ -11,11 +11,11 @@
|
||||
|
||||
%global llvm_libdir %{_libdir}/%{name}
|
||||
%global build_llvm_libdir %{buildroot}%{llvm_libdir}
|
||||
%global rc_ver 3
|
||||
%global rc_ver 4
|
||||
%global maj_ver 13
|
||||
%global min_ver 0
|
||||
%global patch_ver 0
|
||||
%global abi_revision 1
|
||||
%global abi_revision 2
|
||||
%global llvm_srcdir llvm-%{maj_ver}.%{min_ver}.%{patch_ver}%{?rc_ver:rc%{rc_ver}}.src
|
||||
|
||||
%if %{with compat_build}
|
||||
@ -70,6 +70,13 @@ Source4: lit.fedora.cfg.py
|
||||
|
||||
Patch0: 0001-cmake-Allow-shared-libraries-to-customize-the-soname.patch
|
||||
Patch2: 0001-XFAIL-missing-abstract-variable.ll-test-on-ppc64le.patch
|
||||
# Remove config.guess, so that we get a default triple that matches gcc.
|
||||
# This ensures that clang always uses the system gcc install.
|
||||
Patch3: 0001-cmake-Remove-config.guess.patch
|
||||
# Patch3 has the effect of changing the arch triple on ppc64le from powerpc64le
|
||||
# to ppc64le, which inadvertently enabled some ExecutionEngine tests that were
|
||||
# supposed to be unsupported. Patch4 disables these tests on ppc64le.
|
||||
Patch4: 0001-test-ExecutionEngine-Clean-up-lit.local.cfg.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
BuildRequires: gcc-c++
|
||||
@ -272,7 +279,6 @@ LLVM's modified googletest sources.
|
||||
-DLLVM_INSTALL_TOOLCHAIN_ONLY:BOOL=OFF \
|
||||
-DLLVM_ABI_REVISION=%{abi_revision} \
|
||||
\
|
||||
-DLLVM_DEFAULT_TARGET_TRIPLE=%{_host} \
|
||||
-DSPHINX_WARNINGS_AS_ERRORS=OFF \
|
||||
-DCMAKE_INSTALL_PREFIX=%{install_prefix} \
|
||||
-DLLVM_INSTALL_SPHINX_HTML_DIR=%{_pkgdocdir}/html \
|
||||
@ -535,6 +541,9 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Fri Sep 24 2021 Tom Stellard <tstellar@redhat.com> - 13.0.0~rc4-1
|
||||
- 13.0.0-rc4 Release
|
||||
|
||||
* Fri Sep 17 2021 Tom Stellard <tstellar@redhta.com> - 13.0.0~rc3-1
|
||||
- 13.0.0-rc3 Release
|
||||
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (llvm-13.0.0rc3.src.tar.xz) = af2f237e8dbfe47ea21cd0d0463dccfc0585118c4773ffb3dc60b9bad582de33fe9e2f14d41c1332df911ce3234589fedccfb3db706f1d9720e98e8f406e80b6
|
||||
SHA512 (llvm-13.0.0rc3.src.tar.xz.sig) = aecafd70138da902338dd0f4c523ff22a3b43669c973de05a1aa775c9e65ce065086806e2009d354afe99337d9701d27968f980441144f0289735a15caec77b3
|
||||
SHA512 (llvm-13.0.0rc4.src.tar.xz) = 323f12f5625e985bb2cd6bda0282408f81ea377e175af6fc45d90dc6b91a90ab7768f9e2e7cc7b130af2060080aed0ffbad1b681dcca538701b50d988bf96b7c
|
||||
SHA512 (llvm-13.0.0rc4.src.tar.xz.sig) = 8657f257f95239553fa27d26b2573ccaf00bd59658ca3bca952663bdd99ce9e6b2aa51d890d5e3cf5100406ed414b51a032498c167aa9409e5a8c6720cd4b8db
|
||||
|
Loading…
Reference in New Issue
Block a user