64 lines
2.4 KiB
Diff
64 lines
2.4 KiB
Diff
diff --git a/libunwind/CMakeLists.txt b/libunwind/CMakeLists.txt
|
|
index 0a39d31..1198d7a 100644
|
|
--- a/libunwind/CMakeLists.txt
|
|
+++ b/libunwind/CMakeLists.txt
|
|
@@ -1,7 +1,3 @@
|
|
-if (NOT IS_DIRECTORY "${CMAKE_CURRENT_LIST_DIR}/../libcxx")
|
|
- message(FATAL_ERROR "libunwind requires being built in a monorepo layout with libcxx available")
|
|
-endif()
|
|
-
|
|
#===============================================================================
|
|
# Setup Project
|
|
#===============================================================================
|
|
@@ -46,8 +42,37 @@ include(GNUInstallDirs)
|
|
if(LIBUNWIND_STANDALONE_BUILD)
|
|
llvm_enable_language_nolink(C CXX ASM)
|
|
|
|
- # Find the LLVM sources and simulate LLVM CMake options.
|
|
- include(HandleOutOfTreeLLVM)
|
|
+ find_program(LLVM_CONFIG_PATH "llvm-config" DOC "Path to llvm-config binary")
|
|
+ if(NOT LLVM_CONFIG_PATH)
|
|
+ message(FATAL_ERROR "llvm-config not found: specify LLVM_CONFIG_PATH")
|
|
+ endif()
|
|
+
|
|
+ execute_process(COMMAND "${LLVM_CONFIG_PATH}"
|
|
+ "--obj-root"
|
|
+ "--includedir"
|
|
+ "--cmakedir"
|
|
+ "--src-root"
|
|
+ RESULT_VARIABLE HAD_ERROR
|
|
+ OUTPUT_VARIABLE LLVM_CONFIG_OUTPUT
|
|
+ OUTPUT_STRIP_TRAILING_WHITESPACE)
|
|
+ if(HAD_ERROR)
|
|
+ message(FATAL_ERROR "llvm-config failed with status ${HAD_ERROR}")
|
|
+ endif()
|
|
+
|
|
+ string(REGEX REPLACE "[ \t]*[\r\n]+[ \t]*" ";" LLVM_CONFIG_OUTPUT "${LLVM_CONFIG_OUTPUT}")
|
|
+
|
|
+ list(GET LLVM_CONFIG_OUTPUT 0 OBJ_ROOT)
|
|
+ list(GET LLVM_CONFIG_OUTPUT 1 MAIN_INCLUDE_DIR)
|
|
+ list(GET LLVM_CONFIG_OUTPUT 2 LLVM_CMAKE_PATH)
|
|
+ list(GET LLVM_CONFIG_OUTPUT 3 MAIN_SRC_DIR)
|
|
+
|
|
+ if(NOT EXISTS "${LLVM_CMAKE_PATH}/LLVMConfig.cmake")
|
|
+ message(FATAL_ERROR "LLVMConfig.cmake not found")
|
|
+ endif()
|
|
+ include("${LLVM_CMAKE_PATH}/LLVMConfig.cmake")
|
|
+
|
|
+ list(APPEND CMAKE_MODULE_PATH "${LLVM_CMAKE_PATH}")
|
|
+
|
|
|
|
# In a standalone build, we don't have llvm to automatically generate the
|
|
# llvm-lit script for us. So we need to provide an explicit directory that
|
|
diff --git a/libunwind/docs/CMakeLists.txt b/libunwind/docs/CMakeLists.txt
|
|
index 79b87eb..eaf6f3d 100644
|
|
--- a/libunwind/docs/CMakeLists.txt
|
|
+++ b/libunwind/docs/CMakeLists.txt
|
|
@@ -1,5 +1,6 @@
|
|
include(FindSphinx)
|
|
if (SPHINX_FOUND AND LLVM_ENABLE_SPHINX)
|
|
+ include(AddLLVM)
|
|
include(AddSphinxTarget)
|
|
if (${SPHINX_OUTPUT_HTML})
|
|
add_sphinx_target(html libunwind)
|