Update to 19.1.0-rc4

This commit is contained in:
Timm Bäder 2024-09-16 11:49:39 +02:00
parent 57b5b1d0a3
commit 9bdf9e1a0d
3 changed files with 18 additions and 15 deletions

View File

@ -4,16 +4,16 @@
# https://bugzilla.redhat.com/show_bug.cgi?id=2158587
%undefine _include_frame_pointers
%global maj_ver 18
%global maj_ver 19
%global min_ver 1
%global patch_ver 8
#global rc_ver 4
%global patch_ver 0
%global rc_ver 4
%global bolt_version %{maj_ver}.%{min_ver}.%{patch_ver}
%global bolt_srcdir llvm-project-%{bolt_version}%{?rc_ver:rc%{rc_ver}}.src
%global bolt_srcdir llvm-project-%{bolt_version}%{?rc_ver:-rc%{rc_ver}}.src
Name: llvm-bolt
Version: %{bolt_version}%{?rc_ver:~rc%{rc_ver}}
Release: 2%{?dist}
Release: 1%{?dist}
Summary: a post-link optimizer developed to speed up large applications
License: Apache-2.0 WITH LLVM-exception
@ -135,6 +135,7 @@ fi
rm bolt/test/X86/internal-call-instrument.s
%endif
export LIT_XFAIL="AArch64/build_id.c;AArch64/plt-call.test;X86/linux-static-keys.s;X86/plt-call.test"
export LD_LIBRARY_PATH=%{_builddir}/%{bolt_srcdir}/%{_vpath_builddir}/%{_lib}
export DESTDIR=%{buildroot}
%cmake_build --target check-bolt
@ -159,6 +160,9 @@ rm -f %{buildroot}/%{_builddir}/%{bolt_srcdir}/%{_vpath_builddir}/%{_lib}/lib*.a
%doc %{_pkgdocdir}
%changelog
* Mon Sep 16 2024 Timm Bäder <tbaeder@redhat.com> - 19.1.0~rc4-1
- Update to 19.1.0-rc4
* Thu Jul 18 2024 Fedora Release Engineering <releng@fedoraproject.org> - 18.1.8-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild

View File

@ -1,8 +1,7 @@
diff --git a/llvm/lib/CMakeLists.txt b/llvm/lib/CMakeLists.txt
index ea22ff21820a..3b535a4388b1 100644
--- a/llvm/lib/CMakeLists.txt
+++ b/llvm/lib/CMakeLists.txt
@@ -4,9 +4,7 @@ include(LLVM-Build)
diff -ruN llvm-project-19.1.0-rc4.src.orig/llvm/lib/CMakeLists.txt llvm-project-19.1.0-rc4.src/llvm/lib/CMakeLists.txt
--- llvm-project-19.1.0-rc4.src.orig/llvm/lib/CMakeLists.txt 2024-09-03 16:09:11.000000000 +0200
+++ llvm-project-19.1.0-rc4.src/llvm/lib/CMakeLists.txt 2024-09-13 16:26:26.272653588 +0200
@@ -4,9 +4,7 @@
# CMakeLists.txt
add_subdirectory(IR)
@ -12,7 +11,7 @@ index ea22ff21820a..3b535a4388b1 100644
add_subdirectory(IRPrinter)
add_subdirectory(IRReader)
add_subdirectory(CodeGen)
@@ -14,32 +12,25 @@ add_subdirectory(BinaryFormat)
@@ -16,18 +14,14 @@
add_subdirectory(Bitcode)
add_subdirectory(Bitstream)
add_subdirectory(DWARFLinker)
@ -31,9 +30,9 @@ index ea22ff21820a..3b535a4388b1 100644
add_subdirectory(Remarks)
add_subdirectory(Debuginfod)
add_subdirectory(DebugInfo)
add_subdirectory(DWP)
add_subdirectory(ExecutionEngine)
@@ -36,13 +30,10 @@
add_subdirectory(Target)
add_subdirectory(SandboxIR)
add_subdirectory(AsmParser)
-add_subdirectory(LineEditor)
add_subdirectory(ProfileData)

View File

@ -1,2 +1,2 @@
SHA512 (llvm-project-18.1.8.src.tar.xz) = 25eeee9984c8b4d0fbc240df90f33cbb000d3b0414baff5c8982beafcc5e59e7ef18f6f85d95b3a5f60cb3d4cd4f877c80487b5768bc21bc833f107698ad93db
SHA512 (llvm-project-18.1.8.src.tar.xz.sig) = ddfd1e8a06756759af6cbe488c82a6d6a62ba91f3e8a0eb4cece561321824f5d165b08ed91010588790b76e19790931d2651b24dba8567e3b151d3cb43bec25b
SHA512 (llvm-project-19.1.0-rc4.src.tar.xz) = 826978a596b26040124f2ceba858f91031f78faca22f32de2eea1a4d299a849dcb1fffdfb01601adc39d733dd0cdee43b21af05159d45dcebc842f6b6b540ba8
SHA512 (llvm-project-19.1.0-rc4.src.tar.xz.sig) = 5b9dcbf232229fdd87824bc87d0ad4ebd54127c9288708fb3304166422d378b77a843d7c5d8258850a0de59310c24e65042d636a5314e2af8513627a43bdb6e8