10464485d4
Manually set CLANG_RESOURCE_DIR based on the rpm macros in order to avoid using a path that depends on LLVM_LIBDIR_SUFFIX, which is not used anymore since 2ad36cffbc3fe9169c3c86fa794159841aae9dd0.
41 lines
1.9 KiB
Diff
41 lines
1.9 KiB
Diff
From 6888de118707e6392b46073fc35738804f9f1d80 Mon Sep 17 00:00:00 2001
|
|
From: Alex Langford <alangford@apple.com>
|
|
Date: Mon, 31 Jul 2023 16:30:17 -0700
|
|
Subject: [PATCH] [lldb] Fix building LLDB standlone without framework
|
|
|
|
In a809720102fae8d1b5a7073f99f9dae9395c5f41 I refactored some logic to
|
|
deal with the clang resource directory in standalone LLDB builds.
|
|
However, this logic escaped me because it only runs when you do not
|
|
build LLDB.framework.
|
|
|
|
Differential Revision: https://reviews.llvm.org/D156763
|
|
---
|
|
lldb/source/API/CMakeLists.txt | 10 ++++------
|
|
1 file changed, 4 insertions(+), 6 deletions(-)
|
|
|
|
diff --git a/lldb/source/API/CMakeLists.txt b/lldb/source/API/CMakeLists.txt
|
|
index a55754726c58..39ac451c471c 100644
|
|
--- a/lldb/source/API/CMakeLists.txt
|
|
+++ b/lldb/source/API/CMakeLists.txt
|
|
@@ -204,13 +204,11 @@ else()
|
|
# When building the LLDB framework, this isn't necessary as there we copy everything we need into
|
|
# the framework (including the Clang resourece directory).
|
|
if(NOT LLDB_BUILD_FRAMEWORK)
|
|
- set(LLDB_CLANG_RESOURCE_DIR_PARENT "$<TARGET_FILE_DIR:liblldb>/clang")
|
|
- file(MAKE_DIRECTORY "${LLDB_CLANG_RESOURCE_DIR_PARENT}")
|
|
+ set(LLDB_CLANG_RESOURCE_DIR "$<TARGET_FILE_DIR:liblldb>/clang")
|
|
add_custom_command(TARGET liblldb POST_BUILD
|
|
- COMMENT "Linking Clang resource dir into LLDB build directory: ${LLDB_CLANG_RESOURCE_DIR_PARENT}"
|
|
- COMMAND ${CMAKE_COMMAND} -E make_directory "${LLDB_CLANG_RESOURCE_DIR_PARENT}"
|
|
- COMMAND ${CMAKE_COMMAND} -E create_symlink "${LLDB_EXTERNAL_CLANG_RESOURCE_DIR}"
|
|
- "${LLDB_CLANG_RESOURCE_DIR_PARENT}/${LLDB_CLANG_RESOURCE_DIR_NAME}"
|
|
+ COMMENT "Linking Clang resource dir into LLDB build directory: ${LLDB_CLANG_RESOURCE_DIR}"
|
|
+ COMMAND ${CMAKE_COMMAND} -E create_symlink
|
|
+ "${LLDB_EXTERNAL_CLANG_RESOURCE_DIR}" "${LLDB_CLANG_RESOURCE_DIR}"
|
|
)
|
|
endif()
|
|
endif()
|
|
--
|
|
2.41.0
|
|
|