New upstream release fixes FTBFS

This commit is contained in:
Jesse Keating 2010-03-17 16:50:27 +00:00
parent 233d0d162f
commit be371105d0
9 changed files with 78 additions and 1239 deletions

View File

@ -1,2 +1 @@
linphone-2.1.1.tar.gz
linphone-2.1.1-auto.patch
linphone-3.2.1.tar.gz

1
import.log Normal file
View File

@ -0,0 +1 @@
linphone-3_2_1-2_fc13:HEAD:linphone-3.2.1-2.fc13.src.rpm:1268844583

File diff suppressed because it is too large Load Diff

View File

@ -1,187 +0,0 @@
diff -Naur linphone-2.1.1.orig/mediastreamer2/acinclude.m4 linphone-2.1.1/mediastreamer2/acinclude.m4
--- linphone-2.1.1.orig/mediastreamer2/acinclude.m4 2007-12-14 12:17:57.000000000 +0100
+++ linphone-2.1.1/mediastreamer2/acinclude.m4 2009-03-13 08:37:11.000000000 +0100
@@ -1,3 +1,4 @@
+dnl -*- autoconf -*-
AC_DEFUN([MS_CHECK_DEP],[
dnl $1=dependency description
dnl $2=dependency short name, will be suffixed with _CFLAGS and _LIBS
@@ -7,7 +8,7 @@
dnl $6=lib to check
dnl $7=function to check in library
- NAME=$2
+ dep_name=$2
dep_headersdir=$3
dep_libsdir=$4
dep_header=$5
@@ -15,31 +16,31 @@
dep_funclib=$7
other_libs=$8
- if test "$dep_headersdir" != "/usr/include" ; then
- eval ${NAME}_CFLAGS=\"-I$dep_headersdir \"
- fi
- eval ${NAME}_LIBS=\"-L$dep_libsdir -l$dep_lib\"
-
CPPFLAGS_save=$CPPFLAGS
LDFLAGS_save=$LDFLAGS
- CPPFLAGS="-I$dep_headersdir "
- LDFLAGS="-L$dep_libsdir "
+ LIBS_save=$LIBS
+ CPPFLAGS=`echo "-I$dep_headersdir"|sed -e "s:-I/usr/include[\ ]*$::"`
+ LIBS="-l$dep_lib"
+ LDFLAGS=`echo "-L$dep_libsdir"|sed -e "s:-L/usr/lib\(64\)*[\ ]*::"`
+ $2_CFLAGS="$CPPFLAGS"
+ $2_LIBS="$LDFLAGS $LIBS"
+
AC_CHECK_HEADERS([$dep_header],[AC_CHECK_LIB([$dep_lib],[$dep_funclib],found=yes,found=no, [$other_libs])
],found=no)
if test "$found" = "yes" ; then
- eval ${NAME}_found=yes
- AC_SUBST($2_CFLAGS)
- AC_SUBST($2_LIBS)
+ eval $2_found=yes
else
- eval ${NAME}_found=no
- eval ${NAME}_CFLAGS=
- eval ${NAME}_LIBS=
+ eval $2_found=no
+ eval $2_CFLAGS=
+ eval $2_LIBS=
fi
+ AC_SUBST($2_CFLAGS)
+ AC_SUBST($2_LIBS)
CPPFLAGS=$CPPFLAGS_save
LDFLAGS=$LDFLAGS_save
-
+ LIBS=$LIBS_save
])
@@ -72,28 +73,56 @@
AC_MSG_ERROR([Could not find ffmpeg headers and library. This is mandatory for video support])
fi
+ dnl check for new/old ffmpeg header file layout
+ CPPFLAGS_save=$CPPFLAGS
+ CPPFLAGS="$FFMPEG_CFLAGS $CPPFLAGS"
+ AC_CHECK_HEADERS(libavcodec/avcodec.h)
+ CPPFLAGS=$CPPFLAGS_save
+
dnl to workaround a bug on debian and ubuntu, check if libavcodec needs -lvorbisenc to compile
AC_CHECK_LIB(avcodec,avcodec_register_all, novorbis=yes , [
LIBS="$LIBS -lvorbisenc"
], $FFMPEG_LIBS )
- dnl check if sws_scale is available
- AC_CHECK_LIB(avcodec,sws_scale, have_sws_scale=yes , have_sws_scale=no,
- $FFMPEG_LIBS )
- if test x$have_sws_scale = xno ; then
- PKG_CHECK_MODULES(SWSCALE, [libswscale >= 0.5.0 ], need_swscale=yes, need_swscale=no)
- fi
-
- MS_CHECK_DEP([SDL],[SDL],[${libsdldir}/include],[${libsdldir}/lib],[SDL/SDL.h],[SDL],[SDL_Init])
- if test "$SDL_found" = "no" ; then
- AC_MSG_ERROR([Could not find libsdl headers and library. This is mandatory for video support])
+ dnl when swscale feature is not provided by
+ dnl libswscale, its features are swallowed by
+ dnl libavcodec, but without swscale.h and without any
+ dnl declaration into avcodec.h (this is to be
+ dnl considered as an ffmpeg bug).
+ dnl
+ dnl #if defined(HAVE_LIBAVCODEC_AVCODEC_H) && !defined(HAVE_LIBSWSCALE_SWSCALE_H)
+ dnl # include "swscale.h" // private linhone swscale.h
+ dnl #endif
+ CPPFLAGS_save=$CPPFLAGS
+ CPPFLAGS="$FFMPEG_CFLAGS $CPPFLAGS"
+ AC_CHECK_HEADERS(libswscale/swscale.h)
+ CPPFLAGS=$CPPFLAGS_save
+
+ PKG_CHECK_MODULES(SWSCALE, [libswscale >= 0.5.0 ], [echo "We have libswscale"],
+ [echo "We don't have libswscale, let's hope its symbols are in libavcodec"] )
+
+ if test "$libsdldir" != "none" ; then
+ MS_CHECK_DEP([SDL],[SDL],[${libsdldir}/include],[${libsdldir}/lib],[SDL/SDL.h],[SDL],[SDL_Init])
+ if test "$SDL_found" = "no" ; then
+ AC_MSG_ERROR([Could not find libsdl headers and library. This is mandatory for video support])
+ fi
fi
PKG_CHECK_MODULES(THEORA, [theora >= 1.0alpha7 ], [have_theora=yes],
[have_theora=no])
-
- VIDEO_CFLAGS=" $FFMPEG_CFLAGS $SDL_CFLAGS -DVIDEO_ENABLED "
- VIDEO_LIBS=" $FFMPEG_LIBS $SWSCALE_LIBS $SDL_LIBS"
+ AC_CHECK_HEADERS(X11/Xlib.h)
+
+ VIDEO_CFLAGS=" $FFMPEG_CFLAGS -DVIDEO_ENABLED"
+ VIDEO_LIBS=" $FFMPEG_LIBS $SWSCALE_LIBS"
+
+ if test "$SDL_found" = "yes" ; then
+ VIDEO_CFLAGS="$VIDEO_CFLAGS $SDL_CFLAGS -DHAVE_SDL"
+ VIDEO_LIBS="$VIDEO_LIBS $SDL_LIBS"
+ fi
+
+ if test "${ac_cv_header_X11_Xlib_h}" = "yes" ; then
+ VIDEO_LIBS="$VIDEO_LIBS -lX11"
+ fi
fi
AC_SUBST(VIDEO_CFLAGS)
diff -Naur linphone-2.1.1.orig/mediastreamer2/configure.ac linphone-2.1.1/mediastreamer2/configure.ac
--- linphone-2.1.1.orig/mediastreamer2/configure.ac 2008-01-18 23:12:55.000000000 +0100
+++ linphone-2.1.1/mediastreamer2/configure.ac 2009-03-13 08:37:11.000000000 +0100
@@ -109,10 +109,6 @@
CFLAGS="$CFLAGS -D_BIGENDIAN "
fi
-if test $GCC = yes && test $wall_werror = yes; then
- CFLAGS="$CFLAGS -Werror "
-fi
-
macosx_found=no
dnl add thread flags
diff -Naur linphone-2.1.1.orig/mediastreamer2/src/ice.c linphone-2.1.1/mediastreamer2/src/ice.c
--- linphone-2.1.1.orig/mediastreamer2/src/ice.c 2007-10-18 22:05:10.000000000 +0200
+++ linphone-2.1.1/mediastreamer2/src/ice.c 2009-03-13 08:37:11.000000000 +0100
@@ -25,6 +25,10 @@
#include <netdb.h>
#endif
+#ifndef NI_MAXHOST
+#define NI_MAXHOST 1025
+#endif
+
#include "mediastreamer2/ice.h"
#include "mediastreamer2/mscommon.h"
diff -Naur linphone-2.1.1.orig/mediastreamer2/src/Makefile.am linphone-2.1.1/mediastreamer2/src/Makefile.am
--- linphone-2.1.1.orig/mediastreamer2/src/Makefile.am 2008-01-01 01:05:54.000000000 +0100
+++ linphone-2.1.1/mediastreamer2/src/Makefile.am 2009-03-13 08:37:11.000000000 +0100
@@ -121,7 +121,7 @@
AM_CFLAGS+=$(VIDEO_CFLAGS)
endif
-imgdir=$(datadir)/images/
+imgdir=$(datadir)/images/linphone/
img_DATA=nowebcamCIF.jpg
diff -Naur linphone-2.1.1.orig/mediastreamer2/src/nowebcam.c linphone-2.1.1/mediastreamer2/src/nowebcam.c
--- linphone-2.1.1.orig/mediastreamer2/src/nowebcam.c 2007-12-14 14:37:56.000000000 +0100
+++ linphone-2.1.1/mediastreamer2/src/nowebcam.c 2009-03-13 08:37:11.000000000 +0100
@@ -83,8 +83,8 @@
mblk_t *ms_load_nowebcam(MSVideoSize *reqsize, int idx){
char tmp[256];
if (idx<0)
- snprintf(tmp, sizeof(tmp), "%s/images/%s.jpg", PACKAGE_DATA_DIR, NOWEBCAM_JPG);
+ snprintf(tmp, sizeof(tmp), "%s/images/linphone/%s.jpg", PACKAGE_DATA_DIR, NOWEBCAM_JPG);
else
- snprintf(tmp, sizeof(tmp), "%s/images/%s%i.jpg", PACKAGE_DATA_DIR, NOWEBCAM_JPG, idx);
+ snprintf(tmp, sizeof(tmp), "%s/images/linphone/%s%i.jpg", PACKAGE_DATA_DIR, NOWEBCAM_JPG, idx);
return ms_load_jpeg_as_yuv(tmp,reqsize);
}

View File

@ -0,0 +1,41 @@
--- console/Makefile.in.orig 2009-09-28 14:04:14.000000000 +0100
+++ console/Makefile.in 2010-03-15 14:17:00.968656754 +0000
@@ -332,12 +332,13 @@
@BUILD_CONSOLE_TRUE@sipomatic_SOURCES = \
@BUILD_CONSOLE_TRUE@ sipomatic.c sipomatic.h
-@BUILD_CONSOLE_TRUE@sipomatic_CFLAGS = $(COMMON_CFLAGS) $(CONSOLE_FLAGS)
+@BUILD_CONSOLE_TRUE@sipomatic_CFLAGS = $(COMMON_CFLAGS) $(CONSOLE_FLAGS) $(EXOSIP_FLAGS)
@BUILD_CONSOLE_TRUE@sipomatic_LDADD = $(INTLLIBS) \
@BUILD_CONSOLE_TRUE@ $(top_builddir)/coreapi/liblinphone.la \
@BUILD_CONSOLE_TRUE@ $(top_builddir)/mediastreamer2/src/libmediastreamer.la \
@BUILD_CONSOLE_TRUE@ $(ORTP_LIBS) \
@BUILD_CONSOLE_TRUE@ $(SPEEX_LIBS) \
+@BUILD_CONSOLE_TRUE@ $(EXOSIP_LIBS) \
@BUILD_CONSOLE_TRUE@ $(OSIP_LIBS)
@BUILD_CONSOLE_TRUE@linphonecsh_SOURCES = shell.c
--- gtk-glade/Makefile.in.orig 2009-10-02 21:09:47.000000000 +0100
+++ gtk-glade/Makefile.in 2010-03-15 14:18:24.231659156 +0000
@@ -77,7 +77,6 @@
@BUILD_GLADE_UI_TRUE@@BUILD_WIN32_TRUE@am__DEPENDENCIES_2 = \
@BUILD_GLADE_UI_TRUE@@BUILD_WIN32_TRUE@ linphone.res
@BUILD_GLADE_UI_TRUE@linphone_3_DEPENDENCIES = \
-@BUILD_GLADE_UI_TRUE@ $(top_builddir)/oRTP/src/libortp.la \
@BUILD_GLADE_UI_TRUE@ $(top_builddir)/mediastreamer2/src/libmediastreamer.la \
@BUILD_GLADE_UI_TRUE@ $(top_builddir)/coreapi/liblinphone.la \
@BUILD_GLADE_UI_TRUE@ $(am__DEPENDENCIES_1) \
@@ -339,12 +338,11 @@
@BUILD_GLADE_UI_TRUE@ linphone.h
@BUILD_GLADE_UI_TRUE@linphone_3_LDADD = \
-@BUILD_GLADE_UI_TRUE@ $(top_builddir)/oRTP/src/libortp.la \
@BUILD_GLADE_UI_TRUE@ $(top_builddir)/mediastreamer2/src/libmediastreamer.la \
@BUILD_GLADE_UI_TRUE@ $(top_builddir)/coreapi/liblinphone.la \
@BUILD_GLADE_UI_TRUE@ $(LIBGTK_LIBS) $(INTLLIBS) \
@BUILD_GLADE_UI_TRUE@ $(LIBGLADE_LIBS) $(am__append_1)
-@BUILD_GLADE_UI_TRUE@@BUILD_WIN32_FALSE@linphone_3_LDFLAGS = -export-dynamic
+@BUILD_GLADE_UI_TRUE@@BUILD_WIN32_FALSE@linphone_3_LDFLAGS = -export-dynamic -losipparser2 $(ORTP_LIBS)
@BUILD_GLADE_UI_TRUE@@BUILD_WIN32_TRUE@linphone_3_LDFLAGS = -Wl,--export-all-symbols -mwindows
@BUILD_GLADE_UI_TRUE@gladedir = $(datadir)/linphone
@BUILD_GLADE_UI_TRUE@glade_DATA = $(GLADE_FILES) $(PIXMAPS) $(top_srcdir)/COPYING

View File

@ -0,0 +1,12 @@
--- linphone-3.2.1/share/linphone.desktop.orig 2009-06-16 11:49:48.000000000 +0100
+++ linphone-3.2.1/share/linphone.desktop 2010-03-15 15:51:02.126659419 +0000
@@ -5,6 +5,6 @@
Comment[de]=Linphone ist ein web-phone.
Type=Application
Exec=linphone-3
-Icon=linphone/linphone2.png
+Icon=linphone2
Terminal=false
-Categories=Application;Network;
\ No newline at end of file
+Categories=Application;Network;

View File

@ -1,31 +1,27 @@
Name: linphone
Version: 2.1.1
Release: 4%{?dist}
Version: 3.2.1
Release: 2%{?dist}
Summary: Phone anywhere in the whole world by using the Internet
Group: Applications/Communications
License: GPLv2+
URL: http://www.linphone.org/
Source0: http://download.savannah.nongnu.org/releases/linphone/2.1.x/sources/%{name}-%{version}.tar.gz
Patch0: linphone-2.1.1-configure.patch
Patch1: linphone-2.1.1-mediastreamer.patch
Patch2: linphone-2.1.1-oRTP.patch
Source0: http://download.savannah.nongnu.org/releases/linphone/3.2.x/sources/%{name}-%{version}.tar.gz
Patch1: linphone-3.2.1-Makefile.in.patch
Patch2: linphone-3.2.1-oRTP.patch
Patch3: linphone-3.2.1-desktop.patch
# This patch is generated by
# autoreconf -fi
# with the patches above applied
Patch10: linphone-2.1.1-auto.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: libosip2-devel >= 3.1.0
BuildRequires: libeXosip2-devel >= 3.1.0
BuildRequires: ortp-devel >= 0.14.2
BuildRequires: ortp-devel >= 0.16.1
BuildRequires: readline-devel
BuildRequires: ncurses-devel
BuildRequires: gtk2-devel
BuildRequires: gtk2-devel >= 2.16
BuildRequires: alsa-lib-devel
BuildRequires: speex-devel >= 1.2
@ -35,7 +31,7 @@ BuildRequires: desktop-file-utils
BuildRequires: perl(XML::Parser)
BuildRequires: docbook-utils
BuildRequires: libglade2-devel
BuildRequires: intltool
@ -65,16 +61,9 @@ Libraries and headers required to develop software with linphone.
%prep
%setup0 -q
%patch0 -p1
%patch1 -p1
%patch1 -p0
%patch2 -p1
%patch10 -p1
# Make sure autotools are not rerun
touch -r aclocal.m4 configure*
touch -r mediastreamer2/aclocal.m4 mediastreamer2/configure*
touch -r oRTP/aclocal.m4 oRTP/configure*
%patch3 -p1
# Fix encoding
for f in share/cs/*.1; do
@ -107,7 +96,6 @@ rm -rf $RPM_BUILD_ROOT
make install DESTDIR=$RPM_BUILD_ROOT
install -p -m 0644 pixmaps/linphone2.png $RPM_BUILD_ROOT%{_datadir}/pixmaps
%find_lang %{name}
rm $RPM_BUILD_ROOT%{_datadir}/gnome/apps/Internet/linphone.desktop
desktop-file-install --vendor=fedora \
--delete-original \
--dir $RPM_BUILD_ROOT%{_datadir}/applications \
@ -138,7 +126,8 @@ rm -rf $RPM_BUILD_ROOT
%{_datadir}/pixmaps/linphone
%{_datadir}/pixmaps/linphone2.png
%{_datadir}/sounds/linphone
%{_datadir}/images/linphone
%{_datadir}/images
%{_datadir}/linphone
%files devel
%defattr(-,root,root)
@ -147,8 +136,17 @@ rm -rf $RPM_BUILD_ROOT
%{_libdir}/liblinphone.so
%{_libdir}/libmediastreamer.so
%{_libdir}/pkgconfig/*
# This dir seems to have gone away with new release - JK 3/17/2010
#%%doc %{_datadir}/doc/mediastreamer/
%changelog
* Wed Mar 17 2010 Jesse Keating <jkeating@redhat.com> - 3.2.1-2
- Apply patches from bug 555510 to update linphone
- Drop the doc/mediastreamer dir from devel package
* Mon Mar 01 2010 Adam Jackson <ajax@redhat.com> 2.1.1-5
- Rebuild for libortp.so.7
* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.1-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild

View File

@ -1,2 +1 @@
130fb6048f84ee89f7c1a8a010ff1add linphone-2.1.1.tar.gz
fef0a88ae97394fca6b5315489c93432 linphone-2.1.1-auto.patch
434b163f37107c8bedb535d5ce044119 linphone-3.2.1.tar.gz