Update to 1.7.1

This commit is contained in:
Jeffrey C. Ollie 2007-04-23 16:36:34 +00:00
parent 1058ccfcde
commit b6b616362c
6 changed files with 106 additions and 19 deletions

View File

@ -1 +1 @@
linphone-1.6.0.tar.gz linphone-1.7.1.tar.gz

View File

@ -0,0 +1,27 @@
From 6ebb0b61d9634dd24db0148b05f383977474aa44 Mon Sep 17 00:00:00 2001
From: Jeffrey C. Ollie <jeff@ocjtech.us>
Date: Mon, 23 Apr 2007 10:22:34 -0500
Subject: [PATCH] Use OSIP_CFLAGS to compile gtk front end.
Signed-off-by: Jeffrey C. Ollie <jeff@ocjtech.us>
---
gtk/Makefile.am | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/gtk/Makefile.am b/gtk/Makefile.am
index b98149d..cb05421 100644
--- a/gtk/Makefile.am
+++ b/gtk/Makefile.am
@@ -20,7 +20,7 @@ INCLUDES = \
$(ORTP_CFLAGS) \
-I$(top_srcdir)/coreapi \
-I$(top_srcdir)/mediastreamer2/include \
- -I$(osip_prefix)/include
+ $(OSIP_CFLAGS)
--
1.5.1.2

View File

@ -0,0 +1,28 @@
diff --git a/mediastreamer2/src/Makefile.am b/mediastreamer2/src/Makefile.am
index 4940246..3e1df60 100644
--- a/mediastreamer2/src/Makefile.am
+++ b/mediastreamer2/src/Makefile.am
@@ -105,7 +105,7 @@ AM_CFLAGS= -I$(top_srcdir) \
$(GSM_CFLAGS) \
$(STRICT_OPTIONS)
-imgdir=$(datadir)/images/
+imgdir=$(datadir)/images/linphone/
img_DATA=nowebcamCIF.jpg
diff --git a/mediastreamer2/src/nowebcam.c b/mediastreamer2/src/nowebcam.c
index 6e06ee6..917a927 100644
--- a/mediastreamer2/src/nowebcam.c
+++ b/mediastreamer2/src/nowebcam.c
@@ -81,8 +81,8 @@ mblk_t *ms_load_jpeg_as_yuv(const char *jpgpath, MSVideoSize *reqsize){
mblk_t *ms_load_nowebcam(MSVideoSize *reqsize, int idx){
char tmp[256];
if (idx<0)
- snprintf(tmp, sizeof(tmp), "%s/images/%s.jpg", PACKAGE_DATA_DIR, NOWEBCAM_JPG);
+ snprintf(tmp, sizeof(tmp), "%s/images/linphone/%s.jpg", PACKAGE_DATA_DIR, NOWEBCAM_JPG);
else
- snprintf(tmp, sizeof(tmp), "%s/images/%s%i.jpg", PACKAGE_DATA_DIR, NOWEBCAM_JPG, idx);
+ snprintf(tmp, sizeof(tmp), "%s/images/linphone/%s%i.jpg", PACKAGE_DATA_DIR, NOWEBCAM_JPG, idx);
return ms_load_jpeg_as_yuv(tmp,reqsize);
}

View File

@ -0,0 +1,23 @@
diff --git a/m4/ortp.m4 b/m4/ortp.m4
new file mode 100644
index 0000000..f0c0216
--- /dev/null
+++ b/m4/ortp.m4
@@ -0,0 +1,17 @@
+AC_DEFUN([LP_CHECK_ORTP],[
+
+ortp_pkgconfig=true
+
+PKG_CHECK_MODULES([ORTP], [ortp], , [ortp_pkgconfig=false])
+
+if test $ortp_pkgconfig = false; then
+ AC_CHECK_HEADER([ortp/ortp.h], ,AC_MSG_ERROR([Could not find oRTP headers !]))
+ LIBS_save=$LIBS
+ AC_CHECK_LIB([ortp], [ortp_init], , AC_MSG_ERROR([Could not find oRTP library]))
+ ORTP_LIBS='-lortp'
+ LIBS=$LIBS_save
+fi
+AC_SUBST([ORTP_LIBS])
+AC_SUBST([ORTP_CFLAGS])
+
+])

View File

@ -1,26 +1,24 @@
Name: linphone Name: linphone
Version: 1.6.0 Version: 1.7.1
Release: 4%{?dist} Release: 1%{?dist}
Summary: Phone anywhere in the whole world by using the Internet Summary: Phone anywhere in the whole world by using the Internet
Group: Applications/Communications Group: Applications/Communications
License: GPL License: GPL
URL: http://www.linphone.org/ URL: http://www.linphone.org/
Source0: http://download.savannah.nongnu.org/releases/linphone/1.6.x/sources/%{name}-%{version}.tar.gz Source0: http://download.savannah.nongnu.org/releases/linphone/1.7.x/sources/%{name}-%{version}.tar.gz
Patch: linphone-1.0.1-desktop.patch Patch0: linphone-1.7.1-ortpm4.patch
Patch1: linphone-1.4.1-libs.patch Patch1: linphone-1.7.1-imagedir.patch
Patch2: linphone-1.5.1-osipcompat.patch Patch2: linphone-1.7.1-gtkosip.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: compat-libosip2-devel BuildRequires: compat-libosip2-devel
BuildRequires: ortp-devel = 0.13.0 BuildRequires: ortp-devel >= 0.13.1
BuildRequires: readline-devel BuildRequires: readline-devel
BuildRequires: ncurses-devel BuildRequires: ncurses-devel
BuildRequires: gnome-panel-devel BuildRequires: gtk2-devel
BuildRequires: libgnomeui-devel
BuildRequires: glib2-devel
BuildRequires: alsa-lib-devel BuildRequires: alsa-lib-devel
BuildRequires: speex-devel >= 1.2 BuildRequires: speex-devel >= 1.2
@ -29,6 +27,8 @@ BuildRequires: desktop-file-utils
BuildRequires: perl(XML::Parser) BuildRequires: perl(XML::Parser)
BuildRequires: docbook-utils
BuildRequires: automake BuildRequires: automake
BuildRequires: autoconf BuildRequires: autoconf
BuildRequires: libtool BuildRequires: libtool
@ -61,11 +61,15 @@ Libraries and headers required to develop software with linphone.
%prep %prep
%setup0 -q %setup0 -q
%patch0 -p1 -b .old %patch0 -p1 -b .ortpm4
%patch1 -p1 -b .libs %patch1 -p1 -b .imagedir
%patch2 -p0 -b .osip %patch2 -p1 -b .gtkosip
rm -r oRTP #patch0 -p1 -b .old
#patch1 -p1 -b .libs
#patch2 -p0 -b .osip
#rm -r oRTP
pushd share/cs pushd share/cs
for f in *.1 for f in *.1
@ -75,6 +79,7 @@ done
popd popd
%build %build
libtoolize --copy --force libtoolize --copy --force
aclocal -I m4 aclocal -I m4
autoheader autoheader
@ -90,7 +95,7 @@ automake --force-missing --add-missing --copy
autoconf autoconf
popd popd
%configure --disable-static --disable-video %configure --disable-static --disable-rpath --disable-video --enable-alsa --enable-strict --enable-external-ortp --with-osip-version=2.2.2
make %{?_smp_mflags} make %{?_smp_mflags}
%install %install
@ -119,7 +124,6 @@ rm -rf $RPM_BUILD_ROOT
%defattr(-,root,root) %defattr(-,root,root)
%doc AUTHORS ChangeLog COPYING NEWS README TODO %doc AUTHORS ChangeLog COPYING NEWS README TODO
%{_bindir}/* %{_bindir}/*
%{_libdir}/bonobo/servers/*.server
%{_libdir}/liblinphone.so.* %{_libdir}/liblinphone.so.*
%{_libdir}/libmediastreamer.so.* %{_libdir}/libmediastreamer.so.*
%{_libdir}/libquickstream.so.* %{_libdir}/libquickstream.so.*
@ -128,10 +132,10 @@ rm -rf $RPM_BUILD_ROOT
%lang(cs) %{_mandir}/cs/man1/* %lang(cs) %{_mandir}/cs/man1/*
%{_datadir}/applications/*%{name}.desktop %{_datadir}/applications/*%{name}.desktop
%{_datadir}/gnome/help/linphone %{_datadir}/gnome/help/linphone
%{_datadir}/gnome-2.0/ui/*.xml
%{_datadir}/pixmaps/linphone %{_datadir}/pixmaps/linphone
%{_datadir}/pixmaps/linphone2.png %{_datadir}/pixmaps/linphone2.png
%{_datadir}/sounds/linphone %{_datadir}/sounds/linphone
%{_datadir}/images/linphone
%files devel %files devel
%defattr(-,root,root) %defattr(-,root,root)
@ -143,6 +147,11 @@ rm -rf $RPM_BUILD_ROOT
%{_libdir}/pkgconfig/* %{_libdir}/pkgconfig/*
%changelog %changelog
* Tue Apr 17 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.7.1-1
- Update to 1.7.1
- Drop linphone-1.0.1-desktop.patch, linphone-1.4.1-libs.patch and
linphone-1.5.1-osipcompat.patch
* Fri Mar 16 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.6.0-4 * Fri Mar 16 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.6.0-4
- Fix up encodings in Czech manpages - Fix up encodings in Czech manpages

View File

@ -1 +1 @@
fb345125e23c787df0818ff7caad5515 linphone-1.6.0.tar.gz 6fe246d072fad2f4a9533317ab7e9060 linphone-1.7.1.tar.gz