This commit is contained in:
corsepiu 2009-03-13 12:13:51 +00:00
parent 2b822611ff
commit b6131d2690
3 changed files with 0 additions and 83 deletions

View File

@ -1,41 +0,0 @@
From da74486ae265d7736032e4e51602d54449de11b0 Mon Sep 17 00:00:00 2001
From: Jeffrey C. Ollie <jeff@ocjtech.us>
Date: Tue, 17 Apr 2007 15:27:06 -0500
Subject: [PATCH] Move nowebcam image to subdir.
---
mediastreamer2/src/Makefile.am | 2 +-
mediastreamer2/src/nowebcam.c | 4 ++--
2 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/mediastreamer2/src/Makefile.am b/mediastreamer2/src/Makefile.am
index 9c9050c..8717329 100644
--- a/mediastreamer2/src/Makefile.am
+++ b/mediastreamer2/src/Makefile.am
@@ -121,7 +121,7 @@ if BUILD_VIDEO
AM_CFLAGS+=$(VIDEO_CFLAGS)
endif
-imgdir=$(datadir)/images/
+imgdir=$(datadir)/images/linphone/
img_DATA=nowebcamCIF.jpg
diff --git a/mediastreamer2/src/nowebcam.c b/mediastreamer2/src/nowebcam.c
index 1c694f9..f8eaaf9 100644
--- a/mediastreamer2/src/nowebcam.c
+++ b/mediastreamer2/src/nowebcam.c
@@ -85,8 +85,8 @@ mblk_t *ms_load_jpeg_as_yuv(const char *jpgpath, MSVideoSize *reqsize){
mblk_t *ms_load_nowebcam(MSVideoSize *reqsize, int idx){
char tmp[256];
if (idx<0)
- snprintf(tmp, sizeof(tmp), "%s/images/%s.jpg", PACKAGE_DATA_DIR, NOWEBCAM_JPG);
+ snprintf(tmp, sizeof(tmp), "%s/images/linphone/%s.jpg", PACKAGE_DATA_DIR, NOWEBCAM_JPG);
else
- snprintf(tmp, sizeof(tmp), "%s/images/%s%i.jpg", PACKAGE_DATA_DIR, NOWEBCAM_JPG, idx);
+ snprintf(tmp, sizeof(tmp), "%s/images/linphone/%s%i.jpg", PACKAGE_DATA_DIR, NOWEBCAM_JPG, idx);
return ms_load_jpeg_as_yuv(tmp,reqsize);
}
--
1.5.3.8

View File

@ -1,15 +0,0 @@
diff --git a/mediastreamer2/src/ice.c b/mediastreamer2/src/ice.c
index c4296c0..615c7ab 100644
--- a/mediastreamer2/src/ice.c
+++ b/mediastreamer2/src/ice.c
@@ -25,6 +25,10 @@ Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
#include <netdb.h>
#endif
+#ifndef NI_MAXHOST
+#define NI_MAXHOST 1025
+#endif
+
#include "mediastreamer2/ice.h"
#include "mediastreamer2/mscommon.h"

View File

@ -1,27 +0,0 @@
diff --git a/configure.in b/configure.in
index 3cb7bf7..307679b 100644
--- a/configure.in
+++ b/configure.in
@@ -275,7 +275,6 @@ AC_ARG_ENABLE(strict,
if test "$GCC$strictness" = "yesyes" ; then
STRICT_OPTIONS="-Wall -Wp,-D_FORTIFY_SOURCE=2"
- STRICT_OPTIONS="$STRICT_OPTIONS -Werror"
CFLAGS="$CFLAGS -fno-strict-aliasing"
fi
diff --git a/mediastreamer2/configure.ac b/mediastreamer2/configure.ac
index f663b56..18c1e30 100644
--- a/mediastreamer2/configure.ac
+++ b/mediastreamer2/configure.ac
@@ -109,10 +109,6 @@ if test x$ac_cv_c_bigendian = xyes ; then
CFLAGS="$CFLAGS -D_BIGENDIAN "
fi
-if test $GCC = yes && test $wall_werror = yes; then
- CFLAGS="$CFLAGS -Werror "
-fi
-
macosx_found=no
dnl add thread flags