Update to 1.5.0

This commit is contained in:
Jeffrey C. Ollie 2006-11-09 17:52:58 +00:00
parent b6a77f9300
commit 17d731b50c
9 changed files with 100 additions and 265 deletions

View File

@ -1 +1 @@
linphone-1.2.0.tar.gz linphone-1.5.0.tar.gz

View File

@ -1,25 +0,0 @@
--- linphone-0.12.2/share/linphone.pc.in.orig 2005-03-23 21:10:49.392763407 -0500
+++ linphone-0.12.2/share/linphone.pc.in 2005-03-23 21:11:21.983938389 -0500
@@ -1,7 +1,7 @@
-prefix=@prefix@
-exec_prefix=${prefix}
-libdir=${exec_prefix}/lib
-includedir=${prefix}/include
+prefix=@prefix@
+exec_prefix=@exec_prefix@
+libdir=@libdir@
+includedir=@includedir@
Name: liblinphone
--- linphone-1.0.1/share/Makefile.in.pkgconfig 2005-03-23 03:17:48.000000000 -0500
+++ linphone-1.0.1/share/Makefile.in 2005-03-24 13:40:41.828557116 -0500
@@ -286,7 +286,7 @@
#to be compliant with freedesktop.org:
linphone_fddir = $(prefix)/share/applications/
linphone_fd_DATA = linphone.desktop
-pkgconfigdir = $(prefix)/lib/pkgconfig
+pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = linphone.pc
EXTRA_DIST = $(LINPHONE_SOUNDS) \
$(LINPHONE_RINGS) \

View File

@ -1,13 +0,0 @@
--- linphone-1.1.0/configure.Werror 2005-12-05 17:54:55.000000000 -0500
+++ linphone-1.1.0/configure 2005-12-05 17:55:13.000000000 -0500
@@ -23816,10 +23816,6 @@
;;
esac
-if test "$GCC" = "yes" ; then
- STRICT_OPTIONS="-Wall -Werror"
-fi
-
# Check whether --with-realprefix or --without-realprefix was given.

View File

@ -1,11 +0,0 @@
--- linphone-1.2.0/gnome/addressbook.c.gtkentry 2006-01-22 10:22:24.000000000 -0500
+++ linphone-1.2.0/gnome/addressbook.c 2006-01-22 10:23:12.000000000 -0500
@@ -164,7 +164,7 @@
gtk_tree_model_get (model, &iter,SIP_ADDRESS_COLUMN , &address, -1);
}
if (address!=NULL){
- gtk_entry_set_text (GTK_ENTRY(gnome_entry_gtk_entry(GNOME_ENTRY(addressentry))),address);
+ gtk_entry_set_text (GTK_ENTRY(addressentry),address);
g_free(address);
}
gtk_widget_destroy(ab);

View File

@ -1,29 +0,0 @@
--- linphone-1.2.0/mediastreamer/audiostream.c.maxrtp 2006-01-03 04:26:06.000000000 -0500
+++ linphone-1.2.0/mediastreamer/audiostream.c 2006-01-03 04:26:28.000000000 -0500
@@ -112,7 +112,7 @@
RtpSession **recvsend){
RtpSession *rtpr;
rtpr=rtp_session_new(RTP_SESSION_SENDRECV);
- rtp_session_max_buf_size_set(rtpr,MAX_RTP_SIZE);
+/* rtp_session_max_buf_size_set(rtpr,MAX_RTP_SIZE);*/
rtp_session_set_profile(rtpr,profile);
rtp_session_set_local_addr(rtpr,get_local_addr_for(remip),locport);
if (remport>0) rtp_session_set_remote_addr(rtpr,remip,remport);
@@ -133,7 +133,7 @@
/* creates two rtp filters to recv send streams (remote part)*/
rtps=rtp_session_new(RTP_SESSION_SENDONLY);
- rtp_session_max_buf_size_set(rtps,MAX_RTP_SIZE);
+/* rtp_session_max_buf_size_set(rtps,MAX_RTP_SIZE);*/
rtp_session_set_profile(rtps,profile);
#ifdef INET6
rtp_session_set_local_addr(rtps,"::",locport+2);
@@ -147,7 +147,7 @@
rtp_session_set_jitter_compensation(rtps,jitt_comp);
rtpr=rtp_session_new(RTP_SESSION_RECVONLY);
- rtp_session_max_buf_size_set(rtpr,MAX_RTP_SIZE);
+/* rtp_session_max_buf_size_set(rtpr,MAX_RTP_SIZE);*/
rtp_session_set_profile(rtpr,profile);
#ifdef INET6
rtp_session_set_local_addr(rtpr,"::",locport);

View File

@ -1,164 +0,0 @@
--- linphone-1.2.0/gnome/Makefile.in.ortp 2005-12-16 17:05:06.000000000 -0500
+++ linphone-1.2.0/gnome/Makefile.in 2006-01-03 00:58:20.000000000 -0500
@@ -340,8 +340,7 @@
@BUILD_GNOME_TRUE@INCLUDES = \
@BUILD_GNOME_TRUE@ -I$(top_srcdir)\
@BUILD_GNOME_TRUE@ -I$(top_srcdir)/intl \
-@BUILD_GNOME_TRUE@ -I$(top_srcdir)/oRTP/src \
-@BUILD_GNOME_TRUE@ -I$(top_srcdir)/oRTP/ \
+@BUILD_GNOME_TRUE@ -I$(includedir)/ortp/ \
@BUILD_GNOME_TRUE@ -I$(top_srcdir)/mediastreamer \
@BUILD_GNOME_TRUE@ -I$(top_srcdir)/speex/libspeex \
@BUILD_GNOME_TRUE@ -I$(top_srcdir)/coreapi \
--- linphone-1.2.0/coreapi/Makefile.in.ortp 2005-12-16 17:05:05.000000000 -0500
+++ linphone-1.2.0/coreapi/Makefile.in 2006-01-03 00:58:20.000000000 -0500
@@ -289,8 +289,7 @@
INCLUDES = \
-I$(top_srcdir)\
-I$(top_srcdir)/exosip\
- -I$(top_srcdir)/oRTP/include \
- -I$(top_srcdir)/oRTP/ \
+ -I$(includedir)/ortp/ \
-I$(top_srcdir)/mediastreamer \
$(SPEEX_CFLAGS) \
-I$(osip_prefix)/include/
--- linphone-1.2.0/Makefile.in.ortp 2005-12-16 17:05:05.000000000 -0500
+++ linphone-1.2.0/Makefile.in 2006-01-03 00:58:20.000000000 -0500
@@ -61,7 +61,7 @@
uninstall-recursive
ETAGS = etags
CTAGS = ctags
-DIST_SUBDIRS = m4 support pixmaps po ipkg oRTP gsmlib lpc10-1.5 \
+DIST_SUBDIRS = m4 support pixmaps po ipkg gsmlib lpc10-1.5 \
win32acm mediastreamer mediastreamer2 media_api exosip coreapi \
console gnome share developer-docs
DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
@@ -274,7 +274,7 @@
sysconfdir = @sysconfdir@
target_alias = @target_alias@
@BUILD_TRUESPEECH_TRUE@WIN32ACM_DIR = win32acm
-SUBDIRS = m4 support pixmaps po ipkg oRTP gsmlib lpc10-1.5 \
+SUBDIRS = m4 support pixmaps po ipkg gsmlib lpc10-1.5 \
$(WIN32ACM_DIR) mediastreamer mediastreamer2\
media_api exosip coreapi console gnome share developer-docs
--- linphone-1.2.0/console/Makefile.in.ortp 2005-12-16 17:05:05.000000000 -0500
+++ linphone-1.2.0/console/Makefile.in 2006-01-03 00:58:20.000000000 -0500
@@ -281,8 +281,7 @@
-I$(top_srcdir)/coreapi\
-I$(top_srcdir)/osipua/\
-I$(top_srcdir)/osipua/src \
- -I$(top_srcdir)/oRTP/include \
- -I$(top_srcdir)/oRTP/ \
+ -I$(includedir)/ortp/ \
-I$(top_srcdir)/mediastreamer \
$(SPEEX_CFLAGS)\
-I$(osip_prefix)/include \
--- linphone-1.2.0/mediastreamer/Makefile.in.ortp 2005-12-16 17:05:07.000000000 -0500
+++ linphone-1.2.0/mediastreamer/Makefile.in 2006-01-03 00:58:20.000000000 -0500
@@ -67,7 +67,7 @@
@BUILD_TRUESPEECH_TRUE@am__DEPENDENCIES_3 = ../win32acm/libwin32acm.a
libmediastreamer_la_DEPENDENCIES = $(am__DEPENDENCIES_1) \
../gsmlib/libgsm.la ../lpc10-1.5/liblpc10.la \
- ../oRTP/src/libortp.la $(am__DEPENDENCIES_1) \
+ $(am__DEPENDENCIES_1) \
$(am__DEPENDENCIES_1) $(am__DEPENDENCIES_2) \
$(am__DEPENDENCIES_1) $(am__DEPENDENCIES_3) \
$(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1)
@@ -348,6 +348,7 @@
MKINSTALLDIRS = @MKINSTALLDIRS@
MSGFMT = @MSGFMT@
OBJEXT = @OBJEXT@
+ORTP_LIBS = -lortp
OSIP_CFLAGS = @OSIP_CFLAGS@
OSIP_LIBS = @OSIP_LIBS@
PACKAGE = @PACKAGE@
@@ -485,7 +486,7 @@
libmediastreamer_la_LIBADD = $(GLIB_LIBS) \
../gsmlib/libgsm.la \
../lpc10-1.5/liblpc10.la \
- ../oRTP/src/libortp.la \
+ $(ORTP_LIBS) \
$(JACK_LIBS)\
$(SAMPLERATE_LIBS)\
$(SUPPORTLIB) \
@@ -551,8 +552,7 @@
INCLUDES = -I$(top_srcdir) \
-I$(top_srcdir)/mediastreamer \
- -I$(top_srcdir)/oRTP/include \
- -I$(top_srcdir)/oRTP \
+ -I$(includedir)/ortp \
-I$(top_srcdir)/gsmlib \
-I$(top_srcdir)/lpc10-1.5 \
$(SPEEX_CFLAGS) \
--- linphone-1.2.0/mediastreamer2/Makefile.in.ortp 2005-12-16 17:05:07.000000000 -0500
+++ linphone-1.2.0/mediastreamer2/Makefile.in 2006-01-03 00:58:20.000000000 -0500
@@ -54,7 +54,7 @@
@BUILD_UGLIB_TRUE@ $(top_builddir)/support/libuglib.la
libmediastreamer2_la_DEPENDENCIES = $(am__DEPENDENCIES_1) \
../gsmlib/libgsm.la ../lpc10-1.5/liblpc10.la \
- ../oRTP/src/libortp.la $(am__DEPENDENCIES_1) \
+ $(am__DEPENDENCIES_1) \
$(am__DEPENDENCIES_2) $(am__DEPENDENCIES_1) \
$(am__DEPENDENCIES_1)
am_libmediastreamer2_la_OBJECTS = msfilter.lo msAlawdec.lo \
@@ -213,6 +213,7 @@
MKINSTALLDIRS = @MKINSTALLDIRS@
MSGFMT = @MSGFMT@
OBJEXT = @OBJEXT@
+ORTP_LIBS = -lortp
OSIP_CFLAGS = @OSIP_CFLAGS@
OSIP_LIBS = @OSIP_LIBS@
PACKAGE = @PACKAGE@
@@ -313,7 +314,7 @@
libmediastreamer2_la_LIBADD = $(GLIB_LIBS) \
../gsmlib/libgsm.la \
../lpc10-1.5/liblpc10.la \
- ../oRTP/src/libortp.la \
+ $(ORTP_LIBS) \
$(JACK_LIBS)\
$(SUPPORTLIB) \
$(ALSA_LIBS) \
@@ -322,8 +323,7 @@
AM_CFLAGS = $(GLIB_CFLAGS) -DG_LOG_DOMAIN=\"MediaStreamer\" $(TRUESPEECH_CFLAGS) $(IPV6_CFLAGS)
INCLUDES = -I$(top_srcdir) \
-I$(top_srcdir)/mediastreamer2 \
- -I$(top_srcdir)/oRTP/include \
- -I$(top_srcdir)/oRTP \
+ -I$(includedir)/ortp \
-I$(top_srcdir)/gsmlib \
-I$(top_srcdir)/lpc10-1.5 \
$(SPEEX_CFLAGS)
--- linphone-1.2.0/media_api/Makefile.in.ortp 2005-12-16 17:05:07.000000000 -0500
+++ linphone-1.2.0/media_api/Makefile.in 2006-01-03 00:58:20.000000000 -0500
@@ -299,8 +299,7 @@
INCLUDES = -I$(top_srcdir)/mediastreamer \
-I$(top_srcdir)/speex \
-I$(top_srcdir)/gsmlib \
- -I$(top_srcdir)/oRTP \
- -I$(top_srcdir)/oRTP/src \
+ -I$(includedir)/ortp \
-I$(top_srcdir)/lpc10-1.5 \
-I$(top_srcdir)/ffmpeg
--- linphone-1.2.0/configure.ortp 2005-12-16 17:05:11.000000000 -0500
+++ linphone-1.2.0/configure 2006-01-03 00:59:50.000000000 -0500
@@ -463,7 +463,6 @@
# include <unistd.h>
#endif"
-ac_subdirs_all="$ac_subdirs_all oRTP"
ac_subst_vars='SHELL PATH_SEPARATOR PACKAGE_NAME PACKAGE_TARNAME PACKAGE_VERSION PACKAGE_STRING PACKAGE_BUGREPORT exec_prefix prefix program_transform_name bindir sbindir libexecdir datadir sysconfdir sharedstatedir localstatedir libdir includedir oldincludedir infodir mandir build_alias host_alias target_alias DEFS ECHO_C ECHO_N ECHO_T LIBS LIBLINPHONE_SO_VERSION LINPHONE_VERSION INSTALL_PROGRAM INSTALL_SCRIPT INSTALL_DATA CYGPATH_W PACKAGE VERSION ACLOCAL AUTOCONF AUTOMAKE AUTOHEADER MAKEINFO AMTAR install_sh STRIP ac_ct_STRIP INSTALL_STRIP_PROGRAM mkdir_p AWK SET_MAKE am__leading_dot CC CFLAGS LDFLAGS CPPFLAGS ac_ct_CC EXEEXT OBJEXT DEPDIR am__include am__quote AMDEP_TRUE AMDEP_FALSE AMDEPBACKSLASH CCDEPMODE am__fastdepCC_TRUE am__fastdepCC_FALSE CPP EGREP INTLTOOL_DESKTOP_RULE INTLTOOL_DIRECTORY_RULE INTLTOOL_KEYS_RULE INTLTOOL_PROP_RULE INTLTOOL_OAF_RULE INTLTOOL_PONG_RULE INTLTOOL_SERVER_RULE INTLTOOL_SHEET_RULE INTLTOOL_SOUNDLIST_RULE INTLTOOL_UI_RULE INTLTOOL_XAM_RULE INTLTOOL_KBD_RULE INTLTOOL_XML_RULE INTLTOOL_XML_NOMERGE_RULE INTLTOOL_CAVES_RULE INTLTOOL_SCHEMAS_RULE INTLTOOL_THEME_RULE INTLTOOL_EXTRACT INTLTOOL_MERGE INTLTOOL_UPDATE INTLTOOL_PERL INTLTOOL_ICONV INTLTOOL_MSGFMT INTLTOOL_MSGMERGE INTLTOOL_XGETTEXT build build_cpu build_vendor build_os host host_cpu host_vendor host_os LN_S ECHO AR ac_ct_AR RANLIB ac_ct_RANLIB CXX CXXFLAGS ac_ct_CXX CXXDEPMODE am__fastdepCXX_TRUE am__fastdepCXX_FALSE CXXCPP F77 FFLAGS ac_ct_F77 LIBTOOL GETTEXT_PACKAGE USE_NLS MSGFMT GMSGFMT XGETTEXT CATALOGS CATOBJEXT DATADIRNAME GMOFILES INSTOBJEXT INTLLIBS PO_IN_DATADIR_TRUE PO_IN_DATADIR_FALSE POFILES POSUB MKINSTALLDIRS PKG_CONFIG GLIB_CFLAGS GLIB_LIBS GLIB_GENMARSHAL GOBJECT_QUERY GLIB_MKENUMS ac_pt_PKG_CONFIG LIBGNOMEUI_CFLAGS LIBGNOMEUI_LIBS LIBGNOME_CFLAGS LIBGNOME_LIBS LIBGTK_CFLAGS LIBGTK_LIBS GNOME_APPLETS_CFLAGS GNOME_APPLETS_LIBS STRICT_OPTIONS IPV6_CFLAGS TRUESPEECH_CFLAGS BUILD_TRUESPEECH_TRUE BUILD_TRUESPEECH_FALSE JACK_CFLAGS JACK_LIBS SAMPLERATE_CFLAGS SAMPLERATE_LIBS osip_prefix OSIP_CFLAGS OSIP_LIBS EXOSIP_CFLAGS EXOSIP_LIBS SPEEX_CFLAGS SPEEX_LIBS ${NAME}_CFLAGS ${NAME}_LIBS VIDEO_CFLAGS VIDEO_LIBS BUILD_MEDIASTREAMER_TRUE BUILD_MEDIASTREAMER_FALSE BUILD_MEDIA_API_TRUE BUILD_MEDIA_API_FALSE BUILD_UGLIB_TRUE BUILD_UGLIB_FALSE BUILD_GNOME_TRUE BUILD_GNOME_FALSE BUILD_GNOME_APPLET_TRUE BUILD_GNOME_APPLET_FALSE BUILD_SPEEX_TRUE BUILD_SPEEX_FALSE ARMBUILD_TRUE ARMBUILD_FALSE BUILD_VIDEO_TRUE BUILD_VIDEO_FALSE ALSA_LIBS subdirs HTML_DIR GTK_DOC_CFLAGS GTK_DOC_LIBS ENABLE_GTK_DOC_TRUE ENABLE_GTK_DOC_FALSE have_db2html ENABLE_MANUAL_TRUE ENABLE_MANUAL_FALSE LINPHONE_CFLAGS LINPHONE_LIBS LIBOBJS LTLIBOBJS'
ac_subst_files=''
@@ -30162,9 +30161,6 @@
-subdirs="$subdirs oRTP"
-
-
##################################################
# Check for gtk-doc.
##################################################

38
linphone-1.4.1-libs.patch Normal file
View File

@ -0,0 +1,38 @@
diff -ru linphone-1.4.1.old/configure.in linphone-1.4.1.new/configure.in
--- linphone-1.4.1.old/configure.in 2006-09-18 02:28:20.000000000 -0500
+++ linphone-1.4.1.new/configure.in 2006-10-09 08:49:20.000000000 -0500
@@ -242,7 +242,7 @@
AC_SUBST(STRICT_OPTIONS)
-AC_CONFIG_SUBDIRS( oRTP mediastreamer2 )
+AC_CONFIG_SUBDIRS( mediastreamer2 )
dnl check for db2html (docbook) to generate html user manual
AC_CHECK_PROG(have_db2html,db2html, yes, no)
@@ -258,12 +258,7 @@
AC_DEFINE_UNQUOTED(LINPHONE_VERSION,"$PACKAGE_VERSION",[Linphone's version number])
-dnl Packaging: Pick oRTP version from ${top_srcdir}/oRTP/configure.ac
-dnl Feel free to propose an alternative & cleaner version...
-top_srcdir=`dirname $0`
-changequote(, )dnl
-ORTP_VERSION=`grep -E ^[AC]+_INIT ${top_srcdir}/oRTP/configure.ac | sed -e 's:^.*_INIT(.*,\[\(.*\)\]):\1:g'`
-changequote([, ])dnl
+ORTP_VERSION=0.11.0
AC_SUBST([ORTP_VERSION])
AC_OUTPUT([
diff -ru linphone-1.4.1.old/Makefile.am linphone-1.4.1.new/Makefile.am
--- linphone-1.4.1.old/Makefile.am 2006-09-11 07:58:46.000000000 -0500
+++ linphone-1.4.1.new/Makefile.am 2006-10-09 08:49:33.000000000 -0500
@@ -3,7 +3,7 @@
# let make re-run automake upon need
ACLOCAL_AMFLAGS = -I m4
-SUBDIRS = m4 pixmaps po ipkg oRTP gsmlib mediastreamer2\
+SUBDIRS = m4 pixmaps po ipkg gsmlib mediastreamer2\
media_api exosip coreapi console gnome share

View File

@ -1,24 +1,39 @@
Name: linphone Name: linphone
Version: 1.2.0 Version: 1.5.0
Release: 7%{?dist} Release: 2%{?dist}
Summary: Phone anywhere in the whole world by using the Internet Summary: Phone anywhere in the whole world by using the Internet
Group: Applications/Communications Group: Applications/Communications
License: GPL License: GPL
URL: http://www.linphone.org/?lang=us&rubrique=1 URL: http://www.linphone.org/
Source0: http://simon.morlat.free.fr/download/1.2.x/source/%{name}-%{version}.tar.gz Source0: http://download.savannah.nongnu.org/releases/linphone/1.5.x/source/%{name}-%{version}.tar.gz
Patch: linphone-1.0.1-desktop.patch Patch: linphone-1.0.1-desktop.patch
Patch1: linphone-1.2.0-ortp.patch Patch1: linphone-1.4.1-libs.patch
Patch2: linphone-1.1.0-Werror.patch
Patch3: linphone-1.2.0-maxrtp.patch
Patch4: linphone-1.2.0-gtkentry.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: gnome-panel-devel libgnomeui-devel glib2-devel alsa-lib-devel BuildRequires: libosip2-devel
BuildRequires: libosip2-devel speex-devel >= 1.0.5 gettext desktop-file-utils BuildRequires: ortp-devel = 0.11.0
BuildRequires: ortp-devel >= 0.7.1
BuildRequires: readline-devel
BuildRequires: ncurses-devel
BuildRequires: gnome-panel-devel
BuildRequires: libgnomeui-devel
BuildRequires: glib2-devel
BuildRequires: alsa-lib-devel
BuildRequires: speex-devel >= 1.2
BuildRequires: desktop-file-utils
BuildRequires: perl(XML::Parser) BuildRequires: perl(XML::Parser)
BuildRequires: automake
BuildRequires: autoconf
BuildRequires: libtool
BuildRequires: intltool
BuildRequires: gettext
%description %description
Linphone is mostly sip compliant. It works successfully with these Linphone is mostly sip compliant. It works successfully with these
implementations: implementations:
@ -27,7 +42,7 @@ implementations:
* Hotsip, a free of charge phone for Windows. * Hotsip, a free of charge phone for Windows.
* Vocal, an open source SIP stack from Vovida that includes a SIP proxy * Vocal, an open source SIP stack from Vovida that includes a SIP proxy
that works with linphone since version 0.7.1. that works with linphone since version 0.7.1.
* Siproxd is a free sip proxy being developped by Thomas Ries because he * Siproxd is a free sip proxy being developed by Thomas Ries because he
would like to have linphone working behind his firewall. Siproxd is would like to have linphone working behind his firewall. Siproxd is
simple to setup and works perfectly with linphone. simple to setup and works perfectly with linphone.
* Partysip aims at being a generic and fully functionnal SIP proxy. Visit * Partysip aims at being a generic and fully functionnal SIP proxy. Visit
@ -46,14 +61,27 @@ Libraries and headers required to develop software with linphone.
%prep %prep
%setup -q %setup -q
%patch -p 1 -b .old %patch -p 1 -b .old
%patch1 -p 1 -b .ortp %patch1 -p 1 -b .libs
%patch2 -p 1 -b .Werror
%patch3 -p 1 -b .maxrtp
%patch4 -p 1 -b .gtkentry
rm -r oRTP rm -r oRTP
libtoolize --copy --force
autoheader
aclocal -I m4
automake --force-missing --add-missing --copy
autoconf
rm -rf config.cache
pushd mediastreamer2
libtoolize --copy --force
autoheader
aclocal
automake --force-missing --add-missing --copy
autoconf
popd
%build %build
%configure %configure --disable-static --disable-video
make %{?_smp_mflags} make %{?_smp_mflags}
%install %install
@ -65,10 +93,11 @@ rm $RPM_BUILD_ROOT%{_datadir}/gnome/apps/Internet/linphone.desktop
desktop-file-install --vendor=fedora \ desktop-file-install --vendor=fedora \
--delete-original \ --delete-original \
--dir $RPM_BUILD_ROOT%{_datadir}/applications \ --dir $RPM_BUILD_ROOT%{_datadir}/applications \
--add-category X-Fedora \ --remove-category Application \
--add-category Telephony \ --add-category Telephony \
--add-category GTK \ --add-category GTK \
$RPM_BUILD_ROOT%{_datadir}/applications/%{name}.desktop $RPM_BUILD_ROOT%{_datadir}/applications/%{name}.desktop
rm -f %{buildroot}%{_libdir}/*.la
%clean %clean
rm -rf $RPM_BUILD_ROOT rm -rf $RPM_BUILD_ROOT
@ -83,12 +112,13 @@ rm -rf $RPM_BUILD_ROOT
%{_bindir}/* %{_bindir}/*
%{_libdir}/bonobo/servers/*.server %{_libdir}/bonobo/servers/*.server
%{_libdir}/liblinphone.so.* %{_libdir}/liblinphone.so.*
%{_libdir}/libmediastreamer.so.*
%{_libdir}/libquickstream.so.*
%{_libexecdir}/* %{_libexecdir}/*
%{_mandir}/man1/* %{_mandir}/man1/*
%{_datadir}/applications/*%{name}.desktop %{_datadir}/applications/*%{name}.desktop
%{_datadir}/gnome/help/linphone %{_datadir}/gnome/help/linphone
%{_datadir}/gnome-2.0/ui/*.xml %{_datadir}/gnome-2.0/ui/*.xml
%{_datadir}/gtk-doc/html/mediastreamer
%{_datadir}/pixmaps/linphone %{_datadir}/pixmaps/linphone
%{_datadir}/pixmaps/linphone2.png %{_datadir}/pixmaps/linphone2.png
%{_datadir}/sounds/linphone %{_datadir}/sounds/linphone
@ -96,12 +126,21 @@ rm -rf $RPM_BUILD_ROOT
%files devel %files devel
%defattr(-,root,root) %defattr(-,root,root)
%{_includedir}/linphone %{_includedir}/linphone
%{_libdir}/liblinphone.a %{_includedir}/mediastreamer2
%{_libdir}/liblinphone.la
%{_libdir}/liblinphone.so %{_libdir}/liblinphone.so
%{_libdir}/libmediastreamer.so
%{_libdir}/libquickstream.so
%{_libdir}/pkgconfig/* %{_libdir}/pkgconfig/*
%changelog %changelog
* Thu Oct 26 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.5.0-2
- Don't forget to add new files and remove old ones!
* Thu Oct 26 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.5.0-1
- Update to 1.5.0
- Fix spelling error in description.
- Remove invalid categories on desktop file.
* Wed Aug 30 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.2.0-7 * Wed Aug 30 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.2.0-7
- Bump release so that I can "make tag" - Bump release so that I can "make tag"

View File

@ -1 +1 @@
bd5e513a665ce2e381afce64d569c707 linphone-1.2.0.tar.gz e9b01b74a3bb989aa5859d06e56162bd linphone-1.5.0.tar.gz