Updated patch

This commit is contained in:
Björn Esser 2017-04-16 10:26:43 +02:00
parent b9c8ce4d1b
commit 8270382d55
2 changed files with 17 additions and 8 deletions

View File

@ -1,17 +1,17 @@
From 61218921749f92de241fa79480a536b67a4e4925 Mon Sep 17 00:00:00 2001
From 45bc75ca188f52c92ffced79df69a7c15853e999 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Bj=C3=B6rn=20Esser?= <besser82@fedoraproject.org>
Date: Fri, 14 Apr 2017 11:01:58 +0200
Subject: [PATCH] Avoid several warnings in cmake-files from Qt5
Subject: [PATCH] Avoid several warnings from CMake
---
buildtools/CMakeLists.common | 6 ++++++
1 file changed, 6 insertions(+)
buildtools/CMakeLists.common | 12 ++++++++++++
1 file changed, 12 insertions(+)
diff --git a/buildtools/CMakeLists.common b/buildtools/CMakeLists.common
index 55843f5..dbde70e 100644
index 55843f5..6038834 100644
--- a/buildtools/CMakeLists.common
+++ b/buildtools/CMakeLists.common
@@ -6,6 +6,12 @@ if( POLICY CMP0053 )
@@ -6,6 +6,18 @@ if( POLICY CMP0053 )
cmake_policy( SET CMP0053 OLD )
endif()
@ -20,6 +20,12 @@ index 55843f5..dbde70e 100644
+if( POLICY CMP0043 )
+ cmake_policy( SET CMP0043 OLD )
+endif()
+
+# Avoid several warnings when building qt-graph.
+# CMP0028: Double colon in target name means ALIAS or IMPORTED target
+if( POLICY CMP0028 )
+ cmake_policy( SET CMP0028 OLD )
+endif()
+
INCLUDE( "${CMAKE_SOURCE_DIR}/PROJECTINFO.cmake" )

View File

@ -14,7 +14,7 @@
Name: lib%{libsuffix}
Version: 3.3.1
Release: 5%{?dist}
Release: 6%{?dist}
Summary: GUI-abstraction library
License: (LGPLv2 or LGPLv3) and MIT
@ -24,7 +24,7 @@ Source0: %{url}/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
# Improvements, submitted upstream.
# See: https://github.com/libyui/libyui/pull/115
Patch0: https://github.com/besser82/libyui/commit/5e04743f9fb669d26d3814b1b9ba089d0a8c5b14.patch#/%{name}-3.3.1-env_YUI_PREFERED_BACKEND.patch
Patch1: https://github.com/besser82/libyui/commit/61218921749f92de241fa79480a536b67a4e4925.patch#/%{name}-3.3.1-CMP0043.patch
Patch1: https://github.com/besser82/libyui/commit/45bc75ca188f52c92ffced79df69a7c15853e999.patch#/%{name}-3.3.1-CMake_warnings.patch
BuildRequires: boost-devel
BuildRequires: cmake
@ -146,6 +146,9 @@ popd
%changelog
* Sun Apr 16 2017 Björn Esser <besser82@fedoraproject.org> - 3.3.1-6
- Updated patch
* Sat Apr 15 2017 Björn Esser <besser82@fedoraproject.org> - 3.3.1-5
- Updated patches