Rebase to 3.10.0 (#1669818)
This commit is contained in:
parent
01610aba38
commit
47077306a9
@ -1,20 +0,0 @@
|
||||
--- a/src/YDialog.cc
|
||||
+++ b/src/YDialog.cc
|
||||
@@ -687,7 +687,7 @@ YDialog::showText( const std::string & text, bool useRichText )
|
||||
dialog->waitForEvent();
|
||||
dialog->destroy();
|
||||
}
|
||||
- catch ( YUIException exception )
|
||||
+ catch ( const YUIException & exception )
|
||||
{
|
||||
// Don't let the application die just because help couldn't be displayed.
|
||||
|
||||
@@ -811,7 +811,7 @@ YDialog::showRelNotesText()
|
||||
}
|
||||
dialog->destroy();
|
||||
}
|
||||
- catch ( YUIException exception )
|
||||
+ catch ( const YUIException & exception )
|
||||
{
|
||||
// Don't let the application die just because RN couldn't be displayed.
|
||||
|
13
libyui.spec
13
libyui.spec
@ -1,6 +1,6 @@
|
||||
%undefine __cmake_in_source_build
|
||||
|
||||
%global major_so_ver 8
|
||||
%global major_so_ver 12
|
||||
|
||||
# Place rpm-macros into proper location.
|
||||
%global macrosdir %(d=%{_rpmconfigdir}/macros.d; [ -d $d ] || d=%{_sysconfdir}/rpm; echo $d)
|
||||
@ -13,15 +13,13 @@
|
||||
|
||||
|
||||
Name: lib%{libsuffix}
|
||||
Version: 3.3.3
|
||||
Release: 9%{?dist}
|
||||
Version: 3.10.0
|
||||
Release: 1%{?dist}
|
||||
Summary: GUI-abstraction library
|
||||
|
||||
License: (LGPLv2 or LGPLv3) and MIT
|
||||
URL: https://github.com/%{name}/%{name}
|
||||
Source0: %{url}/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
|
||||
# Based on https://github.com/libyui/libyui/commit/b1f593cd99fd33cc3f0cf9b4f5151f672b68d96e
|
||||
Patch0: fix_gcc8.patch
|
||||
Source0: %{url}/archive/%{version}/%{name}-%{version}.tar.gz
|
||||
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: boost-devel
|
||||
@ -143,6 +141,9 @@ cp -a README.md package/libyui.changes \
|
||||
|
||||
|
||||
%changelog
|
||||
* Sat Aug 01 2020 Neal Gompa <ngompa13@gmail.com> - 3.10.0-1
|
||||
- Rebase to 3.10.0 (#1669818)
|
||||
|
||||
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 3.3.3-9
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (libyui-3.3.3.tar.gz) = 1db31218703c90e7b8b877b613997e0984275a0923c7837c6e813626c0037d56d524168e0f56e8ca36561c1af5480a0f379e8f87fbc4a380570a6d9ab336977f
|
||||
SHA512 (libyui-3.10.0.tar.gz) = 8c3186fdff7b3f6f49b25dcb7085f3906a2fa59b7e951b52a9c3aef62eb2b4941cfcfa59da334d4cc9445152130afe3214bd70b9e2efef67dbb9186a439b0d85
|
||||
|
Loading…
Reference in New Issue
Block a user