New upstream version

Updated Patches for libyui-mga
Drop unused patches
Spec-file cosmetics
This commit is contained in:
Björn Esser 2017-04-14 11:53:49 +02:00
parent 05d027d8da
commit 92a21c798e
9 changed files with 259 additions and 168 deletions

View File

@ -1,25 +0,0 @@
--- a/swig/CMakeLists.txt.orig 2015-12-04 10:04:56.318251131 +0100
+++ a/swig/CMakeLists.txt 2015-12-04 10:14:54.478993267 +0100
@@ -31,8 +31,9 @@ IF (WITH_PERL)
# doesn't work yet :-(
# CMake problem, FindPerlLibs.cmake is in a _really_ bad, bad state :-((
# see e.g. http://www.vtk.org/Bug/print_bug_page.php?bug_id=3665
- #FIND_PACKAGE(PerlLibs)
- FIND_PACKAGE(Perl)
+ FIND_PACKAGE(PerlLibs)
+ #FindPerl.cmake included by FindPerlLibs.cmake
+ #FIND_PACKAGE(Perl)
IF (PERL_EXECUTABLE)
MESSAGE(STATUS "Perl executable: ${PERL_EXECUTABLE}")
ADD_SUBDIRECTORY(perl)
--- a/swig/perl/CMakeLists.txt.orig 2015-12-04 10:04:56.318251131 +0100
+++ a/swig/perl/CMakeLists.txt 2015-12-04 10:16:10.805332741 +0100
@@ -14,7 +14,7 @@ EXECUTE_PROCESS(COMMAND ${PERL_EXECUTABL
EXECUTE_PROCESS(COMMAND ${PERL_EXECUTABLE} -e "use Config; print \$Config{archlib}.\"/CORE\"" OUTPUT_VARIABLE PERL_CORE_DIR)
EXECUTE_PROCESS(COMMAND ${PERL_EXECUTABLE} -e "use Config; print \$Config{installvendorarch}" OUTPUT_VARIABLE PERL_VENDOR_ARCH)
EXECUTE_PROCESS(COMMAND ${PERL_EXECUTABLE} -e "use Config; print \$Config{installvendorlib}" OUTPUT_VARIABLE PERL_VENDOR_LIB)
-EXECUTE_PROCESS(COMMAND ${PERL_EXECUTABLE} -e "use Config; print \$Config{ccdlflags}" OUTPUT_VARIABLE PERL_LINK_FLAGS)
+EXECUTE_PROCESS(COMMAND ${PERL_EXECUTABLE} -e "use Config; print \$Config{ccdlflags}; print \",-lpthread\"" OUTPUT_VARIABLE PERL_LINK_FLAGS)
STRING(REGEX REPLACE "^/usr/" "${CMAKE_INSTALL_PREFIX}/" PERL_VENDOR_ARCH "${PERL_VENDOR_ARCH}")
STRING(REGEX REPLACE "^/usr/" "${CMAKE_INSTALL_PREFIX}/" PERL_VENDOR_LIB "${PERL_VENDOR_LIB}")

View File

@ -1,28 +0,0 @@
--- a/swig/yui.i 2015-12-05 21:09:48.996373277 +0100
+++ b/swig/yui.i 2015-12-06 00:22:11.517161595 +0100
@@ -278,8 +278,10 @@ class Exception;
{ return ($self != i); }
#endif
#if defined(SWIGPYTHON)
- int __cmp__( YItem *i )
- { return ($self - i); }
+ int __eq__( YItem *i )
+ { return ($self == i); }
+ int __ne__( YItem *i )
+ { return ($self != i); }
#endif
#if defined(SWIGRUBY)
%rename( "==" ) equals( YItem *i );
@@ -304,8 +306,10 @@ typedef std::vector<YItem *> YItemCollec
{ return ($self != w); }
#endif
#if defined(SWIGPYTHON)
- int __cmp__( YWidget *w )
- { return ($self - w); }
+ int __eq__( YWidget *w )
+ { return ($self == w); }
+ int __ne__( YWidget *w )
+ { return ($self != w); }
#endif
#if defined(SWIGRUBY)
%rename( "==" ) equals( YWidget *w );

View File

@ -1,10 +0,0 @@
--- a/swig/yui.i.mga 2015-12-04 11:43:42.614392025 +0100
+++ a/swig/yui.i 2015-12-04 12:02:08.414341480 +0100
@@ -223,6 +223,7 @@ class Exception;
%include yui/YMultiLineEdit.h
%include yui/YMultiProgressMeter.h
%include yui/YMultiSelectionBox.h
+%include yui/YWizard.h
%include yui/YOptionalWidgetFactory.h
%include yui/YPackageSelector.h
%include yui/YPackageSelectorPlugin.h

View File

@ -1,9 +1,28 @@
From f655af5bac336e365c893ebdcc38194e1c47c2c9 Mon Sep 17 00:00:00 2001
From: Angelo Naselli <anaselli@linux.it>
Date: Sun, 8 Mar 2015 11:22:45 +0100
Subject: Added an example for the mga plugin
From 3683b937c06bd1e4c813da3554898d95b2ecc6b9 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Bj=C3=B6rn=20Esser?= <besser82@fedoraproject.org>
Date: Sun, 5 Feb 2017 17:02:49 +0100
Subject: [PATCH] Patches from MGA (anaselli) to support external plugins
---
CMakeLists.txt | 2 +-
swig/python/examples/mga-dialogs.py | 89 +++++++++++++++++++++++++++++++++++++
swig/yui.i | 9 ++++
3 files changed, 99 insertions(+), 1 deletion(-)
create mode 100644 swig/python/examples/mga-dialogs.py
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 59c94af..c2e6a88 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -28,7 +28,7 @@ ENDIF()
SET( CMAKE_INSTALL_PREFIX "${YPREFIX}" )
SET( LIBYUI_INCLUDE_DIR "${YPREFIX}/include" )
-SET( LIBYUI_LIBRARY "yui" )
+SET( LIBYUI_LIBRARY yui yui-mga )
SET(CPACK_PACKAGE_DESCRIPTION_SUMMARY "Language Bindings for libyui")
SET(CPACK_PACKAGE_VENDOR "Novell Inc.")
diff --git a/swig/python/examples/mga-dialogs.py b/swig/python/examples/mga-dialogs.py
new file mode 100644
index 0000000..285590c
@ -99,3 +118,30 @@ index 0000000..285590c
+if __name__ == "__main__":
+ main_gui = mainGui()
+ main_gui.handleevent()
diff --git a/swig/yui.i b/swig/yui.i
index 0a44d27..5dd5f82 100644
--- a/swig/yui.i
+++ b/swig/yui.i
@@ -99,6 +99,11 @@ SWIGEXPORT void Init__yui(void) {
#include "yui/YUILoader.h"
+#include "yui/mga/YMGA_CBTable.h"
+#include "yui/mga/YMGAMsgBox.h"
+#include "yui/mga/YMGAAboutDialog.h"
+#include "yui/mga/YMGAWidgetExtensionFactory.h"
+
using namespace std;
extern void *start_ui_thread( void *ui_int );
@@ -254,6 +259,10 @@ class Exception;
%include yui/YWidgetID.h
%include yui/YExternalWidgetFactory.h
%include yui/YExternalWidgets.h
+%include yui/mga/YMGA_CBTable.h
+%include yui/mga/YMGAAboutDialog.h
+%include yui/mga/YMGAMsgBox.h
+%include yui/mga/YMGAWidgetExtensionFactory.h
#if defined(SWIGRUBY)
%extend YEvent {

View File

@ -0,0 +1,169 @@
From 1194d299231ec34ac34f9146d8128630ae09ef77 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Bj=C3=B6rn=20Esser?= <besser82@fedoraproject.org>
Date: Sun, 5 Feb 2017 17:46:52 +0100
Subject: [PATCH] Add option to enable MGA-Extensions
---
CMakeLists.txt | 22 +++++++++++-----------
swig/CMakeLists.txt | 4 ----
swig/mono/CMakeLists.txt | 2 +-
swig/perl/CMakeLists.txt | 2 +-
swig/python/CMakeLists.txt | 2 +-
swig/ruby/CMakeLists.txt | 2 +-
swig/yui.i | 7 ++++++-
7 files changed, 21 insertions(+), 20 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c2e6a88..e6784c2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -12,6 +12,7 @@ if(COMMAND cmake_policy)
endif(COMMAND cmake_policy)
OPTION( BUILD_RUBY_GEM "Build Ruby GEM" YES )
+OPTION( WITH_MGA "Build with support for libyui-mga" NO )
# where to look first for cmake modules, before ${CMAKE_ROOT}/Modules/ is checked
SET(CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/cmake/Modules ${CMAKE_MODULE_PATH})
@@ -28,7 +29,6 @@ ENDIF()
SET( CMAKE_INSTALL_PREFIX "${YPREFIX}" )
SET( LIBYUI_INCLUDE_DIR "${YPREFIX}/include" )
-SET( LIBYUI_LIBRARY yui yui-mga )
SET(CPACK_PACKAGE_DESCRIPTION_SUMMARY "Language Bindings for libyui")
SET(CPACK_PACKAGE_VENDOR "Novell Inc.")
@@ -76,19 +76,19 @@ INCLUDE(CPack)
#FIND_PACKAGE(SWIG REQUIRED)
MESSAGE(STATUS "Looking modules in ${CMAKE_MODULE_PATH}")
-FIND_PROGRAM(SWIG_EXECUTABLE
- NAMES swig-1.3 swig
- PATHS ${SWIG_DIR} ${SWIG_DIR}/.. ${SWIG_DIR}/../../bin /usr/bin /usr/local/bin ${CMAKE_INSTALL_PREFIX}/bin
-)
-
-IF ( NOT SWIG_EXECUTABLE )
- MESSAGE( FATAL "SWIG not found." )
-ELSE ( NOT SWIG_EXECUTABLE )
- MESSAGE( STATUS "SWIG found at ${SWIG_EXECUTABLE}" )
-ENDIF ( NOT SWIG_EXECUTABLE )
+FIND_PACKAGE(SWIG REQUIRED)
FIND_PACKAGE(Libyui REQUIRED)
+SET( LIBYUI_LIBRARY yui )
+
+IF(WITH_MGA)
+FIND_PACKAGE(Libyui-mga REQUIRED)
+SET( LIBYUI_LIBRARY yui yui-mga )
+ADD_DEFINITIONS( -DWITH_MGA )
+SET( SWIG_FLAGS "-DWITH_MGA" )
+ENDIF(WITH_MGA)
+
ADD_SUBDIRECTORY(swig)
ADD_CUSTOM_TARGET( svncheck
diff --git a/swig/CMakeLists.txt b/swig/CMakeLists.txt
index 57c526c..b213506 100644
--- a/swig/CMakeLists.txt
+++ b/swig/CMakeLists.txt
@@ -1,7 +1,3 @@
-FIND_PACKAGE(SWIG)
-
-MESSAGE(STATUS "Found SWIG version ${SWIG_VERSION}")
-
#
# Generic setting for all generated bindings
#
diff --git a/swig/mono/CMakeLists.txt b/swig/mono/CMakeLists.txt
index 5cf0be4..e227d43 100644
--- a/swig/mono/CMakeLists.txt
+++ b/swig/mono/CMakeLists.txt
@@ -18,7 +18,7 @@ SET( SWIG_OUTPUT "${CMAKE_CURRENT_BINARY_DIR}/yui_csharp.cxx" )
ADD_CUSTOM_COMMAND (
OUTPUT ${SWIG_OUTPUT}
COMMAND ${CMAKE_COMMAND} -E echo_append "Creating wrapper code for CSharp ..."
- COMMAND ${SWIG_EXECUTABLE} -c++ -csharp -features autodoc -o ${SWIG_OUTPUT} -I${LIBYUI_INCLUDE_DIR} ${SWIG_INPUT}
+ COMMAND ${SWIG_EXECUTABLE} -c++ -csharp -features autodoc ${SWIG_FLAGS} -o ${SWIG_OUTPUT} -I${LIBYUI_INCLUDE_DIR} ${SWIG_INPUT}
COMMAND ${CMAKE_COMMAND} -E echo "Done."
WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/../*.i
diff --git a/swig/perl/CMakeLists.txt b/swig/perl/CMakeLists.txt
index fe65ec6..80dd708 100644
--- a/swig/perl/CMakeLists.txt
+++ b/swig/perl/CMakeLists.txt
@@ -34,7 +34,7 @@ endif(COMMAND cmake_policy)
ADD_CUSTOM_COMMAND (
OUTPUT ${SWIG_OUTPUT}
COMMAND ${CMAKE_COMMAND} -E echo_append "Creating wrapper code for Perl ..."
- COMMAND ${SWIG_EXECUTABLE} -c++ -perl -shadow -features autodoc -o ${SWIG_OUTPUT} -I${LIBYUI_INCLUDE_DIR} ${SWIG_INPUT}
+ COMMAND ${SWIG_EXECUTABLE} -c++ -perl -shadow -features autodoc ${SWIG_FLAGS} -o ${SWIG_OUTPUT} -I${LIBYUI_INCLUDE_DIR} ${SWIG_INPUT}
COMMAND ${CMAKE_COMMAND} -E echo "Done."
WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/../*.i
diff --git a/swig/python/CMakeLists.txt b/swig/python/CMakeLists.txt
index e4c64db..61d964f 100644
--- a/swig/python/CMakeLists.txt
+++ b/swig/python/CMakeLists.txt
@@ -27,7 +27,7 @@ MESSAGE(STATUS "Python site dir: ${PYTHON_SITEDIR}")
ADD_CUSTOM_COMMAND (
OUTPUT ${SWIG_OUTPUT}
COMMAND ${CMAKE_COMMAND} -E echo_append "Creating wrapper code for Python ..."
- COMMAND ${SWIG_EXECUTABLE} -c++ -python -shadow -features autodoc -o ${SWIG_OUTPUT} -I${LIBYUI_INCLUDE_DIR} ${SWIG_INPUT}
+ COMMAND ${SWIG_EXECUTABLE} -c++ -python -shadow -features autodoc ${SWIG_FLAGS} -o ${SWIG_OUTPUT} -I${LIBYUI_INCLUDE_DIR} ${SWIG_INPUT}
COMMAND ${CMAKE_COMMAND} -E echo "Done."
WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/../*.i
diff --git a/swig/ruby/CMakeLists.txt b/swig/ruby/CMakeLists.txt
index 00998b4..f1f8088 100644
--- a/swig/ruby/CMakeLists.txt
+++ b/swig/ruby/CMakeLists.txt
@@ -19,7 +19,7 @@ configure_file(${CMAKE_CURRENT_SOURCE_DIR}/yui/version.rb.in ${CMAKE_CURRENT_BIN
ADD_CUSTOM_COMMAND (
OUTPUT ${SWIG_OUTPUT}
COMMAND ${CMAKE_COMMAND} -E echo_append "Creating wrapper code for ruby..."
- COMMAND ${SWIG_EXECUTABLE} -c++ -ruby -autorename -o ${SWIG_OUTPUT} -I${LIBYUI_INCLUDE_DIR} ${SWIG_INPUT}
+ COMMAND ${SWIG_EXECUTABLE} -c++ -ruby -autorename ${SWIG_FLAGS} -o ${SWIG_OUTPUT} -I${LIBYUI_INCLUDE_DIR} ${SWIG_INPUT}
COMMAND ${CMAKE_COMMAND} -E echo "Done."
WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/../*.i
diff --git a/swig/yui.i b/swig/yui.i
index 5dd5f82..c5494b0 100644
--- a/swig/yui.i
+++ b/swig/yui.i
@@ -99,10 +99,12 @@ SWIGEXPORT void Init__yui(void) {
#include "yui/YUILoader.h"
+#if defined(WITH_MGA)
#include "yui/mga/YMGA_CBTable.h"
#include "yui/mga/YMGAMsgBox.h"
#include "yui/mga/YMGAAboutDialog.h"
#include "yui/mga/YMGAWidgetExtensionFactory.h"
+#endif
using namespace std;
@@ -166,7 +168,7 @@ class Exception;
*
*/
-
+
%apply SWIGTYPE *DISOWN { YItem *item_disown };
%apply SWIGTYPE *DISOWN { YEvent *event_disown };
%apply SWIGTYPE *DISOWN { YTableCell *cell_disown };
@@ -259,10 +261,13 @@ class Exception;
%include yui/YWidgetID.h
%include yui/YExternalWidgetFactory.h
%include yui/YExternalWidgets.h
+
+#if defined(WITH_MGA)
%include yui/mga/YMGA_CBTable.h
%include yui/mga/YMGAAboutDialog.h
%include yui/mga/YMGAMsgBox.h
%include yui/mga/YMGAWidgetExtensionFactory.h
+#endif
#if defined(SWIGRUBY)
%extend YEvent {

View File

@ -1,13 +0,0 @@
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 59c94af..c2e6a88 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -28,7 +28,7 @@ ENDIF()
SET( CMAKE_INSTALL_PREFIX "${YPREFIX}" )
SET( LIBYUI_INCLUDE_DIR "${YPREFIX}/include" )
-SET( LIBYUI_LIBRARY "yui" )
+SET( LIBYUI_LIBRARY yui yui-mga )
SET(CPACK_PACKAGE_DESCRIPTION_SUMMARY "Language Bindings for libyui")
SET(CPACK_PACKAGE_VENDOR "Novell Inc.")

View File

@ -1,27 +0,0 @@
diff --git a/swig/yui.i b/swig/yui.i
index 0a44d27..5dd5f82 100644
--- a/swig/yui.i
+++ b/swig/yui.i
@@ -99,6 +99,11 @@ SWIGEXPORT void Init__yui(void) {
#include "yui/YUILoader.h"
+#include "yui/mga/YMGA_CBTable.h"
+#include "yui/mga/YMGAMsgBox.h"
+#include "yui/mga/YMGAAboutDialog.h"
+#include "yui/mga/YMGAWidgetExtensionFactory.h"
+
using namespace std;
extern void *start_ui_thread( void *ui_int );
@@ -254,6 +259,10 @@ class Exception;
%include yui/YWizard.h
%include yui/YExternalWidgetFactory.h
%include yui/YExternalWidgets.h
+%include yui/mga/YMGA_CBTable.h
+%include yui/mga/YMGAAboutDialog.h
+%include yui/mga/YMGAMsgBox.h
+%include yui/mga/YMGAWidgetExtensionFactory.h
#if defined(SWIGRUBY)
%extend YEvent {

View File

@ -13,29 +13,24 @@
%endif #0%{?fedora} >= 13 || 0%{?rhel} >= 8
# CMake-builds go out-of-tree.
%global _cmake_build_subdir build-%{?_arch}%{?dist}
%global _cmake_build_subdir build-%{_target_platform}
Name: %{libname}-bindings
Version: 1.1.1
Release: 13%{?dist}
Version: 1.1.2
Release: 1%{?dist}
Summary: Language bindings for %{libname}
License: LGPLv2 or LGPLv3
URL: https://github.com/%{libname}/%{name}
Source0: %{url}/archive/%{name}/master/%{version}.tar.gz#/%{name}-%{version}.tar.gz
# Patches from Mageia
Patch0: %{name}-1.1.0-perlcmake.patch
Patch1: %{name}-1.1.1-python-missing-constants.patch
Patch2: %{name}-1.1.0-python3-YWidget-and-YItem.patch
Source0: %{url}/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
# Patches from Mageia to enable libyui-mga bindings
Patch100: %{name}-CMakeLists.patch
Patch101: %{name}-mga-plugins.patch
Patch102: %{name}-mga-example.patch
Patch1000: https://github.com/besser82/libyui-bindings/commit/3683b937c06bd1e4c813da3554898d95b2ecc6b9.patch#/%{name}-1.1.2-libyui-mga.patch
Patch1001: https://github.com/besser82/libyui-bindings/commit/1194d299231ec34ac34f9146d8128630ae09ef77.patch#/%{name}-1.1.2-mga-cmake.patch
BuildRequires: boost-devel
BuildRequires: cmake >= 2.8
BuildRequires: cmake
BuildRequires: %{libname}-devel
BuildRequires: %{libname}-mga-devel
BuildRequires: swig
@ -50,11 +45,8 @@ interfaces (Qt, Gtk) and text based user interfaces (ncurses).
%if 0%{?with_mono}
%package -n mono-%{libsuffix}
Summary: Mono / CSharp bindings for %{libname}
%if 0%{?fedora} >= 23
BuildRequires: mono-devel >= 4.0.0
%else # 0%%{?fedora} >= 23
BuildRequires: mono-devel
%endif # 0%%{?fedora} >= 23
%description -n mono-%{libsuffix}
This package provides Mono / CSharp language bindings to access
@ -70,6 +62,7 @@ Summary: Perl bindings for %{libname}
BuildRequires: perl-devel
BuildRequires: perl-generators
Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
%description -n perl-%{libsuffix}
@ -82,12 +75,10 @@ interfaces (ncurses).
%package -n python2-%{libsuffix}
Summary: Python bindings for %{libname}
BuildRequires: python2-devel
Provides: python-%{libsuffix} == %{version}-%{release}
Provides: python-%{libsuffix}%{?_isa} == %{version}-%{release}
Obsoletes: python-%{libsuffix} <= 1.1.1-2
Obsoletes: python-%{libsuffix}%{?_isa} <= 1.1.1-2
%{?python_provide:%python_provide python2-%{libsuffix}}
%description -n python2-%{libsuffix}
This package provides Python language bindings to access
@ -100,8 +91,11 @@ interfaces (ncurses).
%if 0%{?with_py3}
%package -n python3-%{libsuffix}
Summary: Python3 bindings for %{libname}
BuildRequires: python3-devel
%{?python_provide:%python_provide python3-%{libsuffix}}
%description -n python3-%{libsuffix}
This package provides Python3 language bindings to access
functions of %{libname}.
@ -116,15 +110,7 @@ Summary: Ruby bindings for %{libname}
BuildRequires: ruby-devel
%if 0%{?fedora} >= 19 || 0%{?rhel} >= 7
Requires: ruby(release)
%else #0%{?fedora} >= 19 || 0%{?rhel} >= 7
%if (0%{?fedora} && 0%{?fedora} <= 16) || (0%{?rhel} >= 4 && 0%{?rhel} <= 6)
Requires: ruby(abi) == 1.8
%else #(0%{?fedora} && 0%{?fedora} <= 16) || (0%{?rhel} >= 4 && 0%{?rhel} <= 6)
Requires: ruby(abi) == 1.9.1
%endif #(0%{?fedora} && 0%{?fedora} <= 16) || (0%{?rhel} >= 4 && 0%{?rhel} <= 6)
%endif #0%{?fedora} >= 19 || 0%{?rhel} >= 7
%description -n ruby-%{libsuffix}
This package provides Ruby language bindings to access
@ -135,20 +121,7 @@ interfaces (ncurses).
%prep
%setup -qn %{name}-%{name}-master-%{version}
%patch0 -p1
%patch1 -p1
%patch100 -p1
%patch101 -p1
%patch102 -p1
%if 0%{?with_py3}
cp -a . %{py3dir}
pushd %{py3dir}
%patch2 -p1
popd
%endif #0%{?with_py3}
%autosetup -p 1
%build
@ -161,17 +134,18 @@ pushd %{_cmake_build_subdir}
-DPYTHON_EXECUTABLE=%{__python2} \
-DPYTHON_SITEDIR=%{python2_sitearch} \
-DCMAKE_BUILD_TYPE=RELEASE \
-DBUILD_RUBY_GEM=no \
-DBUILD_RUBY_GEM=NO \
-DWITH_MGA=YES \
-DWITH_MONO=%{?with_mono:ON}%{!?with_mono:OFF} \
-DWITH_PERL=ON \
-DWITH_PYTHON=ON \
-DWITH_RUBY=ON \
..
%make_build
popd
%if 0%{?with_py3}
pushd %{py3dir}
%{__mkdir} -p py3-%{_cmake_build_subdir}
pushd py3-%{_cmake_build_subdir}
%cmake \
@ -180,66 +154,71 @@ pushd py3-%{_cmake_build_subdir}
-DPYTHON_EXECUTABLE=%{__python3} \
-DPYTHON_SITEDIR=%{python3_sitearch} \
-DCMAKE_BUILD_TYPE=RELEASE \
-DBUILD_RUBY_GEM=no \
-DBUILD_RUBY_GEM=NO \
-DWITH_MGA=YES \
-DWITH_MONO=OFF \
-DWITH_PERL=OFF \
-DWITH_PYTHON=ON \
-DWITH_RUBY=OFF \
..
%make_build
popd
popd
%endif #0%{?with_py3}
%install
pushd %{_cmake_build_subdir}
%make_install
popd
%make_install -C %{_cmake_build_subdir}
%if 0%{?with_py3}
pushd %{py3dir}
pushd py3-%{_cmake_build_subdir}
%make_install
popd
popd
%make_install -C py3-%{_cmake_build_subdir}
%endif #0%{?with_py3}
%if 0%{?with_mono}
%files -n mono-%{libsuffix}
%doc package/%{name}.changes README
%doc package/%{name}.changes README.md
%license COPYING*
%{_libdir}/%{libsuffix}/%{libsuffix}.dll
%{_libdir}/%{libsuffix}/%{libsuffix}.so
%endif
%files -n perl-%{libsuffix}
%doc package/%{name}.changes README swig/perl/examples
%doc package/%{name}.changes README.md swig/perl/examples
%license COPYING*
%{perl_vendorarch}/%{libsuffix}.so
%{perl_vendorlib}/%{libsuffix}.pm
%files -n python2-%{libsuffix}
%doc package/%{name}.changes README swig/python/examples
%doc package/%{name}.changes README.md swig/python/examples
%license COPYING*
%{python2_sitearch}/*%{libsuffix}.*
%if 0%{?with_py3}
%files -n python3-%{libsuffix}
%doc package/%{name}.changes README swig/python/examples
%doc package/%{name}.changes README.md swig/python/examples
%license COPYING*
%{python3_sitearch}/__pycache__/*
%{python3_sitearch}/*%{libsuffix}.*
%endif #0%{?with_py3}
%files -n ruby-%{libsuffix}
%doc package/%{name}.changes README swig/ruby/examples
%doc package/%{name}.changes README.md swig/ruby/examples
%license COPYING*
%{ruby_vendorarchdir}/_%{libsuffix}.*
%changelog
* Fri Apr 14 2017 Björn Esser <besser82@fedoraproject.org> - 1.1.2-1
- New upstream version
- Updated Patches for libyui-mga
- Drop unused patches
- Spec-file cosmetics
* Thu Apr 13 2017 Björn Esser <besser82@fedoraproject.org> - 1.1.1-13
- Rebuilt for libyui.so.8

View File

@ -1 +1 @@
98203c90cba969d08c48368e11c4de34 libyui-bindings-1.1.1.tar.gz
SHA512 (libyui-bindings-1.1.2.tar.gz) = 4cd44f3e040c108a4c4727c4b39ceab1245c3b4827b67b2867f08704882a9c4afcfc063297c6d0ff156055986e7a18d6622bc0bf9861b21ce2e26d1e378c525e