fix test
This commit is contained in:
parent
90fedcc9e0
commit
d91ecd77f5
34
0001-fix-test.patch
Normal file
34
0001-fix-test.patch
Normal file
@ -0,0 +1,34 @@
|
|||||||
|
From 75a02c586f6ec49d4316f79004834250ef42b0e0 Mon Sep 17 00:00:00 2001
|
||||||
|
From: David Tardon <dtardon@redhat.com>
|
||||||
|
Date: Sat, 25 Jul 2015 15:11:19 +0200
|
||||||
|
Subject: [PATCH] fix test
|
||||||
|
|
||||||
|
The previous version only worked with libxml2 < 2.9.2, because of a bug
|
||||||
|
in handling nested elements of the same name.
|
||||||
|
|
||||||
|
Change-Id: I1368cedf5845895154806d4ecf427bfbed19165f
|
||||||
|
---
|
||||||
|
configure.ac | 4 ++++
|
||||||
|
src/test/importtest.cpp | 6 +++---
|
||||||
|
2 files changed, 7 insertions(+), 3 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/src/test/importtest.cpp b/src/test/importtest.cpp
|
||||||
|
index 8554309..0296380 100644
|
||||||
|
--- a/src/test/importtest.cpp
|
||||||
|
+++ b/src/test/importtest.cpp
|
||||||
|
@@ -272,9 +272,9 @@ void ImportTest::testVsdxImportBgColorFromTheme()
|
||||||
|
void ImportTest::testVsdxCharBgColor()
|
||||||
|
{
|
||||||
|
m_doc = parse("bgcolor.vsdx", m_buffer);
|
||||||
|
- assertXPathNoAttribute(m_doc, "/document/page/layer/textObject/paragraph/span", "background-color");
|
||||||
|
- assertXPath(m_doc, "/document/page/layer/layer[2]/textObject/paragraph/span", "background-color", "#9dbb61");
|
||||||
|
- assertXPath(m_doc, "/document/page/layer/layer[2]/layer[2]/textObject/paragraph/span", "background-color", "#9dbb61");
|
||||||
|
+ assertXPathNoAttribute(m_doc, "/document/page/layer[1]/textObject/paragraph/span", "background-color");
|
||||||
|
+ assertXPath(m_doc, "/document/page/layer[2]/textObject/paragraph/span", "background-color", "#9dbb61");
|
||||||
|
+ assertXPath(m_doc, "/document/page/layer[3]/textObject/paragraph/span", "background-color", "#9dbb61");
|
||||||
|
}
|
||||||
|
|
||||||
|
CPPUNIT_TEST_SUITE_REGISTRATION(ImportTest);
|
||||||
|
--
|
||||||
|
2.1.0
|
||||||
|
|
@ -17,9 +17,11 @@ BuildRequires: perl
|
|||||||
BuildRequires: pkgconfig(cppunit)
|
BuildRequires: pkgconfig(cppunit)
|
||||||
BuildRequires: pkgconfig(icu-i18n)
|
BuildRequires: pkgconfig(icu-i18n)
|
||||||
BuildRequires: pkgconfig(librevenge-0.0)
|
BuildRequires: pkgconfig(librevenge-0.0)
|
||||||
BuildRequires: pkgconfig(libxml-2.0)
|
BuildRequires: pkgconfig(libxml-2.0) >= 2.9.2
|
||||||
BuildRequires: pkgconfig(zlib)
|
BuildRequires: pkgconfig(zlib)
|
||||||
|
|
||||||
|
Patch0: 0001-fix-test.patch
|
||||||
|
|
||||||
%description
|
%description
|
||||||
%{name} is library providing ability to interpret and import
|
%{name} is library providing ability to interpret and import
|
||||||
Microsoft Visio diagrams into various applications. You can find it
|
Microsoft Visio diagrams into various applications. You can find it
|
||||||
|
Loading…
Reference in New Issue
Block a user