5e8ea6c64c
- Create /var/log/libvirt/{lxc,uml} dirs for logrotate - Make libvirt-python dependon on libvirt-client - Sync misc minor changes from upstream spec
55 lines
2.3 KiB
Diff
55 lines
2.3 KiB
Diff
From b7e3ac4f23befe67518b57e34691c301820a436c Mon Sep 17 00:00:00 2001
|
|
From: Mark McLoughlin <markmc@redhat.com>
|
|
Date: Tue, 6 Oct 2009 12:33:17 +0100
|
|
Subject: [PATCH] Create /var/log/libvirt/{lxc,uml} dirs
|
|
|
|
Otherwise logrotate barfs:
|
|
|
|
error: error accessing /var/log/libvirt/uml: No such file or directory
|
|
error: libvirtd:1 glob failed for /var/log/libvirt/uml/*.log
|
|
error: found error in /var/log/libvirt/qemu/*.log /var/log/libvirt/uml/*.log /var/log/libvirt/lxc/*.log , skipping
|
|
|
|
* qemud/Makefile.am: always create /var/log/libvirt/{lxc,uml} when
|
|
installing the logrotate conf; not ideal, but easier than making
|
|
the logrotate conf depend on which drivers are enabled
|
|
|
|
Fedora-patch: libvirt-logrotate-create-lxc-uml-dirs.patch
|
|
---
|
|
qemud/Makefile.am | 6 ++++--
|
|
1 files changed, 4 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/qemud/Makefile.am b/qemud/Makefile.am
|
|
index 3d143da..a7f4bdf 100644
|
|
--- a/qemud/Makefile.am
|
|
+++ b/qemud/Makefile.am
|
|
@@ -176,7 +176,7 @@ install-data-local: install-init install-data-sasl install-data-polkit \
|
|
test -e $(DESTDIR)$(sysconfdir)/libvirt/qemu/networks/autostart/default.xml || \
|
|
ln -s ../default.xml \
|
|
$(DESTDIR)$(sysconfdir)/libvirt/qemu/networks/autostart/default.xml
|
|
- mkdir -p $(DESTDIR)$(localstatedir)/log/libvirt/qemu
|
|
+ mkdir -p $(DESTDIR)$(localstatedir)/log/libvirt
|
|
mkdir -p $(DESTDIR)$(localstatedir)/run/libvirt
|
|
mkdir -p $(DESTDIR)$(localstatedir)/lib/libvirt
|
|
|
|
@@ -184,7 +184,7 @@ uninstall-local:: uninstall-init uninstall-data-sasl install-data-polkit
|
|
rm -f $(DESTDIR)$(sysconfdir)/libvirt/qemu/networks/autostart/default.xml
|
|
rm -f $(DESTDIR)$(sysconfdir)/$(default_xml_dest)
|
|
rmdir $(DESTDIR)$(sysconfdir)/libvirt/qemu/networks/autostart || :
|
|
- rmdir $(DESTDIR)$(localstatedir)/log/libvirt/qemu || :
|
|
+ rmdir $(DESTDIR)$(localstatedir)/log/libvirt || :
|
|
rmdir $(DESTDIR)$(localstatedir)/run/libvirt || :
|
|
rmdir $(DESTDIR)$(localstatedir)/lib/libvirt || :
|
|
|
|
@@ -240,6 +240,8 @@ libvirtd.logrotate: libvirtd.logrotate.in
|
|
|
|
install-logrotate: libvirtd.logrotate
|
|
mkdir -p $(DESTDIR)$(localstatedir)/log/libvirt/qemu/
|
|
+ mkdir -p $(DESTDIR)$(localstatedir)/log/libvirt/lxc/
|
|
+ mkdir -p $(DESTDIR)$(localstatedir)/log/libvirt/uml/
|
|
mkdir -p $(DESTDIR)$(sysconfdir)/logrotate.d/
|
|
$(INSTALL_DATA) $< $(DESTDIR)$(sysconfdir)/logrotate.d/libvirtd
|
|
|
|
--
|
|
1.6.2.5
|
|
|