- apply the python makefile patch for #463733

daniel
This commit is contained in:
Daniel Veillard 2008-09-24 13:34:20 +00:00
parent ca07bc4597
commit 28f7f11450
2 changed files with 41 additions and 1 deletions

View File

@ -34,10 +34,11 @@
Summary: Library providing a simple API virtualization
Name: libvirt
Version: 0.4.6
Release: 2%{?dist}%{?extra_release}
Release: 3%{?dist}%{?extra_release}
License: LGPLv2+
Group: Development/Libraries
Source: libvirt-%{version}.tar.gz
Patch0: python_make.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
URL: http://libvirt.org/
BuildRequires: python python-devel
@ -159,6 +160,7 @@ of recent versions of Linux (and other OSes).
%prep
%setup -q
%patch0 -p0
%build
%if ! %{with_xen}
@ -394,6 +396,9 @@ fi
%endif
%changelog
* Wed Sep 24 2008 Daniel Veillard <veillard@redhat.com> - 0.4.6-3.fc10
- apply the python makefile patch for #463733
* Wed Sep 24 2008 Daniel Veillard <veillard@redhat.com> - 0.4.6-2.fc10
- upstream release 0.4.6
- fixes some problems with 0.4.5

35
python_make.patch Normal file
View File

@ -0,0 +1,35 @@
Index: python/Makefile.am
===================================================================
RCS file: /data/cvs/libxen/python/Makefile.am,v
retrieving revision 1.13
diff -u -p -r1.13 Makefile.am
--- python/Makefile.am 5 Feb 2008 19:27:37 -0000 1.13
+++ python/Makefile.am 24 Sep 2008 13:21:06 -0000
@@ -50,7 +50,7 @@ GENERATED= libvirt-export.c \
$(GENERATED): $(srcdir)/$(GENERATE) $(API_DESC)
$(PYTHON) $(srcdir)/$(GENERATE) $(srcdir)
-libvirt.py: $(srcdir)/libvir.py libvirtclass.py
+libvirt.py: $(srcdir)/libvir.py $(GENERATED)
cat $(srcdir)/libvir.py libvirtclass.py > $@-t
mv $@-t $@
*** python/Makefile.in.orig 2008-09-24 15:19:20.000000000 +0200
--- python/Makefile.in 2008-09-24 15:20:07.000000000 +0200
*************** uninstall-am: uninstall-local uninstall-
*** 1027,1033 ****
@WITH_PYTHON_TRUE@$(GENERATED): $(srcdir)/$(GENERATE) $(API_DESC)
@WITH_PYTHON_TRUE@ $(PYTHON) $(srcdir)/$(GENERATE) $(srcdir)
! @WITH_PYTHON_TRUE@libvirt.py: $(srcdir)/libvir.py libvirtclass.py
@WITH_PYTHON_TRUE@ cat $(srcdir)/libvir.py libvirtclass.py > $@-t
@WITH_PYTHON_TRUE@ mv $@-t $@
--- 1027,1033 ----
@WITH_PYTHON_TRUE@$(GENERATED): $(srcdir)/$(GENERATE) $(API_DESC)
@WITH_PYTHON_TRUE@ $(PYTHON) $(srcdir)/$(GENERATE) $(srcdir)
! @WITH_PYTHON_TRUE@libvirt.py: $(srcdir)/libvir.py $(GENERATED)
@WITH_PYTHON_TRUE@ cat $(srcdir)/libvir.py libvirtclass.py > $@-t
@WITH_PYTHON_TRUE@ mv $@-t $@