Rebased to version 3.2.1
This commit is contained in:
parent
04cb28c315
commit
0fe69a9b44
@ -1,34 +0,0 @@
|
||||
From ec9c065d405a129d3d33abd3d10d8a7ff1a49420 Mon Sep 17 00:00:00 2001
|
||||
From: "Daniel P. Berrange" <berrange@redhat.com>
|
||||
Date: Wed, 18 Jan 2017 10:48:12 +0000
|
||||
Subject: [PATCH] Disable use of namespaces by default
|
||||
|
||||
When namespaces are enabled there is currently breakage when
|
||||
using disk hotplug and when using AppArmor
|
||||
|
||||
Signed-off-by: Daniel P. Berrange <berrange@redhat.com>
|
||||
---
|
||||
src/qemu/qemu_conf.c | 7 -------
|
||||
1 file changed, 7 deletions(-)
|
||||
|
||||
diff --git a/src/qemu/qemu_conf.c b/src/qemu/qemu_conf.c
|
||||
index 6613d59..aa05b46 100644
|
||||
--- a/src/qemu/qemu_conf.c
|
||||
+++ b/src/qemu/qemu_conf.c
|
||||
@@ -317,13 +317,6 @@ virQEMUDriverConfigPtr virQEMUDriverConfigNew(bool privileged)
|
||||
if (!(cfg->namespaces = virBitmapNew(QEMU_DOMAIN_NS_LAST)))
|
||||
goto error;
|
||||
|
||||
-#if defined(__linux__)
|
||||
- if (privileged &&
|
||||
- virProcessNamespaceAvailable(VIR_PROCESS_NAMESPACE_MNT) == 0 &&
|
||||
- virBitmapSetBit(cfg->namespaces, QEMU_DOMAIN_NS_MOUNT) < 0)
|
||||
- goto error;
|
||||
-#endif /* defined(__linux__) */
|
||||
-
|
||||
#ifdef DEFAULT_LOADER_NVRAM
|
||||
if (virFirmwareParseList(DEFAULT_LOADER_NVRAM,
|
||||
&cfg->firmwares,
|
||||
--
|
||||
2.9.3
|
||||
|
31
libvirt.spec
31
libvirt.spec
@ -226,14 +226,14 @@
|
||||
|
||||
Summary: Library providing a simple virtualization API
|
||||
Name: libvirt
|
||||
Version: 3.2.0
|
||||
Version: 3.2.1
|
||||
Release: 1%{?dist}%{?extra_release}
|
||||
License: LGPLv2+
|
||||
Group: Development/Libraries
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
||||
URL: http://libvirt.org/
|
||||
|
||||
%if %(echo %{version} | grep -o \\. | wc -l) == 3
|
||||
%if %(echo %{version} | grep -q "\.0$"; echo $?) == 1
|
||||
%define mainturl stable_updates/
|
||||
%endif
|
||||
Source: http://libvirt.org/sources/%{?mainturl}libvirt-%{version}.tar.xz
|
||||
@ -359,7 +359,7 @@ BuildRequires: parted-devel
|
||||
# For Multipath support
|
||||
BuildRequires: device-mapper-devel
|
||||
%if %{with_storage_rbd}
|
||||
%if 0%{?rhel} >= 7
|
||||
%if 0%{?fedora} || 0%{?rhel} >= 7
|
||||
BuildRequires: librados2-devel
|
||||
BuildRequires: librbd1-devel
|
||||
%else
|
||||
@ -1363,6 +1363,13 @@ cp $RPM_BUILD_ROOT%{_sysconfdir}/libvirt/qemu/networks/default.xml \
|
||||
$RPM_BUILD_ROOT%{_datadir}/libvirt/networks/default.xml
|
||||
rm -f $RPM_BUILD_ROOT%{_sysconfdir}/libvirt/qemu/networks/default.xml
|
||||
rm -f $RPM_BUILD_ROOT%{_sysconfdir}/libvirt/qemu/networks/autostart/default.xml
|
||||
|
||||
# nwfilter files are installed in /usr/share/libvirt and copied to /etc in %post
|
||||
# to avoid verification errors on changed files in /etc
|
||||
install -d -m 0755 $RPM_BUILD_ROOT%{_datadir}/libvirt/nwfilter/
|
||||
cp -a $RPM_BUILD_ROOT%{_sysconfdir}/libvirt/nwfilter/*.xml \
|
||||
$RPM_BUILD_ROOT%{_datadir}/libvirt/nwfilter/
|
||||
|
||||
# Strip auto-generated UUID - we need it generated per-install
|
||||
sed -i -e "/<uuid>/d" $RPM_BUILD_ROOT%{_datadir}/libvirt/networks/default.xml
|
||||
%if ! %{with_qemu}
|
||||
@ -1589,6 +1596,17 @@ if test $1 -eq 1 && test ! -f %{_sysconfdir}/libvirt/qemu/networks/default.xml ;
|
||||
|
||||
fi
|
||||
|
||||
|
||||
%post daemon-config-nwfilter
|
||||
cp %{_datadir}/libvirt/nwfilter/*.xml %{_sysconfdir}/libvirt/nwfilter/
|
||||
# Make sure libvirt picks up the new nwfilter defininitons
|
||||
%if %{with_systemd}
|
||||
/bin/systemctl try-restart libvirtd.service >/dev/null 2>&1 ||:
|
||||
%else
|
||||
/sbin/service libvirtd condrestart > /dev/null 2>&1 || :
|
||||
%endif
|
||||
|
||||
|
||||
%if %{with_systemd}
|
||||
%triggerun -- libvirt < 0.9.4
|
||||
%{_bindir}/systemd-sysv-convert --save libvirtd >/dev/null 2>&1 ||:
|
||||
@ -1770,7 +1788,9 @@ exit 0
|
||||
%{_datadir}/libvirt/networks/default.xml
|
||||
|
||||
%files daemon-config-nwfilter
|
||||
%{_sysconfdir}/libvirt/nwfilter/*.xml
|
||||
%dir %{_datadir}/libvirt/nwfilter/
|
||||
%{_datadir}/libvirt/nwfilter/*.xml
|
||||
%ghost %{_sysconfdir}/libvirt/nwfilter/*.xml
|
||||
|
||||
%files daemon-driver-interface
|
||||
%{_libdir}/%{name}/connection-driver/libvirt_driver_interface.so
|
||||
@ -2052,6 +2072,9 @@ exit 0
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed May 10 2017 Cole Robinson <crobinso@redhat.com> - 3.2.1-1
|
||||
- Rebased to version 3.2.1
|
||||
|
||||
* Mon Apr 3 2017 Daniel P. Berrange <berrange@redhat.com> - 3.2.0-1
|
||||
- Rebase to version 3.2.0
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (libvirt-3.2.0.tar.xz) = 35a9db3d59a3817d15fd6a586a2a73860b3d8a2d2ff37dbea1b4045fe1514c3535fce2eeba0f09df2d0bb9072ed9f1078ca9bad61a37c586eb019ddad3f898c4
|
||||
SHA512 (libvirt-3.2.1.tar.xz) = 4ec4faceedcad3a5419e91444b0c83adcbed0ff6482fb53c058a75412064de69e09fd096de4a30b8c1149da6ba03287b10e8af925b01d725e655658035e43d9a
|
||||
|
Loading…
Reference in New Issue
Block a user