Upgrade to the upstream release. (BZ 738595).
Use official distribution URL for %{source}.
This commit is contained in:
parent
eda4efe17e
commit
c4c9b1ec74
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
||||
/libunwind-20110424git1e10c293.tar.bz2
|
||||
/libunwind-1.0.1.tar.gz
|
||||
|
@ -4,25 +4,15 @@ match src/setjmp/setjmp.c + include/tdep-x86_64/jmpbuf.h .
|
||||
|
||||
google-perftools link only with libunwind.so.7 .
|
||||
|
||||
diff -dup -rup libunwind-20110424git1e10c293-orig//src/Makefile.am libunwind-20110424git1e10c293//src/Makefile.am
|
||||
--- libunwind-20110424git1e10c293-orig//src/Makefile.am 2011-04-24 19:56:54.000000000 +0200
|
||||
+++ libunwind-20110424git1e10c293//src/Makefile.am 2011-04-24 21:56:15.000000000 +0200
|
||||
--- libunwind-1.0.1-orig/src/Makefile.am 2011-09-11 05:06:41.000000000 +0200
|
||||
+++ libunwind-1.0.1/src/Makefile.am 2011-09-15 13:55:42.000000000 +0200
|
||||
@@ -1,5 +1,5 @@
|
||||
SOVERSION=7:0:0 # See comments at end of file.
|
||||
SOVERSION=8:0:0 # See comments at end of file.
|
||||
-SETJMP_SO_VERSION=0:0:0
|
||||
+#SETJMP_SO_VERSION=0:0:0
|
||||
#
|
||||
# Don't link with start-files since we don't use any constructors/destructors:
|
||||
#
|
||||
@@ -9,7 +9,7 @@ lib_LIBRARIES =
|
||||
lib_LTLIBRARIES =
|
||||
if !REMOTE_ONLY
|
||||
lib_LIBRARIES += libunwind-ptrace.a
|
||||
-lib_LTLIBRARIES += libunwind.la libunwind-setjmp.la
|
||||
+lib_LTLIBRARIES += libunwind.la #libunwind-setjmp.la
|
||||
endif
|
||||
|
||||
noinst_HEADERS =
|
||||
@@ -27,8 +27,8 @@ libunwind_ptrace_a_SOURCES = \
|
||||
noinst_HEADERS += ptrace/_UPT_internal.h
|
||||
|
||||
@ -53,7 +43,7 @@ diff -dup -rup libunwind-20110424git1e10c293-orig//src/Makefile.am libunwind-201
|
||||
|
||||
### libunwind:
|
||||
libunwind_la_LIBADD =
|
||||
@@ -369,7 +369,7 @@ if ARCH_ARM
|
||||
@@ -373,7 +373,7 @@ if ARCH_ARM
|
||||
if !REMOTE_ONLY
|
||||
libunwind_arm_la_LIBADD += libunwind.la -lc
|
||||
endif
|
||||
@ -62,7 +52,7 @@ diff -dup -rup libunwind-20110424git1e10c293-orig//src/Makefile.am libunwind-201
|
||||
else
|
||||
if ARCH_IA64
|
||||
ia64_mk_Gcursor_i_SOURCES = ia64/mk_Gcursor_i.c
|
||||
@@ -389,8 +389,8 @@ Lcursor_i.h: ia64/mk_Lcursor_i
|
||||
@@ -393,8 +393,8 @@ Lcursor_i.h: ia64/mk_Lcursor_i
|
||||
if !REMOTE_ONLY
|
||||
libunwind_ia64_la_LIBADD += libunwind.la -lc
|
||||
endif
|
||||
@ -73,7 +63,7 @@ diff -dup -rup libunwind-20110424git1e10c293-orig//src/Makefile.am libunwind-201
|
||||
else
|
||||
if ARCH_HPPA
|
||||
lib_LTLIBRARIES += libunwind-hppa.la
|
||||
@@ -402,7 +402,7 @@ if ARCH_HPPA
|
||||
@@ -406,7 +406,7 @@ if ARCH_HPPA
|
||||
if !REMOTE_ONLY
|
||||
libunwind_hppa_la_LIBADD += libunwind.la -lc
|
||||
endif
|
||||
@ -82,7 +72,7 @@ diff -dup -rup libunwind-20110424git1e10c293-orig//src/Makefile.am libunwind-201
|
||||
else
|
||||
if ARCH_MIPS
|
||||
lib_LTLIBRARIES += libunwind-mips.la
|
||||
@@ -414,7 +414,7 @@ if ARCH_MIPS
|
||||
@@ -418,7 +418,7 @@ if ARCH_MIPS
|
||||
if !REMOTE_ONLY
|
||||
libunwind_mips_la_LIBADD += libunwind.la -lc
|
||||
endif
|
||||
@ -91,7 +81,7 @@ diff -dup -rup libunwind-20110424git1e10c293-orig//src/Makefile.am libunwind-201
|
||||
else
|
||||
if ARCH_X86
|
||||
lib_LTLIBRARIES += libunwind-x86.la
|
||||
@@ -426,7 +426,7 @@ if ARCH_X86
|
||||
@@ -430,7 +430,7 @@ if ARCH_X86
|
||||
if !REMOTE_ONLY
|
||||
libunwind_x86_la_LIBADD += libunwind.la -lc
|
||||
endif
|
||||
@ -100,7 +90,7 @@ diff -dup -rup libunwind-20110424git1e10c293-orig//src/Makefile.am libunwind-201
|
||||
else
|
||||
if ARCH_X86_64
|
||||
lib_LTLIBRARIES += libunwind-x86_64.la
|
||||
@@ -438,7 +438,7 @@ if ARCH_X86_64
|
||||
@@ -442,7 +442,7 @@ if ARCH_X86_64
|
||||
if !REMOTE_ONLY
|
||||
libunwind_x86_64_la_LIBADD += libunwind.la -lc
|
||||
endif
|
||||
@ -109,7 +99,7 @@ diff -dup -rup libunwind-20110424git1e10c293-orig//src/Makefile.am libunwind-201
|
||||
else
|
||||
if ARCH_PPC32
|
||||
lib_LTLIBRARIES += libunwind-ppc32.la
|
||||
@@ -450,7 +450,7 @@ if ARCH_PPC32
|
||||
@@ -454,7 +454,7 @@ if ARCH_PPC32
|
||||
if !REMOTE_ONLY
|
||||
libunwind_ppc32_la_LIBADD += libunwind.la -lc
|
||||
endif
|
||||
@ -118,7 +108,7 @@ diff -dup -rup libunwind-20110424git1e10c293-orig//src/Makefile.am libunwind-201
|
||||
else
|
||||
if ARCH_PPC64
|
||||
lib_LTLIBRARIES += libunwind-ppc64.la
|
||||
@@ -462,7 +462,7 @@ if ARCH_PPC64
|
||||
@@ -466,7 +466,7 @@ if ARCH_PPC64
|
||||
if !REMOTE_ONLY
|
||||
libunwind_ppc64_la_LIBADD += libunwind.la -lc
|
||||
endif
|
||||
@ -127,9 +117,17 @@ diff -dup -rup libunwind-20110424git1e10c293-orig//src/Makefile.am libunwind-201
|
||||
|
||||
endif # ARCH_PPC64
|
||||
endif # ARCH_PPC32
|
||||
diff -dup -rup libunwind-20110424git1e10c293-orig//tests/Makefile.am libunwind-20110424git1e10c293//tests/Makefile.am
|
||||
--- libunwind-20110424git1e10c293-orig//tests/Makefile.am 2011-04-24 19:56:54.000000000 +0200
|
||||
+++ libunwind-20110424git1e10c293//tests/Makefile.am 2011-04-24 21:57:31.000000000 +0200
|
||||
@@ -480,7 +480,7 @@ endif # ARCH_ARM
|
||||
# libunwind-setjmp depends on libunwind-$(arch). Therefore must be added
|
||||
# at the end.
|
||||
if !REMOTE_ONLY
|
||||
-lib_LTLIBRARIES += libunwind-setjmp.la
|
||||
+#lib_LTLIBRARIES += libunwind-setjmp.la
|
||||
endif
|
||||
|
||||
#
|
||||
--- libunwind-1.0.1-orig/tests/Makefile.am 2011-09-11 05:06:41.000000000 +0200
|
||||
+++ libunwind-1.0.1/tests/Makefile.am 2011-09-15 13:56:16.000000000 +0200
|
||||
@@ -27,7 +27,7 @@ if ARCH_IA64
|
||||
Gia64-test-nat Lia64-test-nat \
|
||||
Gia64-test-rbs Lia64-test-rbs \
|
||||
@ -139,17 +137,18 @@ diff -dup -rup libunwind-20110424git1e10c293-orig//tests/Makefile.am libunwind-2
|
||||
else
|
||||
if ARCH_PPC64
|
||||
if USE_ALTIVEC
|
||||
@@ -44,8 +45,8 @@ endif #ARCH_IA64
|
||||
@@ -44,8 +44,9 @@ endif #ARCH_IA64
|
||||
Gtest-dyn1 Ltest-dyn1 \
|
||||
Gtest-trace Ltest-trace \
|
||||
test-async-sig test-flush-cache test-init-remote \
|
||||
- test-mem test-setjmp test-ptrace \
|
||||
+ test-mem test-ptrace \
|
||||
Ltest-nomalloc Ltest-nocalloc rs-race
|
||||
noinst_PROGRAMS_cdep = forker mapper test-ptrace-misc test-varargs \
|
||||
Gperf-simple Lperf-simple \
|
||||
Gperf-trace Lperf-trace
|
||||
@@ -120,8 +122,8 @@ if USE_ELFXX
|
||||
+# test-setjmp
|
||||
noinst_PROGRAMS_cdep = forker mapper test-ptrace-misc \
|
||||
Gperf-simple Lperf-simple
|
||||
|
||||
@@ -123,8 +124,8 @@ if USE_ELFXX
|
||||
LIBUNWIND_ELF = $(top_builddir)/src/libunwind-elfxx.la
|
||||
endif
|
||||
|
||||
@ -160,7 +159,7 @@ diff -dup -rup libunwind-20110424git1e10c293-orig//tests/Makefile.am libunwind-2
|
||||
|
||||
test_async_sig_LDADD = $(LIBUNWIND_local) -lpthread
|
||||
test_flush_cache_LDADD = $(LIBUNWIND_local)
|
||||
@@ -156,6 +158,6 @@ Lperf_simple_LDADD = $(LIBUNWIND_local)
|
||||
@@ -159,6 +160,6 @@ Lperf_simple_LDADD = $(LIBUNWIND_local)
|
||||
Ltest_trace_LDADD = $(LIBUNWIND_local)
|
||||
Lperf_trace_LDADD = $(LIBUNWIND_local)
|
||||
|
||||
|
@ -1,12 +1,12 @@
|
||||
--- libunwind-20110424git1e10c293-orig/src/Makefile.am 2011-05-09 15:46:44.000000000 +0200
|
||||
+++ libunwind-20110424git1e10c293/src/Makefile.am 2011-05-09 15:53:27.000000000 +0200
|
||||
--- libunwind-1.0.1/src/Makefile.am.orig 2011-09-15 13:57:09.000000000 +0200
|
||||
+++ libunwind-1.0.1/src/Makefile.am 2011-09-15 13:57:44.000000000 +0200
|
||||
@@ -8,7 +8,7 @@ COMMON_SO_LDFLAGS = -XCClinker -nostartf
|
||||
lib_LIBRARIES =
|
||||
lib_LTLIBRARIES =
|
||||
if !REMOTE_ONLY
|
||||
-lib_LIBRARIES += libunwind-ptrace.a
|
||||
+lib_LTLIBRARIES += libunwind-ptrace.la
|
||||
lib_LTLIBRARIES += libunwind.la #libunwind-setjmp.la
|
||||
lib_LTLIBRARIES += libunwind.la
|
||||
endif
|
||||
|
||||
@@ -16,7 +16,7 @@ noinst_HEADERS =
|
||||
|
@ -3,12 +3,11 @@
|
||||
|
||||
Summary: An unwinding library
|
||||
Name: libunwind
|
||||
Version: 0.99
|
||||
%define snapshot 20110424git1e10c293
|
||||
Release: 3.%{snapshot}%{?dist}
|
||||
Version: 1.0.1
|
||||
Release: 1%{?dist}
|
||||
License: BSD
|
||||
Group: Development/Debuggers
|
||||
Source: libunwind-%{snapshot}.tar.bz2
|
||||
Source: http://download.savannah.gnu.org/releases/libunwind/libunwind-%{version}.tar.gz
|
||||
#Fedora specific patch
|
||||
Patch1: libunwind-disable-setjmp.patch
|
||||
Patch2: libunwind-install-ptrace.patch
|
||||
@ -34,7 +33,7 @@ The libunwind-devel package includes the libraries and header files for
|
||||
libunwind.
|
||||
|
||||
%prep
|
||||
%setup -q -n libunwind-%{snapshot}
|
||||
%setup -q
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
|
||||
@ -87,6 +86,10 @@ echo ====================TESTSUITE DISABLED=========================
|
||||
%{_includedir}/libunwind*.h
|
||||
|
||||
%changelog
|
||||
* Thu Sep 15 2011 Jan Kratochvil <jan.kratochvil@redhat.com> - 1.0.1-1.fc17
|
||||
- Upgrade to the upstream release. (BZ 738595).
|
||||
- Use official distribution URL for %%{source}.
|
||||
|
||||
* Thu Jun 02 2011 Paul Whalen <paul.whalen@senecac.on.ca> - 0.99-3.20110424git1e10c293
|
||||
- Added arm macro to ExclusiveArch
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user