Merge remote-tracking branch 'up/main' into main-riscv64

Signed-off-by: David Abdurachmanov <davidlt@rivosinc.com>
This commit is contained in:
David Abdurachmanov 2024-03-20 09:37:16 +02:00
commit b246e00145
Signed by: davidlt
GPG Key ID: 7A5F42FAF91FACC3
3 changed files with 37 additions and 17 deletions

View File

@ -10,16 +10,15 @@ in DSOs (they are considered external):
This patch is downstream-specific due to annobin.
diff --git a/src/Makefile.am b/src/Makefile.am
index 2b5b02959e99eb8f..e5ff21515c36d30f 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -147,7 +147,7 @@ libunwind_la_SOURCES_local = \
$(libunwind_la_SOURCES_local_unwind)
noinst_HEADERS += os-linux.h
-libunwind_la_SOURCES_os_linux = os-linux.c dl-iterate-phdr.c
+libunwind_la_SOURCES_os_linux = os-linux.c
libunwind_la_SOURCES_os_hpux = os-hpux.c
diff -up libunwind-1.8.0/src/Makefile.am.no-dl-iterate-phdr libunwind-1.8.0/src/Makefile.am
--- libunwind-1.8.0/src/Makefile.am.no-dl-iterate-phdr 2024-01-29 16:30:52.230008417 -0500
+++ libunwind-1.8.0/src/Makefile.am 2024-01-29 16:31:40.476692706 -0500
@@ -346,7 +346,7 @@ noinst_LTLIBRARIES += $(libunwind_elf_li
libunwind_la_LIBADD += $(libunwind_elf_libs)
if OS_LINUX
- libunwind_la_SOURCES_os = os-linux.c dl-iterate-phdr.c
+ libunwind_la_SOURCES_os = os-linux.c
libunwind_la_SOURCES_os_local = $(libunwind_la_SOURCES_os_linux_local)
libunwind_la_SOURCES_aarch64_os = aarch64/Gos-linux.c
libunwind_la_SOURCES_aarch64_os_local = aarch64/Los-linux.c

View File

@ -35,7 +35,7 @@
# Ltest-resume-sig-rt
# test-ptrace
%ifarch aarch64 i686 ppc64le s390x
%ifarch i686 ppc64le s390x
%global test_failure_override true
%else
%global test_failure_override false
@ -45,8 +45,8 @@
Summary: An unwinding library
Name: libunwind
Version: 1.7.2
Release: 1.0.riscv64%{?dist}
Version: 1.8.0
Release: 3.0.riscv64%{?dist}
License: MIT
URL: http://savannah.nongnu.org/projects/libunwind
Source: https://github.com/libunwind/libunwind/releases/download/v%{version}/%{name}-%{version}.tar.gz
@ -81,6 +81,11 @@ libunwind.
%autosetup -p1 -n %{name}-%{version}
%build
%ifarch aarch64
# LTO causes FTBFS on aarch64 (rhbz#2261344)
%global _lto_cflags %{nil}
%endif
%global optflags %{optflags} -fcommon
aclocal
libtoolize --force
@ -131,9 +136,25 @@ echo ====================TESTING END=====================
%{_includedir}/libunwind*.h
%changelog
* Thu Dec 14 2023 David Abdurachmanov <davidlt@rivosinc.com> - 1.7.2-1.0.riscv64
* Wed Mar 20 2023 David Abdurachmanov <davidlt@rivosinc.com> - 1.8.0-3.0.riscv64
- Enable riscv64 (now supported upstream)
* Wed Mar 06 2024 Richard W.M. Jones <rjones@redhat.com> - 1.8.0-3
- Bump and rebuild package (for riscv64)
* Thu Feb 08 2024 Kalev Lember <klember@redhat.com> - 1.8.0-2
- Disable LTO on aarch64 to fix the build (rhbz#2261344)
- Re-enable tests on aarch64
* Mon Jan 29 2024 Tom Callaway <spot@fedoraproject.org> - 1.8.0-1
- update to 1.8.0
* Thu Jan 25 2024 Fedora Release Engineering <releng@fedoraproject.org> - 1.7.2-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
* Sun Jan 21 2024 Fedora Release Engineering <releng@fedoraproject.org> - 1.7.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
* Wed Aug 9 2023 Tom Callaway <spot@fedoraproject.org> - 1.7.2-1
- update to 1.7.2

View File

@ -1 +1 @@
SHA512 (libunwind-1.7.2.tar.gz) = 903f7e26c7d4c22e6ef4fe8954ca0f153fdf346cec40e1e8f7ab966d251110f4deb0a84d1fd150aee194ed966b5c1e01ee27c821cd043859852da33a94faae1f
SHA512 (libunwind-1.8.0.tar.gz) = ecbcfacacbcc4f7e4326397af448c92253f88b8f57c14c31b9b82b3a2951eb67b164b2a137b2800a2ada933a07a5bdd75f0198d3e4c6a2d8d740559e3a76f1b2