Merge remote-tracking branch 'up/main' into main-riscv64

Signed-off-by: David Abdurachmanov <davidlt@rivosinc.com>
This commit is contained in:
David Abdurachmanov 2024-02-02 11:20:10 +02:00
commit d20131ea50
Signed by: davidlt
GPG Key ID: 7A5F42FAF91FACC3
3 changed files with 119 additions and 8 deletions

View File

@ -0,0 +1,35 @@
From 414deacee0f564afdf2d7750450274c581330a59 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Fr=C3=A9d=C3=A9ric=20B=C3=A9rat?= <fberat@redhat.com>
Date: Wed, 21 Dec 2022 13:14:03 +0100
Subject: [PATCH] tests: Fix grep warning about stray \ before /
Recent version of grep emit a warning if stray \ is found before /.
This leads to the link-order test failure.
* tests/link-order.at: Remove unneeded \ before /
---
tests/link-order.at | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/tests/link-order.at b/tests/link-order.at
index 3f01a00d..a145347f 100644
--- a/tests/link-order.at
+++ b/tests/link-order.at
@@ -99,12 +99,12 @@ aix* | interix*) ;; # These systems have different path syntax
case $hardcode_direct$hardcode_direct_absolute in
yesno)
AT_CHECK([if $EGREP relinking stderr; then
- $EGREP " .*\/new\/lib/libb$shared_ext .*\/old\/lib/libcee$shared_ext" stdout
+ $EGREP " .*/new/lib/libb$shared_ext .*/old/lib/libcee$shared_ext" stdout
else :; fi], [0], [ignore], [], [echo "wrong link order"])
;;
*)
AT_CHECK([if $EGREP relinking stderr; then
- $EGREP " -L.*\/new\/lib -lb -L.*\/old\/lib -lcee" stdout
+ $EGREP " -L.*/new/lib -lb -L.*/old/lib -lcee" stdout
else :; fi], [0], [ignore], [], [echo "wrong link order"])
;;
esac
--
2.38.1

20
libtool-c99.patch Normal file
View File

@ -0,0 +1,20 @@
Include <string.h> for the strcmp function. This improves C99
compiler compatibility because it avoids an implicit function
declaration.
Submitted upstream:
<https://lists.gnu.org/archive/html/libtool-patches/2023-01/msg00000.html>
diff --git a/tests/lt_dlopen_a.at b/tests/lt_dlopen_a.at
index 95f18a0df165d41d..d3948738e4199cc6 100644
--- a/tests/lt_dlopen_a.at
+++ b/tests/lt_dlopen_a.at
@@ -27,6 +27,7 @@ AT_KEYWORDS([libltdl lt_dlopen_a])
AT_DATA([main.c],
[[#include <ltdl.h>
#include <stdio.h>
+#include <string.h>
/* This dlopen() in the main executable should override any dlopen()s in
shared libraries etc.

View File

@ -1,7 +1,3 @@
%ifarch riscv64
%global debug_package %{nil}
%endif
# See the bug #429880
%global gcc_major %(gcc -dumpversion || echo "666")
# See rhbz#1193591
@ -12,8 +8,41 @@
Summary: The GNU Portable Library Tool
Name: libtool
Version: 2.4.7
Release: 2.0.riscv64%{?dist}
License: GPLv2+ and LGPLv2+ and GFDL
Release: 10%{?dist}
# To help future rebase, the following licenses were seen in the following files/folders:
# '*' is anything that was not explicitly listed earlier in the folder
#
# From libtool package:
# usr/bin/:
# libtool - GPL-2.0-or-later WITH Libtool-exception AND MIT
# libtoolize - GPL-2.0-or-later AND MIT
# usr/share/:
# aclocal/* - FSFULLR
# doc/libtool:
# AUTHORS - GPL-2.0-or-later
# * - FSFAP
# info/* - GFDL-1.3-or-later
# libtool/build-aux/:
# {compile,depcomp,missing} - GPL-2.0-or-later WITH Autoconf-exception-generic
# config.{guess,sub} - GPL-3.0-or-later WITH Autoconf-exception-generic-3.0
# install-sh - X11 AND LicenseRef-Fedora-public-domain
# ltmain.sh - GPL-2.0-or-later WITH Libtool-exception AND MIT
# usr/share/man/man1/*: generated from usr/bin/libtool{,ize} using help2man
#
# From libtool-ltdl package:
# usr/lib64/
# * - LGPL-2.0-or-later WITH Libtool-exception
#
# From libtool-ltdl-devel package:
# usr/include/* - LGPL-2.0-or-later WITH Libtool-exception
# usr/share/:
# README - FSFAP
# {*.c,*.h,Makefile.am,configure.ac,ltdl.mk} - LGPL-2.0-or-later WITH Libtool-exception
# Makefile.in - FSFULLRWD
# aclocal.m4 - FSFULLR AND FSFULLRWD
# configure - FSFUL
License: GPL-2.0-or-later AND GPL-2.0-or-later WITH Autoconf-exception-generic AND GPL-2.0-or-later WITH Libtool-exception AND LGPL-2.0-or-later WITH Libtool-exception AND GPL-3.0-or-later WITH Autoconf-exception-generic-3.0 AND MIT AND FSFAP AND FSFULLR AND FSFULLRWD AND GFDL-1.3-or-later AND X11 AND LicenseRef-Fedora-public-domain
URL: http://www.gnu.org/software/libtool/
Source: http://ftp.gnu.org/gnu/libtool/libtool-%{version}.tar.xz
@ -43,10 +72,16 @@ Patch3: libtool-2.4.6-disable_non-pic_arm.patch
# https://lists.gnu.org/archive/html/libtool-patches/2022-02/msg00000.html
Patch4: libtool-2.4.6-keep-compiler-deps.patch
# Patch sent upstream
# https://lists.gnu.org/archive/html/libtool-patches/2022-12/msg00004.html
Patch5: 0001-tests-Fix-grep-warning-about-stray-before.patch
%if ! 0%{?_module_build}
Patch100: libtool-nodocs.patch
%endif
Patch101: libtool-c99.patch
# /usr/bin/libtool includes paths within gcc's versioned directories
# Libtool must be rebuilt whenever a new upstream gcc is built
# Starting with gcc 7 gcc in Fedora is packaged so that only major
@ -169,8 +204,29 @@ rm -f %{buildroot}%{_libdir}/libltdl.{a,la}
%changelog
* Fri Aug 05 2022 David Abdurachmanov <davidlt@rivosinc.com> - 2.4.7-2.0.riscv64
- Disable debug packages on riscv64
* Sun Jan 21 2024 Fedora Release Engineering <releng@fedoraproject.org> - 2.4.7-10
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
* Mon Jan 15 2024 Jakub Jelinek <jakub@redhat.com> - 2.4.7-9
- bump: for gcc 14.* in rawhide
* Tue Aug 08 2023 Frederic Berat <fberat@redhat.com> - 2.4.7-8
- Migrate to SPDX licenses (#2222091).
* Thu Jul 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 2.4.7-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
* Thu Jan 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 2.4.7-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
* Mon Jan 16 2023 Jakub Jelinek <jakub@redhat.com> - 2.4.7-5
- bump: for gcc 13.* in rawhide
* Tue Jan 10 2023 Florian Weimer <fweimer@redhat.com> - 2.4.7-4
- C99 compatibility fix in the testsuite
* Wed Dec 21 2022 Frederic Berat <fberat@redhat.com> - 2.4.7-3
- Fix test failure due to grep update
* Thu Jul 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 2.4.7-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild