97 lines
2.8 KiB
RPMSpec
97 lines
2.8 KiB
RPMSpec
%global libname termkey
|
|
|
|
# Unibilium by default, otherwise ncurses
|
|
%bcond_without unibilium
|
|
|
|
Name: lib%{libname}
|
|
Version: 0.20
|
|
Release: 4%{?dist}
|
|
Summary: Library for easy processing of keyboard entry from terminal-based programs
|
|
|
|
License: MIT
|
|
URL: http://www.leonerd.org.uk/code/libtermkey/
|
|
Source0: %{url}/%{name}-%{version}.tar.gz
|
|
|
|
# Non-upstream patches
|
|
Patch0: 0001-build-take-into-account-CFLAGS-LDFLAGS-for-tests.patch
|
|
Patch1: 0002-include-stdlib.h-for-putenv.patch
|
|
|
|
BuildRequires: gcc
|
|
BuildRequires: make
|
|
BuildRequires: libtool
|
|
%if %{with unibilium}
|
|
BuildRequires: pkgconfig(unibilium)
|
|
%else
|
|
BuildRequires: pkgconfig(tinfo)
|
|
%endif
|
|
# For tests
|
|
BuildRequires: %{_bindir}/prove
|
|
|
|
%description
|
|
This library allows easy processing of keyboard entry from terminal-based
|
|
programs. It handles all the necessary logic to recognise special keys, UTF-8
|
|
combining, and so on, with a simple interface.
|
|
|
|
%package devel
|
|
Summary: Development files needed for %{name}
|
|
Requires: %{name}%{?_isa} = %{version}-%{release}
|
|
|
|
%description devel
|
|
%{summary}.
|
|
|
|
%prep
|
|
%autosetup -p1
|
|
# no need for demos
|
|
sed -i -e '/^all:/s/$(DEMOS)//' Makefile
|
|
|
|
%build
|
|
CFLAGS="%{__global_cflags}" LDFLAGS="%{__global_ldflags}" %make_build VERBOSE=1
|
|
|
|
%install
|
|
%make_install PREFIX=%{_prefix} LIBDIR=%{_libdir}
|
|
rm -vf %{buildroot}%{_libdir}/*.{a,la}
|
|
|
|
%check
|
|
CFLAGS="%{__global_cflags} -D_XOPEN_SOURCE" LDFLAGS="%{__global_ldflags}" make test VERBOSE=1
|
|
|
|
%ldconfig_scriptlets
|
|
|
|
%files
|
|
%license LICENSE
|
|
%{_libdir}/%{name}.so.*
|
|
|
|
%files devel
|
|
%{_libdir}/%{name}.so
|
|
%{_includedir}/%{libname}.h
|
|
%{_libdir}/pkgconfig/%{libname}.pc
|
|
%{_mandir}/man3/%{libname}_*.3*
|
|
%{_mandir}/man7/%{libname}.7*
|
|
|
|
%changelog
|
|
* Sat May 26 2018 Andreas Schneider <asn@redhat.com> - 0.20-4
|
|
- Rebuild against unibilium-2.0.0
|
|
|
|
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.20-3
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
|
|
|
* Wed Jan 31 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.20-2
|
|
- Switch to %%ldconfig_scriptlets
|
|
|
|
* Wed Nov 08 2017 Andreas Schneider <asn@redhat.com> - 0.20-1
|
|
- Update to version 0.20
|
|
|
|
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.18-5
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
|
|
|
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.18-4
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
|
|
|
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.18-3
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
|
|
|
* Thu Dec 08 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.18-2
|
|
- Fix FTBFS
|
|
|
|
* Thu Apr 14 2016 Igor Gnatenko <ignatenko@redhat.com> - 0.18-1
|
|
- Initial package
|