* Downgrade - as in f20
This commit is contained in:
parent
d7e91532f0
commit
634063ccfc
1
.gitignore
vendored
1
.gitignore
vendored
@ -1 +1,2 @@
|
|||||||
/libstatgrab-0.90.tar.gz
|
/libstatgrab-0.90.tar.gz
|
||||||
|
/libstatgrab-0.17.tar.gz
|
||||||
|
52
libstatgrab.nochmod.patch
Normal file
52
libstatgrab.nochmod.patch
Normal file
@ -0,0 +1,52 @@
|
|||||||
|
--- src/statgrab/Makefile.am.old 2005-02-04 19:45:16.384407326 +0100
|
||||||
|
+++ src/statgrab/Makefile.am 2005-02-04 19:45:23.292225787 +0100
|
||||||
|
@@ -19,12 +19,12 @@
|
||||||
|
if STATGRAB
|
||||||
|
if SETGIDBINS
|
||||||
|
# Some operating systems need the binary to be setgid kmem
|
||||||
|
- chgrp kmem $(DESTDIR)@bindir@/statgrab
|
||||||
|
- chmod g+s $(DESTDIR)@bindir@/statgrab
|
||||||
|
+ chgrp kmem $(DESTDIR)@bindir@/statgrab || true
|
||||||
|
+ chmod g+s $(DESTDIR)@bindir@/statgrab || true
|
||||||
|
endif
|
||||||
|
if SETUIDBINS
|
||||||
|
# Some operating systems need the binary to be setuid root
|
||||||
|
- chown root $(DESTDIR)@bindir@/statgrab
|
||||||
|
+ chown root $(DESTDIR)@bindir@/statgrab || true
|
||||||
|
chmod u+s $(DESTDIR)@bindir@/statgrab
|
||||||
|
endif
|
||||||
|
endif
|
||||||
|
--- src/statgrab/Makefile.in.old 2005-02-04 19:56:55.352716673 +0100
|
||||||
|
+++ src/statgrab/Makefile.in 2005-02-04 19:57:31.010601483 +0100
|
||||||
|
@@ -507,10 +507,10 @@
|
||||||
|
|
||||||
|
install-exec-local:
|
||||||
|
# Some operating systems need the binary to be setgid kmem
|
||||||
|
-@SETGIDBINS_TRUE@@STATGRAB_TRUE@ chgrp kmem $(DESTDIR)@bindir@/statgrab
|
||||||
|
-@SETGIDBINS_TRUE@@STATGRAB_TRUE@ chmod g+s $(DESTDIR)@bindir@/statgrab
|
||||||
|
+@SETGIDBINS_TRUE@@STATGRAB_TRUE@ chgrp kmem $(DESTDIR)@bindir@/statgrab || true
|
||||||
|
+@SETGIDBINS_TRUE@@STATGRAB_TRUE@ chmod g+s $(DESTDIR)@bindir@/statgrab || true
|
||||||
|
# Some operating systems need the binary to be setuid root
|
||||||
|
-@SETUIDBINS_TRUE@@STATGRAB_TRUE@ chown root $(DESTDIR)@bindir@/statgrab
|
||||||
|
+@SETUIDBINS_TRUE@@STATGRAB_TRUE@ chown root $(DESTDIR)@bindir@/statgrab || true
|
||||||
|
@SETUIDBINS_TRUE@@STATGRAB_TRUE@ chmod u+s $(DESTDIR)@bindir@/statgrab
|
||||||
|
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
||||||
|
# Otherwise a system limit (for SysV at least) may be exceeded.
|
||||||
|
--- src/saidar/Makefile.in.old 2005-02-04 20:34:08.108193091 +0100
|
||||||
|
+++ src/saidar/Makefile.in 2005-02-04 20:34:34.550848428 +0100
|
||||||
|
@@ -474,11 +474,11 @@
|
||||||
|
|
||||||
|
install-exec-local:
|
||||||
|
# Some operating systems need the binary to be setgid kmem
|
||||||
|
-@SAIDAR_TRUE@@SETGIDBINS_TRUE@ chgrp kmem $(DESTDIR)@bindir@/saidar
|
||||||
|
-@SAIDAR_TRUE@@SETGIDBINS_TRUE@ chmod g+s $(DESTDIR)@bindir@/saidar
|
||||||
|
+@SAIDAR_TRUE@@SETGIDBINS_TRUE@ chgrp kmem $(DESTDIR)@bindir@/saidar || true
|
||||||
|
+@SAIDAR_TRUE@@SETGIDBINS_TRUE@ chmod g+s $(DESTDIR)@bindir@/saidar || true
|
||||||
|
# Some operating systems need the binary to be setuid root
|
||||||
|
-@SAIDAR_TRUE@@SETUIDBINS_TRUE@ chown root $(DESTDIR)@bindir@/saidar
|
||||||
|
-@SAIDAR_TRUE@@SETUIDBINS_TRUE@ chmod u+s $(DESTDIR)@bindir@/saidar
|
||||||
|
+@SAIDAR_TRUE@@SETUIDBINS_TRUE@ chown root $(DESTDIR)@bindir@/saidar || true
|
||||||
|
+@SAIDAR_TRUE@@SETUIDBINS_TRUE@ chmod u+s $(DESTDIR)@bindir@/saidar || true
|
||||||
|
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
||||||
|
# Otherwise a system limit (for SysV at least) may be exceeded.
|
||||||
|
.NOEXPORT:
|
@ -1,12 +1,14 @@
|
|||||||
%global pkgname statgrab
|
%global pkgname statgrab
|
||||||
|
|
||||||
Name: libstatgrab
|
Name: libstatgrab
|
||||||
Version: 0.90
|
Version: 0.17
|
||||||
Release: 2%{?dist}
|
Release: 5%{?dist}.2
|
||||||
|
Epoch: 1
|
||||||
Summary: A library that provides cross platform access to statistics about the system
|
Summary: A library that provides cross platform access to statistics about the system
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
URL: http://www.i-scream.org/libstatgrab
|
URL: http://www.i-scream.org/libstatgrab
|
||||||
Source0: http://ftp.i-scream.org/pub/i-scream/%{name}/%{name}-%{version}.tar.gz
|
Source0: http://ftp.i-scream.org/pub/i-scream/%{name}/%{name}-%{version}.tar.gz
|
||||||
|
Patch0: %{name}.nochmod.patch
|
||||||
BuildRequires: libtool ncurses-devel
|
BuildRequires: libtool ncurses-devel
|
||||||
|
|
||||||
%description
|
%description
|
||||||
@ -38,7 +40,7 @@ information like top, but - of course - OTHER informations.
|
|||||||
|
|
||||||
%package devel
|
%package devel
|
||||||
Summary: The development files from %{name}
|
Summary: The development files from %{name}
|
||||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
Requires: %{name}%{?_isa} = %{epoch}:%{version}-%{release}
|
||||||
|
|
||||||
%description devel
|
%description devel
|
||||||
This package contains header files and man pages for those
|
This package contains header files and man pages for those
|
||||||
@ -47,7 +49,7 @@ use to develop libstatgrab based applications.
|
|||||||
%package examples
|
%package examples
|
||||||
Summary: The example files from %{name}
|
Summary: The example files from %{name}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
Requires: %{name}%{?_isa} = %{epoch}:%{version}-%{release}
|
||||||
|
|
||||||
%description examples
|
%description examples
|
||||||
This package contains various examples used to show how
|
This package contains various examples used to show how
|
||||||
@ -55,6 +57,7 @@ to develop libstatgrab based applications.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%patch0 -p0
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure --with-ncurses --disable-static
|
%configure --with-ncurses --disable-static
|
||||||
@ -113,6 +116,12 @@ find %{buildroot} -name '*.la' -delete
|
|||||||
%{_mandir}/*/saidar*
|
%{_mandir}/*/saidar*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Sep 17 2013 Oliver Falk <oliver@linux-kernel.at> - 1:0.17-5.2
|
||||||
|
- Fix requires (epoch)
|
||||||
|
|
||||||
|
* Tue Sep 17 2013 Oliver Falk <oliver@linux-kernel.at> - 1:0.17-5.1
|
||||||
|
- Fix BZ#1008491 - too many broken deps
|
||||||
|
|
||||||
* Fri Aug 16 2013 Christopher Meng <rpm@cicku.me> - 0.90-2
|
* Fri Aug 16 2013 Christopher Meng <rpm@cicku.me> - 0.90-2
|
||||||
- SPEC Cleanup.
|
- SPEC Cleanup.
|
||||||
- Remove unneeded Requires.
|
- Remove unneeded Requires.
|
||||||
|
Loading…
x
Reference in New Issue
Block a user