Add patch to fix undefined symbol: ssh_forward_listen (bug #1221310)
This commit is contained in:
parent
0d4a295682
commit
c7e1319f31
28
0001-Reintroduce-ssh_forward_listen-Fixes-194.patch
Normal file
28
0001-Reintroduce-ssh_forward_listen-Fixes-194.patch
Normal file
@ -0,0 +1,28 @@
|
|||||||
|
From 3c8fe6e2c595ee019408249c364b3019b6c31a8a Mon Sep 17 00:00:00 2001
|
||||||
|
From: Mike DePaulo <mikedep333@gmail.com>
|
||||||
|
Date: Fri, 15 May 2015 22:22:13 -0400
|
||||||
|
Subject: [PATCH] Reintroduce ssh_forward_listen() (Fixes: #194)
|
||||||
|
|
||||||
|
---
|
||||||
|
src/channels.c | 5 +++++
|
||||||
|
1 file changed, 5 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/src/channels.c b/src/channels.c
|
||||||
|
index 7a4e71f..db5f83a 100644
|
||||||
|
--- a/src/channels.c
|
||||||
|
+++ b/src/channels.c
|
||||||
|
@@ -2206,6 +2206,11 @@ error:
|
||||||
|
}
|
||||||
|
|
||||||
|
/* DEPRECATED */
|
||||||
|
+int ssh_forward_listen(ssh_session session, const char *address, int port, int *bound_port) {
|
||||||
|
+ return ssh_channel_listen_forward(session, address, port, bound_port);
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
+/* DEPRECATED */
|
||||||
|
ssh_channel ssh_forward_accept(ssh_session session, int timeout_ms) {
|
||||||
|
return ssh_channel_accept(session, SSH_CHANNEL_FORWARDED_TCPIP, timeout_ms, NULL);
|
||||||
|
}
|
||||||
|
--
|
||||||
|
2.1.4
|
||||||
|
|
10
libssh.spec
10
libssh.spec
@ -1,6 +1,6 @@
|
|||||||
Name: libssh
|
Name: libssh
|
||||||
Version: 0.7.0
|
Version: 0.7.0
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: A library implementing the SSH protocol
|
Summary: A library implementing the SSH protocol
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
URL: http://www.libssh.org
|
URL: http://www.libssh.org
|
||||||
@ -8,6 +8,10 @@ Group: System Environment/Libraries
|
|||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
Source0: https://red.libssh.org/attachments/download/140/libssh-0.7.0.tar.xz
|
Source0: https://red.libssh.org/attachments/download/140/libssh-0.7.0.tar.xz
|
||||||
|
# Fix undefined symbol: ssh_forward_listen
|
||||||
|
# https://bugzilla.redhat.com/show_bug.cgi?id=1221310
|
||||||
|
# https://red.libssh.org/issues/194
|
||||||
|
Patch0: https://red.libssh.org/attachments/download/143/0001-Reintroduce-ssh_forward_listen-Fixes-194.patch
|
||||||
|
|
||||||
BuildRequires: cmake
|
BuildRequires: cmake
|
||||||
BuildRequires: doxygen
|
BuildRequires: doxygen
|
||||||
@ -36,6 +40,7 @@ applications that use %{name}.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%patch0 -p1
|
||||||
# Remove examples, they are not packaged and do not build on EPEL 5
|
# Remove examples, they are not packaged and do not build on EPEL 5
|
||||||
sed -i -e 's|add_subdirectory(examples)||g' CMakeLists.txt
|
sed -i -e 's|add_subdirectory(examples)||g' CMakeLists.txt
|
||||||
rm -rf examples
|
rm -rf examples
|
||||||
@ -88,6 +93,9 @@ rm -rf %{buildroot}
|
|||||||
%{_libdir}/libssh_threads.so
|
%{_libdir}/libssh_threads.so
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu May 21 2015 Orion Poplawski <orion@cora.nwra.com> - 0.7.0-2
|
||||||
|
- Add patch to fix undefined symbol: ssh_forward_listen (bug #1221310)
|
||||||
|
|
||||||
* Mon May 11 2015 Andreas Schneider <asn@redhat.com> - 0.7.0-1
|
* Mon May 11 2015 Andreas Schneider <asn@redhat.com> - 0.7.0-1
|
||||||
- Update to version 0.7.0
|
- Update to version 0.7.0
|
||||||
* Added support for ed25519 keys
|
* Added support for ed25519 keys
|
||||||
|
Loading…
Reference in New Issue
Block a user