libsemanage/libsemanage-rhat.patch
2006-01-14 04:52:47 +00:00

43 lines
1.1 KiB
Diff

diff --exclude-from=exclude -N -u -r nsalibsemanage/Makefile libsemanage-1.5.14/Makefile
--- nsalibsemanage/Makefile 2006-01-05 10:33:10.000000000 -0500
+++ libsemanage-1.5.14/Makefile 2006-01-13 23:46:32.000000000 -0500
@@ -1,11 +1,17 @@
all:
$(MAKE) -C src all
+pywrap:
+ $(MAKE) -C src pywrap
+
install:
$(MAKE) -C include install
$(MAKE) -C src install
$(MAKE) -C man install
+install-pywrap:
+ $(MAKE) -C src install-pywrap
+
relabel:
clean:
diff --exclude-from=exclude -N -u -r nsalibsemanage/src/Makefile libsemanage-1.5.14/src/Makefile
--- nsalibsemanage/src/Makefile 2005-11-29 10:54:15.000000000 -0500
+++ libsemanage-1.5.14/src/Makefile 2006-01-13 23:46:17.000000000 -0500
@@ -37,7 +37,7 @@
SWIG = swig -Wall -python -o $(SWIGCOUT) -outdir ./
-all: $(LIBA) $(LIBSO) $(SWIGSO)
+all: $(LIBA) $(LIBSO)
pywrap: all $(SWIGLOBJ) $(SWIGSO)
@@ -75,7 +75,7 @@
swigify: $(SWIGIF)
$(SWIG) $^
-install: all install-pywrap
+install: all
test -d $(LIBDIR) || install -m 755 -d $(LIBDIR)
install -m 644 $(LIBA) $(LIBDIR)
test -d $(SHLIBDIR) || install -m 755 -d $(SHLIBDIR)