Update to upstream
2.1.2 2011-08-17 * print error debug info for buggy fc * introduce semanage_set_root and friends * throw exceptions in python rather than return * python3 support. * patch for MCS/MLS in user files
This commit is contained in:
parent
617897ade9
commit
716220e45b
@ -1,17 +1,3 @@
|
||||
diff --git a/libsemanage/src/Makefile b/libsemanage/src/Makefile
|
||||
index d21e972..f73b6ae 100644
|
||||
--- a/libsemanage/src/Makefile
|
||||
+++ b/libsemanage/src/Makefile
|
||||
@@ -69,6 +69,9 @@ pywrap: all $(SWIGSO)
|
||||
|
||||
rubywrap: all $(SWIGRUBYSO)
|
||||
|
||||
+semanageswig_python_exception.i: ../include/semanage/semanage.h
|
||||
+ bash exception.sh > $@
|
||||
+
|
||||
$(SWIGLOBJ): $(SWIGCOUT)
|
||||
$(CC) $(filter-out -Werror, $(CFLAGS)) $(PYINC) -fPIC -DSHARED -c -o $@ $<
|
||||
|
||||
diff --git a/libsemanage/src/direct_api.c b/libsemanage/src/direct_api.c
|
||||
index aac1974..3dfa279 100644
|
||||
--- a/libsemanage/src/direct_api.c
|
||||
|
Loading…
Reference in New Issue
Block a user