- Fix leaky descriptor
This commit is contained in:
parent
a247f456ee
commit
07a3ad638e
@ -1,11 +1,12 @@
|
||||
--- libsemanage-1.5.28/src/Makefile~ 2006-02-17 14:45:52.000000000 -0500
|
||||
+++ libsemanage-1.5.28/src/Makefile 2006-03-17 08:44:29.000000000 -0500
|
||||
@@ -3,7 +3,7 @@
|
||||
LIBDIR ?= $(PREFIX)/lib
|
||||
SHLIBDIR ?= $(DESTDIR)/lib
|
||||
INCLUDEDIR ?= $(PREFIX)/include
|
||||
-PYLIBVER ?= python2.4
|
||||
+PYLIBVER ?= $(shell python -c 'import sys;print "python%d.%d" % sys.version_info[0:2]')
|
||||
PYINC ?= /usr/include/${PYLIBVER}
|
||||
PYLIBDIR ?= $(LIBDIR)/${PYLIBVER}
|
||||
|
||||
diff --exclude-from=exclude -N -u -r nsalibsemanage/src/semanage_store.c libsemanage-1.6.2/src/semanage_store.c
|
||||
--- nsalibsemanage/src/semanage_store.c 2006-03-10 09:48:01.000000000 -0500
|
||||
+++ libsemanage-1.6.2/src/semanage_store.c 2006-03-29 14:20:16.000000000 -0500
|
||||
@@ -1159,6 +1159,8 @@
|
||||
ERR(sh, "Could not open direct %s at %s.", lock_name, lock_file);
|
||||
return -1;
|
||||
}
|
||||
+ fcntl(fd, F_SETFD, FD_CLOEXEC);
|
||||
+
|
||||
if (sh->timeout == 0) {
|
||||
/* return immediately */
|
||||
origtime.tv_sec = 0;
|
||||
|
@ -44,6 +44,8 @@ needed for developing applications that manipulate binary policies.
|
||||
|
||||
%build
|
||||
make clean
|
||||
# Don't want to rebuild
|
||||
touch src/semanage_wrap.c
|
||||
make CFLAGS="%{optflags}" all pywrap
|
||||
|
||||
%install
|
||||
|
Loading…
Reference in New Issue
Block a user