libselinux/libselinux-rhat.patch
Daniel J Walsh d27dc97404 - Make some fixes so it will build on RHEL4
- Upgrade to latest from NSA
Updated version for release.
Altered rpm_execcon fallback logic for permissive mode to also handle case
    where /selinux/enforce is not available.
2006-03-17 17:20:57 +00:00

12 lines
462 B
Diff

--- libselinux-1.29.7/src/Makefile~ 2006-01-20 10:37:52.000000000 -0500
+++ libselinux-1.29.7/src/Makefile 2006-03-16 17:22:52.000000000 -0500
@@ -3,7 +3,7 @@
LIBDIR ?= $(PREFIX)/lib
SHLIBDIR ?= $(DESTDIR)/lib
INCLUDEDIR ?= $(PREFIX)/include
-PYLIBVER ?= python2.4
+PYLIBVER ?= $(shell python -c 'import sys;print "python%d.%d" % sys.version_info[0:2]')
PYINC ?= /usr/include/$(PYLIBVER)
PYLIB ?= /usr/lib/$(PYLIBVER)
PYTHONLIBDIR ?= $(LIBDIR)/$(PYLIBVER)