libselinux/libselinux-rhat.patch

37 lines
945 B
Diff

diff --exclude-from=exclude -N -u -r nsalibselinux/Makefile libselinux-1.29.5/Makefile
--- nsalibselinux/Makefile 2005-02-09 17:04:51.000000000 -0500
+++ libselinux-1.29.5/Makefile 2006-01-13 23:54:13.000000000 -0500
@@ -2,12 +2,18 @@
$(MAKE) -C src
$(MAKE) -C utils
+pywrap:
+ $(MAKE) -C src pywrap
+
install:
$(MAKE) -C include install
$(MAKE) -C src install
$(MAKE) -C utils install
$(MAKE) -C man install
+install-pywrap:
+ $(MAKE) -C src install-pywrap
+
relabel:
$(MAKE) -C src relabel
diff --exclude-from=exclude -N -u -r nsalibselinux/src/Makefile libselinux-1.29.5/src/Makefile
--- nsalibselinux/src/Makefile 2006-01-04 10:37:34.000000000 -0500
+++ libselinux-1.29.5/src/Makefile 2006-01-13 23:54:50.000000000 -0500
@@ -26,7 +26,9 @@
SWIG = swig -Wall -python -o $(SWIGCOUT) -outdir ./
-all: $(LIBA) $(LIBSO) $(SWIGSO)
+all: $(LIBA) $(LIBSO)
+
+pywrap: $(SWIGSO)
$(LIBA): $(OBJS)
$(AR) rcs $@ $^