68c8d967fd
Change the AVC to only audit the permissions specified by the policy, excluding any permissions specified via dontaudit or not specified via auditallow. Fix compilation of label_file.c with latest glibc headers.
157 lines
4.8 KiB
Diff
157 lines
4.8 KiB
Diff
diff --exclude-from=exclude -N -u -r nsalibselinux/man/man8/selinuxconlist.8 libselinux-2.0.90/man/man8/selinuxconlist.8
|
|
--- nsalibselinux/man/man8/selinuxconlist.8 1969-12-31 19:00:00.000000000 -0500
|
|
+++ libselinux-2.0.90/man/man8/selinuxconlist.8 2010-01-18 16:52:28.000000000 -0500
|
|
@@ -0,0 +1,18 @@
|
|
+.TH "selinuxconlist" "1" "7 May 2008" "dwalsh@redhat.com" "SELinux Command Line documentation"
|
|
+.SH "NAME"
|
|
+selinuxconlist \- list all SELinux context reachable for user
|
|
+.SH "SYNOPSIS"
|
|
+.B selinuxconlist [-l level] user [context]
|
|
+
|
|
+.SH "DESCRIPTION"
|
|
+.B selinuxconlist
|
|
+reports the list of context reachable for user from the current context or specified context
|
|
+
|
|
+.B \-l level
|
|
+mcs/mls level
|
|
+
|
|
+.SH AUTHOR
|
|
+This manual page was written by Dan Walsh <dwalsh@redhat.com>.
|
|
+
|
|
+.SH "SEE ALSO"
|
|
+secon(8), selinuxdefcon(8)
|
|
diff --exclude-from=exclude -N -u -r nsalibselinux/man/man8/selinuxdefcon.8 libselinux-2.0.90/man/man8/selinuxdefcon.8
|
|
--- nsalibselinux/man/man8/selinuxdefcon.8 1969-12-31 19:00:00.000000000 -0500
|
|
+++ libselinux-2.0.90/man/man8/selinuxdefcon.8 2010-01-18 16:52:28.000000000 -0500
|
|
@@ -0,0 +1,24 @@
|
|
+.TH "selinuxdefcon" "1" "7 May 2008" "dwalsh@redhat.com" "SELinux Command Line documentation"
|
|
+.SH "NAME"
|
|
+selinuxdefcon \- report default SELinux context for user
|
|
+
|
|
+.SH "SYNOPSIS"
|
|
+.B selinuxdefcon [-l level] user fromcon
|
|
+
|
|
+.SH "DESCRIPTION"
|
|
+.B selinuxdefcon
|
|
+reports the default context for the specified user from the specified context
|
|
+
|
|
+.B \-l level
|
|
+mcs/mls level
|
|
+
|
|
+.SH EXAMPLE
|
|
+# selinuxdefcon jsmith system_u:system_r:sshd_t:s0
|
|
+.br
|
|
+unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023
|
|
+
|
|
+.SH AUTHOR
|
|
+This manual page was written by Dan Walsh <dwalsh@redhat.com>.
|
|
+
|
|
+.SH "SEE ALSO"
|
|
+secon(8), selinuxconlist(8)
|
|
diff --exclude-from=exclude -N -u -r nsalibselinux/src/callbacks.c libselinux-2.0.90/src/callbacks.c
|
|
--- nsalibselinux/src/callbacks.c 2009-04-08 09:06:23.000000000 -0400
|
|
+++ libselinux-2.0.90/src/callbacks.c 2010-01-18 16:52:28.000000000 -0500
|
|
@@ -16,6 +16,7 @@
|
|
{
|
|
int rc;
|
|
va_list ap;
|
|
+ if (is_selinux_enabled() == 0) return 0;
|
|
va_start(ap, fmt);
|
|
rc = vfprintf(stderr, fmt, ap);
|
|
va_end(ap);
|
|
diff --exclude-from=exclude -N -u -r nsalibselinux/src/init.c libselinux-2.0.90/src/init.c
|
|
--- nsalibselinux/src/init.c 2009-07-14 11:16:03.000000000 -0400
|
|
+++ libselinux-2.0.90/src/init.c 2010-02-22 11:04:16.000000000 -0500
|
|
@@ -23,7 +23,7 @@
|
|
static void init_selinuxmnt(void)
|
|
{
|
|
char *buf=NULL, *p;
|
|
- FILE *fp;
|
|
+ FILE *fp=NULL;
|
|
struct statfs sfbuf;
|
|
int rc;
|
|
size_t len;
|
|
@@ -57,16 +57,17 @@
|
|
break;
|
|
}
|
|
}
|
|
- fclose(fp);
|
|
|
|
- if (!exists)
|
|
- return;
|
|
+ if (!exists)
|
|
+ goto out;
|
|
+
|
|
+ fclose(fp);
|
|
|
|
/* At this point, the usual spot doesn't have an selinuxfs so
|
|
* we look around for it */
|
|
fp = fopen("/proc/mounts", "r");
|
|
if (!fp)
|
|
- return;
|
|
+ goto out;
|
|
|
|
__fsetlocking(fp, FSETLOCKING_BYCALLER);
|
|
while ((num = getline(&buf, &len, fp)) != -1) {
|
|
@@ -90,7 +91,8 @@
|
|
|
|
out:
|
|
free(buf);
|
|
- fclose(fp);
|
|
+ if (fp)
|
|
+ fclose(fp);
|
|
return;
|
|
}
|
|
|
|
diff --exclude-from=exclude -N -u -r nsalibselinux/src/libselinux.pc.in libselinux-2.0.90/src/libselinux.pc.in
|
|
--- nsalibselinux/src/libselinux.pc.in 2009-11-02 12:58:30.000000000 -0500
|
|
+++ libselinux-2.0.90/src/libselinux.pc.in 2010-02-18 10:02:46.000000000 -0500
|
|
@@ -1,6 +1,6 @@
|
|
prefix=@prefix@
|
|
exec_prefix=${prefix}
|
|
-libdir=${exec_prefix}/lib
|
|
+libdir=${exec_prefix}/@libdir@
|
|
includedir=@includedir@
|
|
|
|
Name: libselinux
|
|
diff --exclude-from=exclude -N -u -r nsalibselinux/src/Makefile libselinux-2.0.90/src/Makefile
|
|
--- nsalibselinux/src/Makefile 2009-12-01 15:46:50.000000000 -0500
|
|
+++ libselinux-2.0.90/src/Makefile 2010-02-18 10:20:27.000000000 -0500
|
|
@@ -11,6 +11,7 @@
|
|
RUBYPLATFORM ?= $(shell ruby -e 'print RUBY_PLATFORM')
|
|
RUBYINC ?= $(LIBDIR)/ruby/$(RUBYLIBVER)/$(RUBYPLATFORM)
|
|
RUBYINSTALL ?= $(LIBDIR)/ruby/site_ruby/$(RUBYLIBVER)/$(RUBYPLATFORM)
|
|
+LIBBASE=$(shell basename $(LIBDIR))
|
|
|
|
VERSION = $(shell cat ../VERSION)
|
|
LIBVERSION = 1
|
|
@@ -85,7 +86,7 @@
|
|
ln -sf $@ $(TARGET)
|
|
|
|
$(LIBPC): $(LIBPC).in
|
|
- sed -e 's/@VERSION@/$(VERSION)/; s:@prefix@:$(PREFIX):; s:@libdir@:$(LIBDIR):; s:@includedir@:$(INCLUDEDIR):' < $< > $@
|
|
+ sed -e 's/@VERSION@/$(VERSION)/; s:@prefix@:$(PREFIX):; s:@libdir@:$(LIBBASE):; s:@includedir@:$(INCLUDEDIR):' < $< > $@
|
|
|
|
selinuxswig_python_exception.i: ../include/selinux/selinux.h
|
|
bash exception.sh > $@
|
|
diff --exclude-from=exclude -N -u -r nsalibselinux/src/matchpathcon.c libselinux-2.0.90/src/matchpathcon.c
|
|
--- nsalibselinux/src/matchpathcon.c 2009-03-06 14:41:45.000000000 -0500
|
|
+++ libselinux-2.0.90/src/matchpathcon.c 2010-01-18 16:52:28.000000000 -0500
|
|
@@ -2,6 +2,7 @@
|
|
#include <string.h>
|
|
#include <errno.h>
|
|
#include <stdio.h>
|
|
+#include <syslog.h>
|
|
#include "selinux_internal.h"
|
|
#include "label_internal.h"
|
|
#include "callbacks.h"
|
|
@@ -57,7 +58,7 @@
|
|
{
|
|
va_list ap;
|
|
va_start(ap, fmt);
|
|
- vfprintf(stderr, fmt, ap);
|
|
+ vsyslog(LOG_ERR, fmt, ap);
|
|
va_end(ap);
|
|
}
|
|
|