- build with -mno-tls-direct-seg-refs on x86 to avoid triggering segfaults

with xen (#200783)
This commit is contained in:
Jeremy Katz 2006-08-01 18:26:09 +00:00
parent 6b84a37b8f
commit be0d45133a
2 changed files with 21 additions and 2 deletions

View File

@ -0,0 +1,14 @@
--- libselinux-1.30.19/src/Makefile.notls 2006-08-01 14:16:38.000000000 -0400
+++ libselinux-1.30.19/src/Makefile 2006-08-01 14:16:58.000000000 -0400
@@ -24,6 +24,11 @@
override CFLAGS += -I../include -I$(INCLUDEDIR) -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64
RANLIB=ranlib
+ARCH := $(patsubst i%86,i386,$(shell uname -m))
+ifneq (,$(filter i386,$(ARCH)))
+CFLAGS += -mno-tls-direct-seg-refs
+endif
+
SWIG = swig -Wall -python -o $(SWIGCOUT) -outdir ./
all: $(LIBA) $(LIBSO)

View File

@ -2,11 +2,11 @@
Summary: SELinux library and simple utilities
Name: libselinux
Version: 1.30.19
Release: 3
Release: 4
License: Public domain (uncopyrighted)
Group: System Environment/Libraries
Source: http://www.nsa.gov/selinux/archives/%{name}-%{version}.tgz
Patch0: libselinux-tlssegneg.patch
BuildRequires: libsepol-devel >= %{libsepolver} swig
Requires: libsepol >= %{libsepolver} setransd
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@ -47,6 +47,7 @@ needed for developing SELinux applications.
%prep
%setup -q
%patch0 -p1 -b .tlssegneg
%build
make clean
@ -116,6 +117,10 @@ exit 0
%{_libdir}/python*/site-packages/selinux.py*
%changelog
* Tue Aug 1 2006 Jeremy Katz <katzj@redhat.com> - 1.30.19-4
- build with -mno-tls-direct-seg-refs on x86 to avoid triggering
segfaults with xen (#200783)
* Mon Jul 17 2006 Dan Walsh <dwalsh@redhat.com> 1.30.19-3
- Rebuild for new gcc