- Upgrade to upstream

Make netlink socket close-on-exec to avoid descriptor leakage from Dan
    Walsh.
Pass CFLAGS when using gcc for linking from Dennis Gilmore.
This commit is contained in:
Daniel J Walsh 2007-09-27 14:54:10 +00:00
parent ae054c560b
commit 7cbfb0e27a
4 changed files with 8 additions and 32 deletions

View File

@ -129,3 +129,4 @@ libselinux-2.0.30.tgz
libselinux-2.0.31.tgz
libselinux-2.0.33.tgz
libselinux-2.0.34.tgz
libselinux-2.0.35.tgz

View File

@ -1,32 +1,3 @@
diff --exclude-from=exclude -N -u -r nsalibselinux/src/avc_internal.c libselinux-2.0.34/src/avc_internal.c
--- nsalibselinux/src/avc_internal.c 2007-07-16 14:20:46.000000000 -0400
+++ libselinux-2.0.34/src/avc_internal.c 2007-09-24 11:37:47.000000000 -0400
@@ -61,7 +61,8 @@
rc = fd;
goto out;
}
-
+
+ fcntl(fd, F_SETFD, FD_CLOEXEC);
if (!blocking && fcntl(fd, F_SETFL, O_NONBLOCK)) {
close(fd);
rc = -1;
diff --exclude-from=exclude -N -u -r nsalibselinux/src/Makefile libselinux-2.0.34/src/Makefile
--- nsalibselinux/src/Makefile 2007-08-03 16:02:56.000000000 -0400
+++ libselinux-2.0.34/src/Makefile 2007-09-24 11:51:42.000000000 -0400
@@ -57,10 +57,10 @@
$(CC) $(CFLAGS) -I$(PYINC) -fPIC -DSHARED -c -o $@ $<
$(SWIGSO): $(SWIGLOBJ)
- $(CC) $(LDFLAGS) -shared -o $@ $< -L. -lselinux -L$(LIBDIR) -Wl,-soname,$@
+ $(CC) $(CFLAGS) $(LDFLAGS) -shared -o $@ $< -L. -lselinux -L$(LIBDIR) -Wl,-soname,$@
$(LIBSO): $(LOBJS)
- $(CC) $(LDFLAGS) -shared -o $@ $^ -ldl -L$(LIBDIR) -Wl,-soname,$(LIBSO),-z,defs,-z,relro
+ $(CC) $(CFLAGS) $(LDFLAGS) -shared -o $@ $^ -ldl -L$(LIBDIR) -Wl,-soname,$(LIBSO),-z,defs,-z,relro
ln -sf $@ $(TARGET)
%.o: %.c policy.h
diff --exclude-from=exclude -N -u -r nsalibselinux/src/matchpathcon.c libselinux-2.0.34/src/matchpathcon.c
--- nsalibselinux/src/matchpathcon.c 2007-09-18 16:27:25.000000000 -0400
+++ libselinux-2.0.34/src/matchpathcon.c 2007-09-18 16:32:31.000000000 -0400

View File

@ -1,8 +1,8 @@
%define libsepolver 2.0.10-1
Summary: SELinux library and simple utilities
Name: libselinux
Version: 2.0.34
Release: 3%{?dist}
Version: 2.0.35
Release: 1%{?dist}
License: Public domain (uncopyrighted)
Group: System Environment/Libraries
Source: http://www.nsa.gov/selinux/archives/%{name}-%{version}.tgz
@ -123,6 +123,10 @@ exit 0
%{_libdir}/python*/site-packages/selinux.py*
%changelog
* Wed Sep 26 2007 Dan Walsh <dwalsh@redhat.com> - 2.0.35-1
- Upgrade to upstream
* Make netlink socket close-on-exec to avoid descriptor leakage from Dan Walsh.
* Pass CFLAGS when using gcc for linking from Dennis Gilmore.
* Mon Sep 24 2007 Dan Walsh <dwalsh@redhat.com> - 2.0.34-3
- Add sparc patch to from Dennis Gilmore to build on Sparc platform

View File

@ -1 +1 @@
e6f14fafbeab0fb9c9662d79eca4ac1e libselinux-2.0.34.tgz
3238a38e2e43c39081d13a579744fbdb libselinux-2.0.35.tgz