fix librx to use libtool modes

This commit is contained in:
Tom Callaway 2009-02-16 16:41:56 +00:00
parent 1bb13ceeae
commit 3c64d6f4d5
2 changed files with 34 additions and 1 deletions

View File

@ -1,7 +1,7 @@
Summary: POSIX regexp functions
Name: librx
Version: 1.5
Release: 10%{?dist}
Release: 11%{?dist}
License: GPLv2+
URL: http://www.gnu.org/software/rx/rx.html
Group: Applications/Text
@ -9,6 +9,7 @@ Source0: ftp://ftp.gnu.org/gnu/rx/rx-%{version}.tar.bz2
Patch0: rx-1.5-shared.patch
Patch1: rx-1.5-texinfo.patch
Patch2: librx-1.5-libdir64.patch
Patch3: rx-1.5-libtoolmode.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: texinfo, libtool
@ -38,6 +39,7 @@ This package contains files needed for development with librx.
%ifarch x86_64 ppc64 sparc64
%patch2 -p1 -b .64bit
%endif
%patch3 -p1 -b .libtoolmode
%build
%configure
@ -84,6 +86,9 @@ fi
%{_libdir}/*.a
%changelog
* Mon Feb 16 2009 Tom "spot" Callaway <tcallawa@redhat.com> 1.5-11
- pass modes to libtool
* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.5-10
- Autorebuild for GCC 4.3

28
rx-1.5-libtoolmode.patch Normal file
View File

@ -0,0 +1,28 @@
diff -up rx-1.5/rx/Makefile.in.BAD rx-1.5/rx/Makefile.in
--- rx-1.5/rx/Makefile.in.BAD 2009-02-16 11:36:15.000000000 -0500
+++ rx-1.5/rx/Makefile.in 2009-02-16 11:36:39.000000000 -0500
@@ -67,13 +67,13 @@ gen_c_files=rgx.x
$(CC) -c $(ALL_CFLAGS) $(DEFS) -I$(srcdir) $<
.c.lo:
- $(LIBTOOL) $(CC) -c $(ALL_CFLAGS) $(DEFS) -I$(srcdir) $< -o $@
+ $(LIBTOOL) --mode=compile $(CC) -c $(ALL_CFLAGS) $(DEFS) -I$(srcdir) $< -o $@
all: librx.la
install: all
$(INSTALL) $(srcdir)/inst-rxposix.h $(DESTDIR)$(includedir)/rxposix.h
- $(LIBTOOL) $(INSTALL) -c librx.la $(DESTDIR)$(libdir)
+ $(LIBTOOL) --mode=install $(INSTALL) -c librx.la $(DESTDIR)$(libdir)
uninstall:
@@ -127,7 +127,7 @@ librx.a: $(libobjs) $(opt_objs)
$(RANLIB) librx.a
librx.la: $(liblobjs) $(opt_objs)
- $(LIBTOOL) $(CC) $(ALL_CFLAGS) $(DEFS) -I$(srcdir) -o $@ $(liblobjs) -rpath $(libdir)
+ $(LIBTOOL) --mode=link $(CC) $(ALL_CFLAGS) $(DEFS) -I$(srcdir) -o $@ $(liblobjs) -rpath $(libdir)
depends: