Resolves: rhbz#751290 - [kde] LibreOffice has black on dark-grey tooltip-texts
This commit is contained in:
parent
0aaa426025
commit
eed39e3747
60
0001-Resolves-rhbz-751290-KDE-black-on-dark-tooltips.patch
Normal file
60
0001-Resolves-rhbz-751290-KDE-black-on-dark-tooltips.patch
Normal file
@ -0,0 +1,60 @@
|
||||
From 7cd58dbe32e5421986216dd7c6b24a4bb0b9c1e5 Mon Sep 17 00:00:00 2001
|
||||
From: Luboš Luňák <l.lunak@suse.cz>
|
||||
Date: Tue, 18 Oct 2011 14:52:47 +0000
|
||||
Subject: style tooltips properly with KDE4 vclplug (fdo#40461)
|
||||
|
||||
---
|
||||
(limited to 'vcl/unx/kde4')
|
||||
|
||||
diff --git a/vcl/unx/kde4/KDESalFrame.cxx b/vcl/unx/kde4/KDESalFrame.cxx
|
||||
index 10e7350..4dd54e5 100644
|
||||
--- a/vcl/unx/kde4/KDESalFrame.cxx
|
||||
+++ b/vcl/unx/kde4/KDESalFrame.cxx
|
||||
@@ -38,6 +38,8 @@
|
||||
#include <kmainwindow.h>
|
||||
#include <kapplication.h>
|
||||
#include <ktoolbar.h>
|
||||
+#include <qdebug.h>
|
||||
+#include <qtooltip.h>
|
||||
|
||||
#undef Region
|
||||
|
||||
@@ -239,11 +241,9 @@ void KDESalFrame::UpdateSettings( AllSettings& rSettings )
|
||||
style.SetFieldTextColor( aText );
|
||||
style.SetFieldRolloverTextColor( aText );
|
||||
style.SetWindowTextColor( aText );
|
||||
- style.SetHelpTextColor( aText );
|
||||
|
||||
// Base
|
||||
style.SetFieldColor( aBase );
|
||||
- style.SetHelpColor( aBase );
|
||||
style.SetWindowColor( aBase );
|
||||
style.SetActiveTabColor( aBase );
|
||||
|
||||
@@ -268,11 +268,14 @@ void KDESalFrame::UpdateSettings( AllSettings& rSettings )
|
||||
style.SetHighlightColor( aHigh );
|
||||
style.SetHighlightTextColor( toColor(pal.color( QPalette::HighlightedText)) );
|
||||
|
||||
+ // Tooltip
|
||||
+ style.SetHelpColor( toColor( QToolTip::palette().color( QPalette::Active, QPalette::ToolTipBase )));
|
||||
+ style.SetHelpTextColor( toColor( QToolTip::palette().color( QPalette::Active, QPalette::ToolTipText )));
|
||||
+
|
||||
// Font
|
||||
Font aFont = toFont( kapp->font(), rSettings.GetUILocale() );
|
||||
|
||||
style.SetAppFont( aFont );
|
||||
- style.SetHelpFont( aFont );
|
||||
|
||||
style.SetMenuFont( aFont ); // will be changed according to pMenuBar
|
||||
//style.SetToolFont( aFont ); //already set above
|
||||
@@ -291,6 +294,8 @@ void KDESalFrame::UpdateSettings( AllSettings& rSettings )
|
||||
}
|
||||
style.SetFloatTitleFont( aFont );
|
||||
|
||||
+ style.SetHelpFont( toFont( QToolTip::font(), rSettings.GetUILocale()));
|
||||
+
|
||||
int flash_time = QApplication::cursorFlashTime();
|
||||
style.SetCursorBlinkTime( flash_time != 0 ? flash_time/2 : STYLE_CURSOR_NOBLINKTIME );
|
||||
|
||||
--
|
||||
cgit v0.9.0.2-2-gbebe
|
@ -27,7 +27,7 @@ Summary: Free Software Productivity Suite
|
||||
Name: libreoffice
|
||||
Epoch: 1
|
||||
Version: 3.4.4.2
|
||||
Release: 3%{?dist}
|
||||
Release: 4%{?dist}
|
||||
License: LGPLv3 and LGPLv2+ and BSD and (MPLv1.1 or GPLv2 or LGPLv2 or Netscape) and (CDDL or GPLv2) and Public Domain
|
||||
Group: Applications/Productivity
|
||||
URL: http://www.documentfoundation.org/develop
|
||||
@ -144,6 +144,7 @@ Patch38: 0001-fix-horizontal-scrollbars-with-KDE-oxygen-style-bnc-.patch
|
||||
Patch39: 0001-Related-rhbz-753201-fedora-ant-java-1.5.0-gcj-won-t-.patch
|
||||
Patch40: solenv.fix.mk.inheritance.patch
|
||||
Patch41: libreoffice-ppc64.patch
|
||||
Patch42: 0001-Resolves-rhbz-751290-KDE-black-on-dark-tooltips.patch
|
||||
|
||||
%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}
|
||||
%define instdir %{_libdir}
|
||||
@ -831,6 +832,7 @@ mv -f redhat.soc extras/source/palettes/standard.soc
|
||||
%patch39 -p1 -b .rhbz753201-fedora-ant-java-1.5.0-gcj-won-t-.patch
|
||||
%patch40 -p1 -b .solenv.fix.mk.inheritance.patch
|
||||
%patch41 -p1 -b .libreoffice-ppc64.patch
|
||||
%patch42 -p1 -b .rhbz751290-KDE-black-on-dark-tooltips.patch
|
||||
|
||||
# these are horribly incomplete--empty translations and copied english
|
||||
# strings with spattering of translated strings
|
||||
@ -2133,6 +2135,9 @@ update-desktop-database %{_datadir}/applications &> /dev/null || :
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Tue Nov 22 2011 Lukas Tinkl <ltinkl@redhat.com> - 3.4.4.2-4
|
||||
- Resolves: rhbz#751290 - [kde] LibreOffice has black on dark-grey tooltip-texts
|
||||
|
||||
* Fri Nov 11 2011 Caolán McNamara <caolanm@redhat.com> - 3.4.4.2-3
|
||||
- Related: fdo#42534 0001-Related-i58612-don-t-crash-anyway.patch
|
||||
- Resolves: fdo#42749 KDE oxygen theme and scrollbars
|
||||
|
Loading…
x
Reference in New Issue
Block a user