Related: rhbz#1119709 disable libe-book on rhel
This commit is contained in:
parent
e4df9b8ee2
commit
d0c0791b60
73
0001-disable-libe-book-support.patch
Normal file
73
0001-disable-libe-book-support.patch
Normal file
@ -0,0 +1,73 @@
|
||||
From d662ad12358a00f8db0d07b2741926a2ed7d7f4d Mon Sep 17 00:00:00 2001
|
||||
From: David Tardon <dtardon@redhat.com>
|
||||
Date: Thu, 21 Aug 2014 14:49:53 +0200
|
||||
Subject: [PATCH] disable libe-book support
|
||||
|
||||
Change-Id: I7aab13e9aac90f678231c0176d0d96aa09bea813
|
||||
---
|
||||
configure.ac | 5 -----
|
||||
writerperfect/Library_wpftwriter.mk | 2 --
|
||||
writerperfect/source/writer/wpftwriter_genericfilter.cxx | 4 ----
|
||||
3 files changed, 11 deletions(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 2560a0d..e46f407 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -7724,11 +7724,6 @@ fi
|
||||
AC_SUBST([ENABLE_EOT])
|
||||
|
||||
dnl ===================================================================
|
||||
-dnl Check for system libe-book
|
||||
-dnl ===================================================================
|
||||
-libo_CHECK_SYSTEM_MODULE([libebook],[EBOOK],[libe-book-0.0 >= 0.0.2],["-I${WORKDIR}/UnpackedTarball/libebook/inc"],["-L${WORKDIR}/UnpackedTarball/libebook/src/lib/.libs -le-book-0.0"])
|
||||
-
|
||||
-dnl ===================================================================
|
||||
dnl Check for system libetonyek
|
||||
dnl ===================================================================
|
||||
libo_CHECK_SYSTEM_MODULE([libetonyek],[ETONYEK],[libetonyek-0.0],["-I${WORKDIR}/UnpackedTarball/libetonyek/inc"],["-L${WORKDIR}/UnpackedTarball/libetonyek/src/lib/.libs -letonyek-0.0"])
|
||||
diff --git a/writerperfect/Library_wpftwriter.mk b/writerperfect/Library_wpftwriter.mk
|
||||
index cfcdf5d..67207cf 100644
|
||||
--- a/writerperfect/Library_wpftwriter.mk
|
||||
+++ b/writerperfect/Library_wpftwriter.mk
|
||||
@@ -50,7 +50,6 @@ $(eval $(call gb_Library_use_static_libraries,wpftwriter,\
|
||||
$(eval $(call gb_Library_use_externals,wpftwriter,\
|
||||
abw \
|
||||
boost_headers \
|
||||
- ebook \
|
||||
etonyek \
|
||||
icui18n \
|
||||
icudata \
|
||||
@@ -66,7 +65,6 @@ $(eval $(call gb_Library_use_externals,wpftwriter,\
|
||||
|
||||
$(eval $(call gb_Library_add_exception_objects,wpftwriter,\
|
||||
writerperfect/source/writer/AbiWordImportFilter \
|
||||
- writerperfect/source/writer/EBookImportFilter \
|
||||
writerperfect/source/writer/MSWorksImportFilter \
|
||||
writerperfect/source/writer/MWAWImportFilter \
|
||||
writerperfect/source/writer/WordPerfectImportFilter \
|
||||
diff --git a/writerperfect/source/writer/wpftwriter_genericfilter.cxx b/writerperfect/source/writer/wpftwriter_genericfilter.cxx
|
||||
index 05f6542..831bc38 100644
|
||||
--- a/writerperfect/source/writer/wpftwriter_genericfilter.cxx
|
||||
+++ b/writerperfect/source/writer/wpftwriter_genericfilter.cxx
|
||||
@@ -32,7 +32,6 @@
|
||||
#include "sal/types.h"
|
||||
|
||||
#include "AbiWordImportFilter.hxx"
|
||||
-#include "EBookImportFilter.hxx"
|
||||
#include "WordPerfectImportFilter.hxx"
|
||||
#include "MSWorksImportFilter.hxx"
|
||||
#include "MWAWImportFilter.hxx"
|
||||
@@ -52,9 +51,6 @@ static cppu::ImplementationEntry const services[] = {
|
||||
{ &MWAWImportFilter_createInstance, &MWAWImportFilter_getImplementationName,
|
||||
&MWAWImportFilter_getSupportedServiceNames,
|
||||
&cppu::createSingleComponentFactory, 0, 0 },
|
||||
- { &EBookImportFilter_createInstance, &EBookImportFilter_getImplementationName,
|
||||
- &EBookImportFilter_getSupportedServiceNames,
|
||||
- &cppu::createSingleComponentFactory, 0, 0 },
|
||||
{ 0, 0, 0, 0, 0, 0 } };
|
||||
|
||||
}
|
||||
--
|
||||
1.9.3
|
||||
|
@ -99,12 +99,11 @@ Source32: %{external_url}/libodfgen-0.1.1.tar.bz2
|
||||
Source33: %{external_url}/libmwaw-0.3.1.tar.bz2
|
||||
Source34: %{external_url}/libetonyek-0.1.1.tar.bz2
|
||||
Source35: %{external_url}/libfreehand-0.1.0.tar.bz2
|
||||
Source36: %{external_url}/libe-book-0.1.1.tar.bz2
|
||||
Source37: %{external_url}/libabw-0.1.0.tar.bz2
|
||||
Source38: %{external_url}/libatomic_ops-7_2d.zip
|
||||
Source39: %{external_url}/language-subtag-registry-2014-04-10.tar.bz2
|
||||
Source40: %{external_url}/librevenge-0.0.1.tar.bz2
|
||||
%global bundling_options %{?bundling_options} --without-system-libcdr --without-system-libwpg --without-system-libwpd --without-system-libwps --without-system-libvisio --without-system-libmspub --without-system-libcmis --without-system-libodfgen --without-system-libmwaw --without-system-libetonyek --without-system-libfreehand --without-system-libebook --without-system-libabw --without-system-libatomic_ops --without-system-librevenge
|
||||
Source36: %{external_url}/libabw-0.1.0.tar.bz2
|
||||
Source37: %{external_url}/libatomic_ops-7_2d.zip
|
||||
Source38: %{external_url}/language-subtag-registry-2014-04-10.tar.bz2
|
||||
Source39: %{external_url}/librevenge-0.0.1.tar.bz2
|
||||
%global bundling_options %{?bundling_options} --without-system-libcdr --without-system-libwpg --without-system-libwpd --without-system-libwps --without-system-libvisio --without-system-libmspub --without-system-libcmis --without-system-libodfgen --without-system-libmwaw --without-system-libetonyek --without-system-libfreehand --without-system-libabw --without-system-libatomic_ops --without-system-librevenge
|
||||
%endif
|
||||
|
||||
# build tools
|
||||
@ -289,23 +288,25 @@ Patch8: 0001-disable-failing-test-on-rhel-6.patch
|
||||
# not upstreamed
|
||||
# TODO: fails on ppc; investigate
|
||||
Patch9: 0001-disable-swui-test-on-RHEL-7.patch
|
||||
# not upstreamed
|
||||
Patch10: 0001-disable-libe-book-support.patch
|
||||
%endif
|
||||
# not upstreamed
|
||||
Patch10: 0001-Resolves-rhbz-1035092-no-shortcut-key-for-Italian-To.patch
|
||||
Patch11: 0001-Resolves-rhbz-1035092-no-shortcut-key-for-Italian-To.patch
|
||||
# not upstreamed
|
||||
Patch11: 0001-disable-firebird-unit-test.patch
|
||||
Patch12: 0001-disable-firebird-unit-test.patch
|
||||
# not upstreamed
|
||||
Patch12: 0001-never-run-autogen.sh.patch
|
||||
Patch13: 0001-never-run-autogen.sh.patch
|
||||
# not upstreamed
|
||||
Patch13: 0001-add-X-TryExec-entries-to-desktop-files.patch
|
||||
Patch14: 0001-add-X-TryExec-entries-to-desktop-files.patch
|
||||
# not upstreamed
|
||||
Patch14: 0001-disable-PSD-import-test-which-deadlocks-on-ARM.patch
|
||||
Patch15: 0001-rhbz-1111216-allow-to-export-an-empty-sheet-to-PDF.patch
|
||||
Patch16: 0001-avoid-problems-detecting-HTML-files-with-.xls-ext.patch
|
||||
Patch17: 0001-scrolling-very-slow-in-calc.patch
|
||||
Patch18: 0001-Related-rhbz-1117853-nStartPara-of-EE_PARA_NOT_FOUND.patch
|
||||
Patch19: 0001-Resolves-fdo-81487-pasting-into-outline-view-crashes.patch
|
||||
Patch20: 0001-Related-rhbz-1130264-plausible-fix-for-reported-cras.patch
|
||||
Patch15: 0001-disable-PSD-import-test-which-deadlocks-on-ARM.patch
|
||||
Patch16: 0001-rhbz-1111216-allow-to-export-an-empty-sheet-to-PDF.patch
|
||||
Patch17: 0001-avoid-problems-detecting-HTML-files-with-.xls-ext.patch
|
||||
Patch18: 0001-scrolling-very-slow-in-calc.patch
|
||||
Patch19: 0001-Related-rhbz-1117853-nStartPara-of-EE_PARA_NOT_FOUND.patch
|
||||
Patch20: 0001-Resolves-fdo-81487-pasting-into-outline-view-crashes.patch
|
||||
Patch21: 0001-Related-rhbz-1130264-plausible-fix-for-reported-cras.patch
|
||||
|
||||
%define instdir %{_libdir}
|
||||
%define baseinstdir %{instdir}/libreoffice
|
||||
|
Loading…
Reference in New Issue
Block a user