fix build on rhel-7
This commit is contained in:
parent
d559f87e22
commit
bb8afecb00
2
.gitignore
vendored
2
.gitignore
vendored
@ -13,7 +13,7 @@
|
||||
/libassuan-2.4.3.tar.bz2
|
||||
/libcmis-0.5.1.tar.gz
|
||||
/libepubgen-0.0.1.tar.bz2
|
||||
/libgpg-error-1.26.tar.bz2
|
||||
/libgpg-error-1.27.tar.bz2
|
||||
/liborcus-0.12.1.tar.gz
|
||||
/libqxp-0.0.0.tar.xz
|
||||
/libpagemaker-0.0.3.tar.bz2
|
||||
|
26
0001-fix-build-of-bundled-libepubgen-on-ppc64le.patch
Normal file
26
0001-fix-build-of-bundled-libepubgen-on-ppc64le.patch
Normal file
@ -0,0 +1,26 @@
|
||||
From d6765e376706680156e71e985eeeb58bf469f849 Mon Sep 17 00:00:00 2001
|
||||
From: David Tardon <dtardon@redhat.com>
|
||||
Date: Sun, 5 Nov 2017 15:05:43 +0100
|
||||
Subject: [PATCH] fix build of bundled libepubgen on ppc64le
|
||||
|
||||
Change-Id: I559058ffe2192764a27d278eea0e4d4676bbd64d
|
||||
---
|
||||
external/libepubgen/UnpackedTarball_libepubgen.mk | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/external/libepubgen/UnpackedTarball_libepubgen.mk b/external/libepubgen/UnpackedTarball_libepubgen.mk
|
||||
index 28582a5cf0f3..312facb2bb11 100644
|
||||
--- a/external/libepubgen/UnpackedTarball_libepubgen.mk
|
||||
+++ b/external/libepubgen/UnpackedTarball_libepubgen.mk
|
||||
@@ -32,6 +32,8 @@ $(eval $(call gb_UnpackedTarball_UnpackedTarball,libepubgen))
|
||||
|
||||
$(eval $(call gb_UnpackedTarball_set_tarball,libepubgen,$(EPUBGEN_TARBALL)))
|
||||
|
||||
+$(eval $(call gb_UnpackedTarball_update_autoconf_configs,libepubgen))
|
||||
+
|
||||
$(eval $(call gb_UnpackedTarball_set_patchlevel,libepubgen,0))
|
||||
|
||||
$(eval $(call gb_UnpackedTarball_add_patches,libepubgen,\
|
||||
--
|
||||
2.14.1
|
||||
|
26
0001-fix-build-with-older-boost.patch
Normal file
26
0001-fix-build-with-older-boost.patch
Normal file
@ -0,0 +1,26 @@
|
||||
From 4f2308bb6e5c26e304bb9372b3e5971e8ce24df1 Mon Sep 17 00:00:00 2001
|
||||
From: David Tardon <dtardon@redhat.com>
|
||||
Date: Sat, 4 Nov 2017 19:55:21 +0100
|
||||
Subject: [PATCH] fix build with older boost
|
||||
|
||||
Change-Id: Ie3f7a32bf8d5c9c118d35272c8e197b9c6ffcd80
|
||||
---
|
||||
include/connectivity/sqlerror.hxx | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/include/connectivity/sqlerror.hxx b/include/connectivity/sqlerror.hxx
|
||||
index 026d6d84bbae..b1084959a94b 100644
|
||||
--- a/include/connectivity/sqlerror.hxx
|
||||
+++ b/include/connectivity/sqlerror.hxx
|
||||
@@ -71,7 +71,7 @@ namespace connectivity
|
||||
public:
|
||||
ParamValue( ) : base_type( ) { }
|
||||
ParamValue( OUString const& val ) : base_type( val ) { }
|
||||
- ParamValue( ParamValue const& rhs ) : base_type( rhs ) { }
|
||||
+ ParamValue( ParamValue const& rhs ) : base_type( static_cast<base_type const&>( rhs ) ) { }
|
||||
|
||||
bool is() const { return !base_type::operator!(); }
|
||||
};
|
||||
--
|
||||
2.14.1
|
||||
|
40
0001-one-slash-is-enough.patch
Normal file
40
0001-one-slash-is-enough.patch
Normal file
@ -0,0 +1,40 @@
|
||||
From 1bacce999d7dad91b1f87baaf09b08e6b4629fad Mon Sep 17 00:00:00 2001
|
||||
From: David Tardon <dtardon@redhat.com>
|
||||
Date: Sun, 5 Nov 2017 20:41:03 +0100
|
||||
Subject: [PATCH] one slash is enough
|
||||
|
||||
Change-Id: I35fbca7592f3e17a071df567f691c62fe9232fc1
|
||||
---
|
||||
sc/source/ui/vba/vbafiledialogitems.hxx | 2 +-
|
||||
ucbhelper/source/provider/contentinfo.cxx | 2 +-
|
||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/sc/source/ui/vba/vbafiledialogitems.hxx b/sc/source/ui/vba/vbafiledialogitems.hxx
|
||||
index c78d8d1ffe83..47ba90ac4440 100644
|
||||
--- a/sc/source/ui/vba/vbafiledialogitems.hxx
|
||||
+++ b/sc/source/ui/vba/vbafiledialogitems.hxx
|
||||
@@ -9,7 +9,7 @@
|
||||
#ifndef INCLUDED_SC_SOURCE_UI_VBA_VBAFILEDIALOGSELECTEDITEMS
|
||||
#define INCLUDED_SC_SOURCE_UI_VBA_VBAFILEDIALOGSELECTEDITEMS
|
||||
|
||||
-#include <ooo/vba//excel/XFileDialogSelectedItems.hpp>
|
||||
+#include <ooo/vba/excel/XFileDialogSelectedItems.hpp>
|
||||
#include <vbahelper/vbahelperinterface.hxx>
|
||||
#include <vbahelper/vbacollectionimpl.hxx>
|
||||
#include <com/sun/star/container/XIndexAccess.hpp>
|
||||
diff --git a/ucbhelper/source/provider/contentinfo.cxx b/ucbhelper/source/provider/contentinfo.cxx
|
||||
index cd8ba829d209..d2cfa62f43eb 100644
|
||||
--- a/ucbhelper/source/provider/contentinfo.cxx
|
||||
+++ b/ucbhelper/source/provider/contentinfo.cxx
|
||||
@@ -23,7 +23,7 @@
|
||||
|
||||
*************************************************************************/
|
||||
#include <com/sun/star/beans/PropertyValue.hpp>
|
||||
-#include <com/sun/star//ucb/UnsupportedCommandException.hpp>
|
||||
+#include <com/sun/star/ucb/UnsupportedCommandException.hpp>
|
||||
#include <com/sun/star/ucb/XPropertySetRegistry.hpp>
|
||||
|
||||
#include "osl/mutex.hxx"
|
||||
--
|
||||
2.14.1
|
||||
|
@ -110,7 +110,7 @@ Source107: %{external_url}/libstaroffice-0.0.4.tar.xz
|
||||
Source108: %{external_url}/harfbuzz-1.4.8.tar.bz2
|
||||
Source109: %{external_url}/graphite2-minimal-1.3.10.tgz
|
||||
Source110: %{external_url}/gpgme-1.9.0.tar.bz2
|
||||
Source111: %{external_url}/libgpg-error-1.26.tar.bz2
|
||||
Source111: %{external_url}/libgpg-error-1.27.tar.bz2
|
||||
Source112: %{external_url}/libassuan-2.4.3.tar.bz2
|
||||
Source113: %{external_url}/cppunit-1.14.0.tar.gz
|
||||
Source114: %{external_url}/libqxp-0.0.0.tar.xz
|
||||
@ -123,7 +123,7 @@ Provides: bundled(harfbuzz) = 1.4.8
|
||||
Provides: bundled(libassuan) = 2.4.3
|
||||
Provides: bundled(libcmis) = 0.5.1
|
||||
Provides: bundled(libepubgen) = 0.0.1
|
||||
Provides: bundled(libgpg-error) = 1.26
|
||||
Provides: bundled(libgpg-error) = 1.27
|
||||
Provides: bundled(liborcus) = 0.12.1
|
||||
Provides: bundled(libpagemaker) = 0.0.3
|
||||
Provides: bundled(libqxp) = 0.0.0
|
||||
@ -282,6 +282,9 @@ Patch8: 0001-Make-testUtf8StringLiterals-work-when-char-is-unsign.patch
|
||||
%if 0%{?rhel}
|
||||
# not upstreamed
|
||||
Patch500: 0001-disable-libe-book-support.patch
|
||||
Patch501: 0001-fix-build-with-older-boost.patch
|
||||
Patch502: 0001-fix-build-of-bundled-libepubgen-on-ppc64le.patch
|
||||
Patch503: 0001-one-slash-is-enough.patch
|
||||
%endif
|
||||
|
||||
%global instdir %{_libdir}
|
||||
@ -1035,6 +1038,10 @@ sed -i -e /CppunitTest_dbaccess_hsqldb_test/d dbaccess/Module_dbaccess.mk # i686
|
||||
sed -i -e s/CppunitTest_dbaccess_RowSetClones// dbaccess/Module_dbaccess.mk # i686
|
||||
sed -i -e /CppunitTest_services/d postprocess/Module_postprocess.mk # i686
|
||||
sed -i -e /CppunitTest_sd_export_ooxml2/d sd/Module_sd.mk # i686
|
||||
%if 0%{?rhel}
|
||||
sed -i -e /CppunitTest_desktop_lib/d desktop/Module_desktop.mk
|
||||
sed -i -e /CppunitTest_writerperfect_draw/d writerperfect/Module_writerperfect.mk
|
||||
%endif
|
||||
git commit -q -a -m 'temporarily disable failing tests'
|
||||
|
||||
# Seeing .git dir makes some of the build tools change their behavior.
|
||||
|
Loading…
Reference in New Issue
Block a user