use git to manage patches
This commit is contained in:
parent
632edf3d43
commit
a85919d8b3
@ -1,10 +1,24 @@
|
||||
--- a/solenv/bin/modules/installer/worker.pm 2010-11-20 13:36:38.000000000 +0000
|
||||
+++ b/solenv/bin/modules/installer/worker.pm 2010-11-20 13:36:42.000000000 +0000
|
||||
@@ -204,7 +204,6 @@
|
||||
From 2ed57bc3ba020ebc6aec933445ae0b274685499e Mon Sep 17 00:00:00 2001
|
||||
From: David Tardon <dtardon@redhat.com>
|
||||
Date: Mon, 3 Feb 2014 21:41:00 +0100
|
||||
Subject: [PATCH] installation fix
|
||||
|
||||
---
|
||||
solenv/bin/modules/installer/worker.pm | 1 -
|
||||
1 file changed, 1 deletion(-)
|
||||
|
||||
diff --git a/solenv/bin/modules/installer/worker.pm b/solenv/bin/modules/installer/worker.pm
|
||||
index aab676f..0e6f67d 100644
|
||||
--- a/solenv/bin/modules/installer/worker.pm
|
||||
+++ b/solenv/bin/modules/installer/worker.pm
|
||||
@@ -96,7 +96,6 @@ sub create_installation_directory
|
||||
|
||||
$installdir = installer::systemactions::create_directories("install", $languageref);
|
||||
installer::logger::print_message( "... creating installation set in $installdir ...\n" );
|
||||
- remove_old_installation_sets($installdir);
|
||||
my $inprogressinstalldir = $installdir . "_inprogress";
|
||||
installer::systemactions::rename_directory($installdir, $inprogressinstalldir);
|
||||
$installdir = $inprogressinstalldir;
|
||||
$installdir = installer::systemactions::create_directories("install", $languageref);
|
||||
installer::logger::print_message( "... creating installation set in $installdir ...\n" );
|
||||
- remove_old_installation_sets($installdir);
|
||||
my $inprogressinstalldir = $installdir . "_inprogress";
|
||||
installer::systemactions::rename_directory($installdir, $inprogressinstalldir);
|
||||
$installdir = $inprogressinstalldir;
|
||||
--
|
||||
1.8.4.2
|
||||
|
||||
|
@ -112,6 +112,7 @@ BuildRequires: doxygen
|
||||
BuildRequires: findutils
|
||||
BuildRequires: flex
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: git
|
||||
BuildRequires: gperf
|
||||
BuildRequires: icu
|
||||
BuildRequires: make
|
||||
@ -1027,6 +1028,13 @@ done \
|
||||
%prep
|
||||
%setup -q -n %{name}-%{version}%{?libo_prerelease} -b 1 -b 2
|
||||
rm -rf git-hooks */git-hooks
|
||||
|
||||
# set up git repo
|
||||
git init
|
||||
git config gc.auto 0 # disable auto packing
|
||||
git add -A
|
||||
git commit -q -a -m %{name}-%{version}
|
||||
|
||||
#Customize Palette to remove Sun colours and add Red Hat colours
|
||||
(head -n -1 extras/source/palettes/standard.soc && \
|
||||
echo -e ' <draw:color draw:name="Red Hat 1" draw:color="#cc0000"/>
|
||||
@ -1036,27 +1044,14 @@ rm -rf git-hooks */git-hooks
|
||||
<draw:color draw:name="Red Hat 5" draw:color="#4e376b"/>' && \
|
||||
tail -n 1 extras/source/palettes/standard.soc) > redhat.soc
|
||||
mv -f redhat.soc extras/source/palettes/standard.soc
|
||||
%patch1 -p1
|
||||
%patch2 -p1 -b .ooo86080.unopkg.bodge.patch
|
||||
%patch3 -p1 -b .ooo88341.sc.verticalboxes.patch
|
||||
%patch4 -p1 -b .oooXXXXX.solenv.allowmissing.patch
|
||||
%patch5 -p1 -b .ooo101274.opening-a-directory.patch
|
||||
%patch6 -p1 -b .libreoffice-installfix.patch
|
||||
%if 0%{?rhel} && 0%{?rhel} < 7
|
||||
%patch7 -p1 -b .rhel6gcj.patch
|
||||
%patch8 -p1 -b .rhel6poppler.patch
|
||||
%patch9 -p1 -b .rhel6langs.patch
|
||||
%patch10 -p1 -b .rhel6glib.patch
|
||||
%endif
|
||||
%patch11 -p1 -b .rhbz-1032774-bodge-around-reported-NULL-valu.patch
|
||||
%patch12 -p1 -b .rhbz-1035092-no-shortcut-key-for-Italian-To.patch
|
||||
%patch13 -p1 -b .rhbz-912529-Kerkis-SmallCaps-shown-instead-.patch
|
||||
%patch14 -p1 -b .rhbz-1038189-refresh-printer-list-when-prin.patch
|
||||
%patch15 -p1 -b .rhbz-1047871-conditional-formatting-doesn-t-.patch
|
||||
%patch16 -p1 -b .Use-sal_Int32-to-satisfy-oox-helper-helper.hxx-s-con.patch
|
||||
git commit -q -a -m 'add Red Hat colors to palette'
|
||||
|
||||
# apply patches
|
||||
git am %{patches}
|
||||
|
||||
# fdo#72987 firebird unit test fails on big endian platforms
|
||||
sed -i -e /firebird_test/d dbaccess/Module_dbaccess.mk
|
||||
git commit -q -a -m 'disable firebird unit test'
|
||||
|
||||
# TODO: check this
|
||||
# these are horribly incomplete--empty translations and copied english
|
||||
@ -1068,6 +1063,8 @@ cp -r translations/source/en-GB translations/source/ms
|
||||
cp -r translations/source/en-GB translations/source/ur
|
||||
%endif
|
||||
|
||||
git commit -q -a -m 'fix translations'
|
||||
|
||||
%build
|
||||
echo build start time is `date`, diskspace: `df -h . | tail -n 1`
|
||||
echo building localizations: %{langpack_langs}
|
||||
|
@ -1,11 +1,17 @@
|
||||
Index: configuration/ppds/SGENPRT.PS
|
||||
===================================================================
|
||||
RCS file: /cvs/external/psprint_config/configuration/ppds/SGENPRT.PS,v
|
||||
retrieving revision 1.3
|
||||
diff -u -p -u -r1.3 SGENPRT.PS
|
||||
--- openoffice.org.orig/psprint_config/configuration/ppds/SGENPRT.PS 26 Nov 2004 16:10:35 -0000 1.3
|
||||
+++ openoffice.org/psprint_config/configuration/ppds/SGENPRT.PS 30 Aug 2005 11:17:51 -0000
|
||||
@@ -58,6 +58,7 @@
|
||||
From ea8d40dfc86fd45bb64ecaa33b703eb99701c3e4 Mon Sep 17 00:00:00 2001
|
||||
From: David Tardon <dtardon@redhat.com>
|
||||
Date: Mon, 3 Feb 2014 19:25:59 +0100
|
||||
Subject: [PATCH] rhbz#188467 printing defaults
|
||||
|
||||
---
|
||||
psprint_config/configuration/ppds/SGENPRT.PS | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/psprint_config/configuration/ppds/SGENPRT.PS b/psprint_config/configuration/ppds/SGENPRT.PS
|
||||
index 0446757..177e2c4 100644
|
||||
--- a/psprint_config/configuration/ppds/SGENPRT.PS
|
||||
+++ b/psprint_config/configuration/ppds/SGENPRT.PS
|
||||
@@ -42,6 +42,7 @@
|
||||
*ColorDevice: True
|
||||
*DefaultColorSpace: RGB
|
||||
*LanguageLevel: "2"
|
||||
@ -13,3 +19,6 @@ diff -u -p -u -r1.3 SGENPRT.PS
|
||||
|
||||
*% --- For None Color or old PostScript(R) printers use following lines ---
|
||||
*% *ColorDevice: False
|
||||
--
|
||||
1.8.4.2
|
||||
|
||||
|
@ -1,6 +1,17 @@
|
||||
--- openoffice.org.orig/desktop/scripts/unopkg.sh 2008-01-14 15:55:26.000000000 +0000
|
||||
+++ openoffice.org/desktop/scripts/unopkg.sh 2008-02-14 10:52:10.000000000 +0000
|
||||
@@ -62,6 +62,33 @@
|
||||
From 3b77bbe76b9f99d871074e8baa6e0845f4756442 Mon Sep 17 00:00:00 2001
|
||||
From: David Tardon <dtardon@redhat.com>
|
||||
Date: Mon, 3 Feb 2014 20:24:50 +0100
|
||||
Subject: [PATCH] i#86080 unopkg bodge
|
||||
|
||||
---
|
||||
desktop/scripts/unopkg.sh | 33 +++++++++++++++++++++++++++++++--
|
||||
1 file changed, 31 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/desktop/scripts/unopkg.sh b/desktop/scripts/unopkg.sh
|
||||
index d16d226..aefc918 100755
|
||||
--- a/desktop/scripts/unopkg.sh
|
||||
+++ b/desktop/scripts/unopkg.sh
|
||||
@@ -53,6 +53,33 @@ AIX)
|
||||
;;
|
||||
esac
|
||||
|
||||
@ -34,7 +45,7 @@
|
||||
#collect all bootstrap variables specified on the command line
|
||||
#so that they can be passed as arguments to javaldx later on
|
||||
for arg in $@
|
||||
@@ -110,6 +137,8 @@
|
||||
@@ -92,6 +119,8 @@ unset XENVIRONMENT
|
||||
# SAL_NO_XINITTHREADS=true; export SAL_NO_XINITTHREADS
|
||||
|
||||
# execute binary
|
||||
@ -45,3 +56,6 @@
|
||||
+if [ -n "$INSTDIR" ]; then
|
||||
+ rm -rf $INSTDIR
|
||||
+fi
|
||||
--
|
||||
1.8.4.2
|
||||
|
||||
|
@ -1,12 +1,18 @@
|
||||
Index: bin/modules/installer/scriptitems.pm
|
||||
===================================================================
|
||||
RCS file: /cvs/tools/solenv/bin/modules/installer/scriptitems.pm,v
|
||||
retrieving revision 1.17
|
||||
diff -u -p -r1.17 scriptitems.pm
|
||||
--- openoffice.org.orig/solenv/bin/modules/installer/scriptitems.pm 24 Feb 2005 16:21:15 -0000 1.17
|
||||
+++ openoffice.org/solenv/bin/modules/installer/scriptitems.pm 18 Mar 2005 22:39:42 -0000
|
||||
@@ -1356,11 +1356,10 @@
|
||||
From eab93c587dd524241f63e885b0e4ac8700da5d16 Mon Sep 17 00:00:00 2001
|
||||
From: David Tardon <dtardon@redhat.com>
|
||||
Date: Mon, 3 Feb 2014 20:31:04 +0100
|
||||
Subject: [PATCH] solenv: allow missing files
|
||||
|
||||
---
|
||||
solenv/bin/modules/installer/scriptitems.pm | 15 ++++++---------
|
||||
1 file changed, 6 insertions(+), 9 deletions(-)
|
||||
|
||||
diff --git a/solenv/bin/modules/installer/scriptitems.pm b/solenv/bin/modules/installer/scriptitems.pm
|
||||
index 4c384ce..963ca84 100644
|
||||
--- a/solenv/bin/modules/installer/scriptitems.pm
|
||||
+++ b/solenv/bin/modules/installer/scriptitems.pm
|
||||
@@ -1133,11 +1133,10 @@ sub remove_Files_Without_Sourcedirectory
|
||||
|
||||
if ( ! $installer::globals::languagepack && !$installer::globals::helppack)
|
||||
{
|
||||
- $infoline = "ERROR: Removing file $filename from file list.\n";
|
||||
@ -19,7 +25,7 @@ diff -u -p -r1.17 scriptitems.pm
|
||||
|
||||
next; # removing this file from list, if sourcepath is empty
|
||||
}
|
||||
@@ -1368,11 +1367,10 @@
|
||||
@@ -1145,11 +1144,10 @@ sub remove_Files_Without_Sourcedirectory
|
||||
{
|
||||
if (( $onefile->{'ismultilingual'} ) || ( $styles =~ /\bFORCELANGUAGEPACK\b/ ))
|
||||
{
|
||||
@ -33,7 +39,7 @@ diff -u -p -r1.17 scriptitems.pm
|
||||
|
||||
next; # removing this file from list, if sourcepath is empty
|
||||
}
|
||||
@@ -1390,11 +1388,10 @@
|
||||
@@ -1167,11 +1165,10 @@ sub remove_Files_Without_Sourcedirectory
|
||||
{
|
||||
if (( $onefile->{'ismultilingual'} ) || ( $styles =~ /\bFORCEHELPPACK\b/ ))
|
||||
{
|
||||
@ -47,14 +53,6 @@ diff -u -p -r1.17 scriptitems.pm
|
||||
|
||||
next; # removing this file from list, if sourcepath is empty
|
||||
}
|
||||
--- openoffice.org.orig/solenv/bin/modules/installer/simplepackage.pm 2010-07-12 10:27:26.000000000 +0100
|
||||
+++ openoffice.org/solenv/bin/modules/installer/simplepackage.pm 2010-07-12 10:27:54.000000000 +0100
|
||||
@@ -53,7 +53,7 @@
|
||||
( $installer::globals::packageformat eq "archive" ))
|
||||
{
|
||||
$installer::globals::is_simple_packager_project = 1;
|
||||
- $installer::globals::patch_user_dir = 1;
|
||||
+ $installer::globals::patch_user_dir = 1;
|
||||
}
|
||||
elsif( $installer::globals::packageformat eq "dmg" )
|
||||
{
|
||||
--
|
||||
1.8.4.2
|
||||
|
||||
|
Loading…
x
Reference in New Issue
Block a user