7.4.0
This commit is contained in:
parent
921bb24a95
commit
6b3829519f
12
.gitignore
vendored
12
.gitignore
vendored
@ -5,9 +5,9 @@
|
||||
/libreoffice-multiliblauncher.sh
|
||||
/dtoa-20180411.tgz
|
||||
/libcuckoo-93217f8d391718380c508a722ab9acd5e9081233.tar.gz
|
||||
/libreoffice-7.3.5.2.tar.xz
|
||||
/libreoffice-7.3.5.2.tar.xz.asc
|
||||
/libreoffice-help-7.3.5.2.tar.xz
|
||||
/libreoffice-help-7.3.5.2.tar.xz.asc
|
||||
/libreoffice-translations-7.3.5.2.tar.xz
|
||||
/libreoffice-translations-7.3.5.2.tar.xz.asc
|
||||
/libreoffice-7.4.0.2.tar.xz
|
||||
/libreoffice-7.4.0.2.tar.xz.asc
|
||||
/libreoffice-help-7.4.0.2.tar.xz
|
||||
/libreoffice-help-7.4.0.2.tar.xz.asc
|
||||
/libreoffice-translations-7.4.0.2.tar.xz
|
||||
/libreoffice-translations-7.4.0.2.tar.xz.asc
|
||||
|
@ -14,7 +14,7 @@ diff --git a/desktop/source/app/app.cxx b/desktop/source/app/app.cxx
|
||||
index c54aea9dd4f7..a613fe12cef2 100644
|
||||
--- a/desktop/source/app/app.cxx
|
||||
+++ b/desktop/source/app/app.cxx
|
||||
@@ -1147,14 +1147,12 @@ void Desktop::Exception(ExceptionCategory nCategory)
|
||||
@@ -1165,8 +1165,6 @@
|
||||
if( bRestart )
|
||||
{
|
||||
RequestHandler::Disable();
|
||||
@ -22,8 +22,10 @@ index c54aea9dd4f7..a613fe12cef2 100644
|
||||
- osl_removeSignalHandler( pSignalHandler );
|
||||
|
||||
restartOnMac(false);
|
||||
if ( m_rSplashScreen.is() )
|
||||
#if !ENABLE_WASM_STRIP_SPLASH
|
||||
@@ -1174,7 +1172,7 @@
|
||||
m_rSplashScreen->reset();
|
||||
#endif
|
||||
|
||||
- _exit( EXITHELPER_CRASH_WITH_RESTART );
|
||||
+ return;
|
||||
|
@ -1,70 +0,0 @@
|
||||
From c3afc3ba94500f726475adc895de6c92814ae8bb Mon Sep 17 00:00:00 2001
|
||||
From: Stephan Bergmann <sbergman@redhat.com>
|
||||
Date: Fri, 8 Jul 2022 16:47:01 +0200
|
||||
Subject: [PATCH] rhbz#2104545: Only call utl::IsYounger when its result is
|
||||
actually used
|
||||
|
||||
...as it may be expensive, or even throw (uncaught) exceptions (as apparently
|
||||
happened at rhbz#2104545, throwing some css::uno::RuntimeException while aMedObj
|
||||
was an sftp URL).
|
||||
|
||||
The two branches in the if statement's condition that will now potentially call
|
||||
physObjIsOlder are disjoint (one for aMedObj being a file URL, the other for
|
||||
aMedObj being any WebDAV-related URL), so there is no chance that this change
|
||||
accidentally causes utl::IsYounger to be called more often than it used to be
|
||||
called.
|
||||
|
||||
Reviewed-on: https://gerrit.libreoffice.org/c/core/+/136904
|
||||
Tested-by: Jenkins
|
||||
Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
|
||||
(cherry picked from commit 27ffdcf096a7e9863489599dd80528b088d1e9b8)
|
||||
Conflicts:
|
||||
sfx2/source/view/viewfrm.cxx
|
||||
|
||||
Change-Id: I29a5f18a12a8b83ec603366db26451175b5622c9
|
||||
Reviewed-on: https://gerrit.libreoffice.org/c/core/+/136909
|
||||
Tested-by: Jenkins
|
||||
Reviewed-by: Michael Stahl <michael.stahl@allotropia.de>
|
||||
---
|
||||
sfx2/source/view/viewfrm.cxx | 11 +++++++----
|
||||
1 file changed, 7 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/sfx2/source/view/viewfrm.cxx b/sfx2/source/view/viewfrm.cxx
|
||||
index ecae96b5d945..7f3bf1a6bcc2 100644
|
||||
--- a/sfx2/source/view/viewfrm.cxx
|
||||
+++ b/sfx2/source/view/viewfrm.cxx
|
||||
@@ -270,6 +270,11 @@ bool AskPasswordToModify_Impl( const uno::Reference< task::XInteractionHandler >
|
||||
|
||||
return bResult;
|
||||
}
|
||||
+
|
||||
+bool physObjIsOlder(INetURLObject const & aMedObj, INetURLObject const & aPhysObj) {
|
||||
+ return ::utl::UCBContentHelper::IsYounger(aMedObj.GetMainURL( INetURLObject::DecodeMechanism::NONE),
|
||||
+ aPhysObj.GetMainURL( INetURLObject::DecodeMechanism::NONE ) );
|
||||
+}
|
||||
}
|
||||
|
||||
void SfxViewFrame::ExecReload_Impl( SfxRequest& rReq )
|
||||
@@ -438,8 +443,6 @@ void SfxViewFrame::ExecReload_Impl( SfxRequest& rReq )
|
||||
// etag tells that the cache representation (e.g. in LO) is different from the one on the server,
|
||||
// but tells nothing about the age
|
||||
// Details at this link: http://tools.ietf.org/html/rfc4918#section-15, section 15.7
|
||||
- bool bPhysObjIsYounger = ::utl::UCBContentHelper::IsYounger( aMedObj.GetMainURL( INetURLObject::DecodeMechanism::NONE ),
|
||||
- aPhysObj.GetMainURL( INetURLObject::DecodeMechanism::NONE ) );
|
||||
bool bIsWebDAV = aMedObj.isAnyKnownWebDAVScheme();
|
||||
|
||||
// tdf#118938 Reload the document when the user enters the editing password,
|
||||
@@ -447,8 +450,8 @@ void SfxViewFrame::ExecReload_Impl( SfxRequest& rReq )
|
||||
if ( ( !bNeedsReload && ( ( aMedObj.GetProtocol() == INetProtocol::File &&
|
||||
( aMedObj.getFSysPath( FSysStyle::Detect ) != aPhysObj.getFSysPath( FSysStyle::Detect )
|
||||
|| bPasswordEntered ) &&
|
||||
- !bPhysObjIsYounger )
|
||||
- || ( bIsWebDAV && !bPhysObjIsYounger )
|
||||
+ !physObjIsOlder(aMedObj, aPhysObj) )
|
||||
+ || ( bIsWebDAV && !physObjIsOlder(aMedObj, aPhysObj) )
|
||||
|| ( pMed->IsRemote() && !bIsWebDAV ) ) )
|
||||
|| pVersionItem )
|
||||
// <- tdf#82744
|
||||
--
|
||||
2.36.1
|
||||
|
@ -1,26 +0,0 @@
|
||||
From d0805b6732c0fe3168d144928cec1c59c2711211 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Caol=C3=A1n=20McNamara?= <caolanm@redhat.com>
|
||||
Date: Sun, 6 Mar 2022 23:19:08 +0000
|
||||
Subject: [PATCH] s390x canvas test fails
|
||||
|
||||
Change-Id: I7ac059aa19dd348f4e9c567445aff8f066c867b4
|
||||
---
|
||||
canvas/Module_canvas.mk | 4 ----
|
||||
1 file changed, 4 deletions(-)
|
||||
|
||||
diff --git a/canvas/Module_canvas.mk b/canvas/Module_canvas.mk
|
||||
index 0ca3c4c9bfe0..f62d7ef46299 100644
|
||||
--- a/canvas/Module_canvas.mk
|
||||
+++ b/canvas/Module_canvas.mk
|
||||
@@ -49,8 +49,4 @@ $(eval $(call gb_Module_add_targets,canvas,\
|
||||
))
|
||||
endif
|
||||
|
||||
-$(eval $(call gb_Module_add_check_targets,canvas,\
|
||||
- CppunitTest_canvas_test \
|
||||
-))
|
||||
-
|
||||
# vim: set noet sw=4 ts=4:
|
||||
--
|
||||
2.35.1
|
||||
|
File diff suppressed because it is too large
Load Diff
@ -1,35 +0,0 @@
|
||||
From 9fcb36d5ebb53f398c48024a1babcc36fc9625f3 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Caol=C3=A1n=20McNamara?= <caolanm@redhat.com>
|
||||
Date: Sat, 5 Mar 2022 21:42:33 +0000
|
||||
Subject: [PATCH] workaround x86 ICE with gcc 12
|
||||
|
||||
Change-Id: I5c31cf31bf676fde4440e46e532595237cc41bab
|
||||
---
|
||||
sc/source/core/tool/interpr2.cxx | 4 ++++
|
||||
1 file changed, 4 insertions(+)
|
||||
|
||||
diff --git a/sc/source/core/tool/interpr2.cxx b/sc/source/core/tool/interpr2.cxx
|
||||
index 6525f2a6784b..fd3aba045487 100644
|
||||
--- a/sc/source/core/tool/interpr2.cxx
|
||||
+++ b/sc/source/core/tool/interpr2.cxx
|
||||
@@ -3421,6 +3421,9 @@ void lclAppendBlock( OStringBuffer& rText, sal_Int32 nValue )
|
||||
|
||||
} // namespace
|
||||
|
||||
+#if defined(X86)
|
||||
+void ScInterpreter::ScBahtText() {}
|
||||
+#else
|
||||
void ScInterpreter::ScBahtText()
|
||||
{
|
||||
sal_uInt8 nParamCount = GetByte();
|
||||
@@ -3487,6 +3490,7 @@ void ScInterpreter::ScBahtText()
|
||||
|
||||
PushString( OStringToOUString(aText.makeStringAndClear(), RTL_TEXTENCODING_UTF8) );
|
||||
}
|
||||
+#endif
|
||||
|
||||
void ScInterpreter::ScGetPivotData()
|
||||
{
|
||||
--
|
||||
2.35.1
|
||||
|
@ -1,5 +1,5 @@
|
||||
# download path contains version without the last (fourth) digit
|
||||
%global libo_version 7.3.5
|
||||
%global libo_version 7.4.0
|
||||
# Should contain .alphaX / .betaX, if this is pre-release (actually
|
||||
# pre-RC) version. The pre-release string is part of tarball file names,
|
||||
# so we need a way to define it easily at one place.
|
||||
@ -151,6 +151,7 @@ BuildRequires: pkgconfig(gobject-introspection-1.0)
|
||||
BuildRequires: pkgconfig(gstreamer-1.0)
|
||||
BuildRequires: pkgconfig(gstreamer-plugins-base-1.0)
|
||||
BuildRequires: pkgconfig(gtk+-3.0)
|
||||
BuildRequires: pkgconfig(gtk+-4.0)
|
||||
BuildRequires: pkgconfig(hunspell)
|
||||
BuildRequires: pkgconfig(ice)
|
||||
BuildRequires: pkgconfig(icu-i18n)
|
||||
@ -252,11 +253,6 @@ Patch1: 0001-disble-tip-of-the-day-dialog-by-default.patch
|
||||
Patch2: 0001-Resolves-rhbz-1432468-disable-opencl-by-default.patch
|
||||
# backported
|
||||
Patch3: 0001-Revert-tdf-101630-gdrive-support-w-oAuth-and-Drive-A.patch
|
||||
# ICE
|
||||
Patch4: 0001-workaround-x86-ICE-with-gcc-12.patch
|
||||
Patch5: 0001-s390x-canvas-test-fails.patch
|
||||
Patch6: 0001-tdf-144862-use-resolution-independent-positions-for-.patch
|
||||
Patch7: 0001-rhbz-2104545-Only-call-utl-IsYounger-when-its-result.patch
|
||||
# not upstreamed
|
||||
Patch500: 0001-disable-libe-book-support.patch
|
||||
|
||||
@ -611,6 +607,15 @@ Supplements: (%{name}-core%{?_isa} and gtk3%{?_isa})
|
||||
%description gtk3
|
||||
A plug-in for LibreOffice that enables integration into GTK+ 3 environment.
|
||||
|
||||
%package gtk4
|
||||
Summary: LibreOffice GTK+ 4 experimental integration plug-in
|
||||
Requires: %{name}-core%{?_isa} = %{epoch}:%{version}-%{release}
|
||||
Requires: %{name}-ure%{?_isa} = %{epoch}:%{version}-%{release}
|
||||
Supplements: (%{name}-core%{?_isa} and gtk4%{?_isa})
|
||||
|
||||
%description gtk4
|
||||
An experimental plug-in for LibreOffice that enables integration into GTK+ 4 environment.
|
||||
|
||||
%if 0%{?fedora}
|
||||
|
||||
%package kf5
|
||||
@ -1089,6 +1094,7 @@ touch autogen.lastrun
|
||||
--enable-python=system \
|
||||
--with-idlc-cpp=cpp \
|
||||
--disable-scripting-beanshell --disable-scripting-javascript \
|
||||
--enable-gtk4 \
|
||||
%{javaoptions} \
|
||||
%{distrooptions} \
|
||||
%{?bundling_options} \
|
||||
@ -1370,7 +1376,7 @@ install -m 0644 -p mime/packages/libreoffice$PRODUCTVERSION.xml %{buildroot}%{_d
|
||||
|
||||
%if 0%{?fedora}
|
||||
# restrict abipkgdiff to shared objects that actually have a stable ABI
|
||||
for pkg in core base officebean ogltrans pdfimport calc writer impress graphicfilter postgresql ure pyuno x11 gtk3 kf5 libreofficekit; do
|
||||
for pkg in core base officebean ogltrans pdfimport calc writer impress graphicfilter postgresql ure pyuno x11 gtk3 gtk4 kf5 libreofficekit; do
|
||||
cat > %{buildroot}%{baseinstdir}/program/${pkg}.abignore << _EOF
|
||||
[suppress_file]
|
||||
file_name_not_regexp=.*\.so\.[0-9]+
|
||||
@ -1501,9 +1507,7 @@ rm -f %{buildroot}%{baseinstdir}/program/officebean.abignore
|
||||
%endif
|
||||
|
||||
%check
|
||||
%ifnarch s390x
|
||||
make unitcheck slowcheck
|
||||
%endif
|
||||
# we don't need this anymore
|
||||
rm -f %{buildroot}%{baseinstdir}/program/classes/smoketest.jar
|
||||
|
||||
@ -2224,6 +2228,12 @@ gtk-update-icon-cache -q %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
%endif
|
||||
%{baseinstdir}/program/libvclplug_gtk3lo.so
|
||||
|
||||
%files gtk4
|
||||
%if 0%{?fedora}
|
||||
%{baseinstdir}/program/gtk4.abignore
|
||||
%endif
|
||||
%{baseinstdir}/program/libvclplug_gtk4lo.so
|
||||
|
||||
%if 0%{?fedora}
|
||||
|
||||
%files kf5
|
||||
@ -2247,6 +2257,9 @@ gtk-update-icon-cache -q %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
%{_includedir}/LibreOfficeKit
|
||||
|
||||
%changelog
|
||||
* Tue Aug 09 2022 Caolán McNamara <caolanm@redhat.com> - 1:7.4.0.2-1
|
||||
- 7.4 version
|
||||
|
||||
* Wed Aug 03 2022 Caolán McNamara <caolanm@redhat.com> - 1:7.3.5.2-3
|
||||
- Rebuilt for poppler 22.08.0
|
||||
|
||||
|
12
sources
12
sources
@ -5,9 +5,9 @@ SHA512 (f543e6e2d7275557a839a164941c0a86e5f2c3f2a0042bfc434c88c6dde9e140-opens__
|
||||
SHA512 (libreoffice-multiliblauncher.sh) = db532afdf5000bc66f9e02c7d0ab586468466f63f8f0bdb204832581e8277c5c59f688fa096548d642411cb8c46e8de4a744676b4e624c075262cfd6945138cd
|
||||
SHA512 (dtoa-20180411.tgz) = 722aa814c33a34bfffe6c0201b0035cc3b65854a0ba9ae2f51620a89d68019353e2c306651b35bca337186b22b2e9865ef3c5e3df8e9328006f882e4577f8c85
|
||||
SHA512 (libcuckoo-93217f8d391718380c508a722ab9acd5e9081233.tar.gz) = 4159dfb4d08e359feb23127e12db590260913e70774161ac9513abb5183ad6ed6d2bdfbe56fc8aa68e2fc57ee29eae67aa0180e1a7d955016884ecba2ca60ff8
|
||||
SHA512 (libreoffice-7.3.5.2.tar.xz) = 00d381e97c0bc6f97d4e770b7037f08fc659e58e792d47b539ecd0b3fb4e3e9b570769e9b3eb26522d951fa14926f71bef8567756b8b8b8c4777a00e48ee030c
|
||||
SHA512 (libreoffice-7.3.5.2.tar.xz.asc) = 9680c5f12a1c6e51d7000e7af1d2b176d353e850ade9d8298668d866cbbfd1ba93f1375d9003089bfaa83b5dd438d49080f3d7843cf6fb7d80ca07617022c935
|
||||
SHA512 (libreoffice-help-7.3.5.2.tar.xz) = 9e8c782fa20bef6806d96965c469be2423d5be6e6b3e78f690c553294cfe83877cd96fc2234caa247cf063264c1bea4909047771298946e33ae83e04597104c6
|
||||
SHA512 (libreoffice-help-7.3.5.2.tar.xz.asc) = 3cedc500e4f7d6d8a284bf9323ef475f8453ea2979df586980b174d7fc3105075eeb4bd590a5d834bbfde60b4985e5e0d36a308e827bda11dcb5c11b91b31f2a
|
||||
SHA512 (libreoffice-translations-7.3.5.2.tar.xz) = fc928a77f804b886d6d494307c0d028d42c6322c211911eb2aaeb68d4b3d1992f5d43b22668464d8fffbbf1bcddfcc19a810192b10d4d37e51039aa639b2bbce
|
||||
SHA512 (libreoffice-translations-7.3.5.2.tar.xz.asc) = 76f14f67bf26e3225661da4042d9defb0980d3fd556e63661bf85b0e11fdf3801cdd5f5a1b442296c5410906e6ff492ce103d781241448fd4a90fae491ecf824
|
||||
SHA512 (libreoffice-7.4.0.2.tar.xz) = f7b6493bf43f4396e108fc75387a0ed9ca7a9c9f743dda779dcc084ba174ebf3ce35cb207c8ee9544ef12a7d5084ff6f221d8b63f1a3a2ab4cce7c16bb340fec
|
||||
SHA512 (libreoffice-7.4.0.2.tar.xz.asc) = 25f8f6976a519b8359eb02373484cd7ff5dbedaab98f61f930f73b7b73d4d0e28a2f2118c727146038c4b96629b19ac199934350a7f33b979ca16709a0edacb3
|
||||
SHA512 (libreoffice-help-7.4.0.2.tar.xz) = ac742a502a7f14a0b46cc490452bf621d2841cb83f3538f50853b694be15bcd39f57cf2ad17f07d59be13a4db0634b1a0e4d06a572c60e102c9d913a274ddeea
|
||||
SHA512 (libreoffice-help-7.4.0.2.tar.xz.asc) = 2c87fa17a7935b44c65d9af02d6d0e86557d45ff9c99901d8d460be84c7c920d3589cdeb4f80b3f55d8103454a16b705c4622391c75b815d6b8e67e3813296d7
|
||||
SHA512 (libreoffice-translations-7.4.0.2.tar.xz) = a4492cc407af1759927414de30eebc4e3bc8398f23898224a3155e3f4c22c98ff4aae1283532c7a5e29b49625d5b2e973c26513c15101c30d795498651af74ce
|
||||
SHA512 (libreoffice-translations-7.4.0.2.tar.xz.asc) = d63eee1a44584bbb406898de319af2db757fab6611b67c845f42e4d319e57eeefa4bafda9fc134cda9b87799bbfb9ba9b409fee03b5e77dd3c6b1d024c0fe235
|
||||
|
Loading…
Reference in New Issue
Block a user