hardcode poppler version available on rhel-6

This commit is contained in:
David Tardon 2014-01-26 08:23:41 +01:00
parent 079f4b6d1f
commit 65005c2f09

View File

@ -19,18 +19,17 @@
else
--- a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx 2011-11-10 13:22:11.949473646 +0000
+++ b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx 2011-11-10 13:23:24.889473889 +0000
@@ -64,11 +64,6 @@
@@ -64,7 +64,9 @@
class GfxPath;
class GfxFont;
class PDFDoc;
-#include <cpp/poppler-version.h>
-#define POPPLER_CHECK_VERSION(major,minor,micro) \
- (POPPLER_VERSION_MAJOR > (major) || \
- (POPPLER_VERSION_MAJOR == (major) && POPPLER_VERSION_MINOR > (minor)) || \
- (POPPLER_VERSION_MAJOR == (major) && POPPLER_VERSION_MINOR == (minor) && POPPLER_VERSION_MICRO >= (micro)))
namespace pdfi
{
+#define POPPLER_VERSION_MAJOR 0
+#define POPPLER_VERSION_MINOR 12
+#define POPPLER_VERSION_MICRO 4
#define POPPLER_CHECK_VERSION(major,minor,micro) \
(POPPLER_VERSION_MAJOR > (major) || \
(POPPLER_VERSION_MAJOR == (major) && POPPLER_VERSION_MINOR > (minor)) || \
--- a/sdext/Module_sdext.mk
+++ b/sdext/Module_sdext.mk
@@ -32,11 +32,6 @@ $(eval $(call gb_Module_add_targets,sdext,\