get opengl slide transitions working with glm >= 0.9.9.0
This commit is contained in:
parent
77ce29d959
commit
5d7f8f1bad
@ -0,0 +1,30 @@
|
||||
From 44d4060c9d3dcf8d28ba4f4569ba6e0971237cd2 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Caol=C3=A1n=20McNamara?= <caolanm@redhat.com>
|
||||
Date: Fri, 31 Jan 2020 21:45:11 +0000
|
||||
Subject: [PATCH] opengl slide transitions not working with glm >= GLM 0.9.9.0
|
||||
|
||||
tracked it down to...
|
||||
|
||||
Removed default initialization, use GLM_FORCE_CTOR_INIT to restore the old behavior
|
||||
so adding in GLM_FORCE_CTOR_INIT to get them working again
|
||||
|
||||
Change-Id: I1c6e7d8eb748fce40f0c518ff708708e5fb1e3d2
|
||||
---
|
||||
slideshow/Library_OGLTrans.mk | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/slideshow/Library_OGLTrans.mk b/slideshow/Library_OGLTrans.mk
|
||||
index 4eca2a1ecaa3..9b64181d6a46 100644
|
||||
--- a/slideshow/Library_OGLTrans.mk
|
||||
+++ b/slideshow/Library_OGLTrans.mk
|
||||
@@ -17,6 +17,7 @@ endif
|
||||
|
||||
$(eval $(call gb_Library_add_defs,OGLTrans,\
|
||||
-DGLM_FORCE_RADIANS \
|
||||
+ -DGLM_FORCE_CTOR_INIT \
|
||||
))
|
||||
|
||||
$(eval $(call gb_Library_use_sdk_api,OGLTrans))
|
||||
--
|
||||
2.24.1
|
||||
|
@ -54,7 +54,7 @@ Summary: Free Software Productivity Suite
|
||||
Name: libreoffice
|
||||
Epoch: 1
|
||||
Version: %{libo_version}.2
|
||||
Release: 1%{?libo_prerelease}%{?dist}
|
||||
Release: 2%{?libo_prerelease}%{?dist}
|
||||
License: (MPLv1.1 or LGPLv3+) and LGPLv3 and LGPLv2+ and BSD and (MPLv1.1 or GPLv2 or LGPLv2 or Netscape) and Public Domain and ASL 2.0 and MPLv2.0 and CC0
|
||||
URL: http://www.libreoffice.org/
|
||||
|
||||
@ -242,6 +242,7 @@ Patch0: 0001-don-t-suppress-crashes.patch
|
||||
Patch1: 0001-Resolves-rhbz-1432468-disable-opencl-by-default.patch
|
||||
Patch2: 0001-rhbz-1775767-null-deref.patch
|
||||
Patch3: 0001-Adapt-SAL_WARN-to-C-20-deleted-ostream-for-sal_Unico.patch
|
||||
Patch4: 0001-opengl-slide-transitions-not-working-with-glm-GLM-0..patch
|
||||
|
||||
%if 0%{?rhel}
|
||||
# not upstreamed
|
||||
@ -2134,6 +2135,9 @@ done
|
||||
%{_includedir}/LibreOfficeKit
|
||||
|
||||
%changelog
|
||||
* Fri Jan 31 2020 Caolán McNamara <caolanm@redhat.com> - 1:6.3.4.2-2
|
||||
- get opengl slide transitions working with glm >= 0.9.9.0
|
||||
|
||||
* Wed Jan 22 2020 Caolán McNamara <caolanm@redhat.com> - 1:6.3.4.2-1
|
||||
- latest stable release
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user