latest version
This commit is contained in:
parent
fbd42f2bda
commit
548fedad1d
12
.gitignore
vendored
12
.gitignore
vendored
@ -6,9 +6,9 @@
|
||||
/f543e6e2d7275557a839a164941c0a86e5f2c3f2a0042bfc434c88c6dde9e140-opens___.ttf
|
||||
/libreoffice-multiliblauncher.sh
|
||||
/dtoa-20180411.tgz
|
||||
/libreoffice-7.1.2.2.tar.xz
|
||||
/libreoffice-7.1.2.2.tar.xz.asc
|
||||
/libreoffice-help-7.1.2.2.tar.xz
|
||||
/libreoffice-help-7.1.2.2.tar.xz.asc
|
||||
/libreoffice-translations-7.1.2.2.tar.xz
|
||||
/libreoffice-translations-7.1.2.2.tar.xz.asc
|
||||
/libreoffice-7.1.3.2.tar.xz
|
||||
/libreoffice-7.1.3.2.tar.xz.asc
|
||||
/libreoffice-help-7.1.3.2.tar.xz
|
||||
/libreoffice-help-7.1.3.2.tar.xz.asc
|
||||
/libreoffice-translations-7.1.3.2.tar.xz
|
||||
/libreoffice-translations-7.1.3.2.tar.xz.asc
|
||||
|
@ -1,43 +0,0 @@
|
||||
From 2beb3922391ae1a6f1d26128d82c0e34cb963af3 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Caol=C3=A1n=20McNamara?= <caolanm@redhat.com>
|
||||
Date: Tue, 23 Mar 2021 14:55:09 +0000
|
||||
Subject: [PATCH] Related: tdf#141197 critical a11y warning
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
** (soffice:19098): CRITICAL **: 13:44:40.365:
|
||||
AtkObject* atk_object_wrapper_ref(const com::sun::star::uno::Reference<com::sun::star::accessibility::XAccessible>&, bool):
|
||||
assertion 'bool(rxAccessible)' failed
|
||||
|
||||
probably since...
|
||||
|
||||
commit cbc18cc904c652a936c4b68fba4d975bd89b5abd
|
||||
Date: Mon Nov 23 21:03:28 2020 +0100
|
||||
|
||||
tdf#138425 vcl/gtk activate main menu in UpdateFull
|
||||
|
||||
Change-Id: Ieb181e02bb0d2a907aec8534349ec2a80fd9c7e3
|
||||
Reviewed-on: https://gerrit.libreoffice.org/c/core/+/113000
|
||||
Tested-by: Jenkins
|
||||
Reviewed-by: Caolán McNamara <caolanm@redhat.com>
|
||||
---
|
||||
vcl/source/window/menu.cxx | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/vcl/source/window/menu.cxx b/vcl/source/window/menu.cxx
|
||||
index 4fb964f2f008..233f531cfcaf 100644
|
||||
--- a/vcl/source/window/menu.cxx
|
||||
+++ b/vcl/source/window/menu.cxx
|
||||
@@ -1303,7 +1303,7 @@ css::uno::Reference<css::accessibility::XAccessible> Menu::GetAccessible()
|
||||
// Since PopupMenu are sometimes shared by different instances of MenuBar, the mxAccessible member gets
|
||||
// overwritten and may contain a disposed object when the initial menubar gets set again. So use the
|
||||
// mxAccessible member only for sub menus.
|
||||
- if ( pStartedFrom )
|
||||
+ if (pStartedFrom && pStartedFrom != this)
|
||||
{
|
||||
for ( sal_uInt16 i = 0, nCount = pStartedFrom->GetItemCount(); i < nCount; ++i )
|
||||
{
|
||||
--
|
||||
2.30.2
|
||||
|
@ -1,120 +0,0 @@
|
||||
From 26ff4db374438a230f1670ab12d88f7f54075127 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Caol=C3=A1n=20McNamara?= <caolanm@redhat.com>
|
||||
Date: Wed, 24 Mar 2021 11:33:42 +0000
|
||||
Subject: [PATCH] tdf#141197 if we have a sysobj child then include that in the
|
||||
atk hierarchy
|
||||
|
||||
this also should make the case of an embedded video visible in the atk
|
||||
hierarchy as well as the target of the native gtk widgets in a vcl
|
||||
window container in the startcenter
|
||||
|
||||
Change-Id: Ia91439cbccbffbb0badbfb466f7ab6d1ccbfe3ae
|
||||
---
|
||||
vcl/Library_vclplug_gtk3.mk | 1 +
|
||||
vcl/Library_vclplug_gtk3_kde5.mk | 1 +
|
||||
vcl/unx/gtk3/a11y/atkwrapper.hxx | 1 +
|
||||
vcl/unx/gtk3/a11y/gtk3atkwrapper.cxx | 28 ++++++++++++++++++++++++++++
|
||||
4 files changed, 31 insertions(+)
|
||||
|
||||
diff --git a/vcl/Library_vclplug_gtk3.mk b/vcl/Library_vclplug_gtk3.mk
|
||||
index 9e67d5efc265..317152b59fe9 100644
|
||||
--- a/vcl/Library_vclplug_gtk3.mk
|
||||
+++ b/vcl/Library_vclplug_gtk3.mk
|
||||
@@ -36,6 +36,7 @@ $(eval $(call gb_Library_set_include,vclplug_gtk3,\
|
||||
|
||||
$(eval $(call gb_Library_add_defs,vclplug_gtk3,\
|
||||
-DVCLPLUG_GTK_IMPLEMENTATION \
|
||||
+ -DVCL_INTERNALS \
|
||||
))
|
||||
|
||||
$(eval $(call gb_Library_use_custom_headers,vclplug_gtk3,\
|
||||
diff --git a/vcl/Library_vclplug_gtk3_kde5.mk b/vcl/Library_vclplug_gtk3_kde5.mk
|
||||
index 51dafda097be..602be3d13b45 100644
|
||||
--- a/vcl/Library_vclplug_gtk3_kde5.mk
|
||||
+++ b/vcl/Library_vclplug_gtk3_kde5.mk
|
||||
@@ -41,6 +41,7 @@ $(eval $(call gb_Library_add_cxxflags,vclplug_gtk3_kde5,\
|
||||
|
||||
$(eval $(call gb_Library_add_defs,vclplug_gtk3_kde5,\
|
||||
-DVCLPLUG_GTK_IMPLEMENTATION -DVCLPLUG_GTK3_KDE5_IMPLEMENTATION \
|
||||
+ -DVCL_INTERNALS \
|
||||
))
|
||||
|
||||
$(eval $(call gb_Library_use_custom_headers,vclplug_gtk3_kde5,\
|
||||
diff --git a/vcl/unx/gtk3/a11y/atkwrapper.hxx b/vcl/unx/gtk3/a11y/atkwrapper.hxx
|
||||
index d9c651a2eae8..0fcbce6369fd 100644
|
||||
--- a/vcl/unx/gtk3/a11y/atkwrapper.hxx
|
||||
+++ b/vcl/unx/gtk3/a11y/atkwrapper.hxx
|
||||
@@ -46,6 +46,7 @@ struct AtkObjectWrapper
|
||||
{
|
||||
AtkObject aParent;
|
||||
AtkObject* mpOrig; //if we're a GtkDrawingArea acting as a custom LibreOffice widget, this is the toolkit default impl
|
||||
+ AtkObject* mpSysObjChild; //if we're a container for a sysobj, then this is the sysobj native gtk AtkObject
|
||||
|
||||
css::uno::Reference<css::accessibility::XAccessible> mpAccessible;
|
||||
css::uno::Reference<css::accessibility::XAccessibleContext> mpContext;
|
||||
diff --git a/vcl/unx/gtk3/a11y/gtk3atkwrapper.cxx b/vcl/unx/gtk3/a11y/gtk3atkwrapper.cxx
|
||||
index 2442e6ab665d..56bc8717d0fb 100644
|
||||
--- a/vcl/unx/gtk3/a11y/gtk3atkwrapper.cxx
|
||||
+++ b/vcl/unx/gtk3/a11y/gtk3atkwrapper.cxx
|
||||
@@ -40,9 +40,13 @@
|
||||
#include <com/sun/star/accessibility/XAccessibleImage.hpp>
|
||||
#include <com/sun/star/accessibility/XAccessibleHypertext.hpp>
|
||||
#include <com/sun/star/accessibility/XAccessibleSelection.hpp>
|
||||
+#include <com/sun/star/awt/XWindow.hpp>
|
||||
|
||||
#include <rtl/strbuf.hxx>
|
||||
#include <osl/diagnose.h>
|
||||
+#include <vcl/syschild.hxx>
|
||||
+#include <vcl/sysdata.hxx>
|
||||
+#include <vcl/toolkit/unowrap.hxx>
|
||||
|
||||
#include "atkwrapper.hxx"
|
||||
#include "atkregistry.hxx"
|
||||
@@ -406,6 +410,10 @@ static gint
|
||||
wrapper_get_n_children( AtkObject *atk_obj )
|
||||
{
|
||||
AtkObjectWrapper *obj = ATK_OBJECT_WRAPPER (atk_obj);
|
||||
+
|
||||
+ if (obj->mpSysObjChild)
|
||||
+ return 1;
|
||||
+
|
||||
gint n = 0;
|
||||
|
||||
if( obj->mpContext.is() )
|
||||
@@ -428,6 +436,13 @@ wrapper_ref_child( AtkObject *atk_obj,
|
||||
gint i )
|
||||
{
|
||||
AtkObjectWrapper *obj = ATK_OBJECT_WRAPPER (atk_obj);
|
||||
+
|
||||
+ if (obj->mpSysObjChild)
|
||||
+ {
|
||||
+ g_object_ref(obj->mpSysObjChild);
|
||||
+ return obj->mpSysObjChild;
|
||||
+ }
|
||||
+
|
||||
AtkObject* child = nullptr;
|
||||
|
||||
// see comments above atk_object_wrapper_remove_child
|
||||
@@ -874,6 +889,19 @@ atk_object_wrapper_new( const css::uno::Reference< css::accessibility::XAccessib
|
||||
}
|
||||
}
|
||||
|
||||
+ // tdf#141197 if we have a sysobj child then include that in the hierarchy
|
||||
+ if (UnoWrapperBase* pWrapper = UnoWrapperBase::GetUnoWrapper())
|
||||
+ {
|
||||
+ css::uno::Reference<css::awt::XWindow> xAWTWindow(rxAccessible, css::uno::UNO_QUERY);
|
||||
+ VclPtr<vcl::Window> xWindow = pWrapper->GetWindow(xAWTWindow);
|
||||
+ if (xWindow && xWindow->GetType() == WindowType::SYSTEMCHILDWINDOW)
|
||||
+ {
|
||||
+ const SystemEnvData* pEnvData = static_cast<SystemChildWindow*>(xWindow.get())->GetSystemData();
|
||||
+ if (GtkWidget *pSysObj = pEnvData ? static_cast<GtkWidget*>(pEnvData->pWidget) : nullptr)
|
||||
+ pWrap->mpSysObjChild = gtk_widget_get_accessible(pSysObj);
|
||||
+ }
|
||||
+ }
|
||||
+
|
||||
return ATK_OBJECT( pWrap );
|
||||
}
|
||||
catch (const uno::Exception &)
|
||||
--
|
||||
2.30.2
|
||||
|
@ -1,5 +1,5 @@
|
||||
# download path contains version without the last (fourth) digit
|
||||
%global libo_version 7.1.2
|
||||
%global libo_version 7.1.3
|
||||
# Should contain .alphaX / .betaX, if this is pre-release (actually
|
||||
# pre-RC) version. The pre-release string is part of tarball file names,
|
||||
# so we need a way to define it easily at one place.
|
||||
@ -50,7 +50,7 @@ Summary: Free Software Productivity Suite
|
||||
Name: libreoffice
|
||||
Epoch: 1
|
||||
Version: %{libo_version}.2
|
||||
Release: 4%{?libo_prerelease}%{?dist}
|
||||
Release: 1%{?libo_prerelease}%{?dist}
|
||||
License: (MPLv1.1 or LGPLv3+) and LGPLv3 and LGPLv2+ and BSD and (MPLv1.1 or GPLv2 or LGPLv2 or Netscape) and Public Domain and ASL 2.0 and MPLv2.0 and CC0
|
||||
URL: http://www.libreoffice.org/
|
||||
|
||||
@ -249,11 +249,9 @@ Patch2: 0001-Resolves-rhbz-1432468-disable-opencl-by-default.patch
|
||||
# backported
|
||||
Patch3: 0001-fix-detecting-qrcodegen.patch
|
||||
Patch4: 0001-rhbz-1918152-fix-FTBFS.patch
|
||||
Patch5: 0001-Related-tdf-141197-critical-a11y-warning.patch
|
||||
Patch6: 0001-tdf-141197-if-we-have-a-sysobj-child-then-include-th.patch
|
||||
Patch7: 0001-Get-rid-of-apache-commons-logging.patch
|
||||
Patch8: 0001-rhbz-1956977-crash-on-switch-from-active-comment-to-.patch
|
||||
Patch9: 0001-Related-tdf-138888-fix-assertion-on-avmedia-MediaCon.patch
|
||||
Patch5: 0001-Get-rid-of-apache-commons-logging.patch
|
||||
Patch6: 0001-rhbz-1956977-crash-on-switch-from-active-comment-to-.patch
|
||||
Patch7: 0001-Related-tdf-138888-fix-assertion-on-avmedia-MediaCon.patch
|
||||
|
||||
# not upstreamed
|
||||
Patch500: 0001-disable-libe-book-support.patch
|
||||
@ -2239,6 +2237,9 @@ gtk-update-icon-cache -q %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
%{_includedir}/LibreOfficeKit
|
||||
|
||||
%changelog
|
||||
* Thu May 06 2021 Caolán McNamara <caolanm@redhat.com> - 1:7.1.3.2-1
|
||||
- latest version
|
||||
|
||||
* Wed May 05 2021 Caolán McNamara <caolanm@redhat.com> - 1:7.1.2.2-4
|
||||
- Resolves: rhbz#1956977 Impress crashes on switch from commenting to slide sorter
|
||||
- Resolves: rhbz#1957034 fix assertion on avmedia volumne control
|
||||
|
12
sources
12
sources
@ -7,9 +7,9 @@ SHA512 (0168229624cfac409e766913506961a8-ucpp-1.3.2.tar.gz) = b9c02d63e9b47a838d
|
||||
SHA512 (f543e6e2d7275557a839a164941c0a86e5f2c3f2a0042bfc434c88c6dde9e140-opens___.ttf) = 6a6d131dad5191614950a49323ae6d9385afe331983c1c85fde82ce6ee816051d95dde9ef90658b8f0a8a0a21754e72ff724bf41f6b96c046b7b4c2660f7095b
|
||||
SHA512 (libreoffice-multiliblauncher.sh) = db532afdf5000bc66f9e02c7d0ab586468466f63f8f0bdb204832581e8277c5c59f688fa096548d642411cb8c46e8de4a744676b4e624c075262cfd6945138cd
|
||||
SHA512 (dtoa-20180411.tgz) = 722aa814c33a34bfffe6c0201b0035cc3b65854a0ba9ae2f51620a89d68019353e2c306651b35bca337186b22b2e9865ef3c5e3df8e9328006f882e4577f8c85
|
||||
SHA512 (libreoffice-7.1.2.2.tar.xz) = 0e4cc2417943fcfaf84b513f6ee781a4f75d5c42804fa98c5499ec6d461be04bf68ca1f8f92952863ba3765d7e2894e77f78aa1f532b67649e31154683767297
|
||||
SHA512 (libreoffice-7.1.2.2.tar.xz.asc) = 076a5d1db56b989bf81c5bc62f0177ce73fae69b11f773ede463f827ae1021dcf1723ca000d1feb250b7ff8efc77d6f37dcae8544368062afcc27b0ea6fca9ed
|
||||
SHA512 (libreoffice-help-7.1.2.2.tar.xz) = 571db9a2fb3410ea6e86e5000f78648acb1f581a94cb0d2021a174116c44194c68749a875624aa042985630d83b44f312a6275524e8cd57f66678c6a1f8ec22e
|
||||
SHA512 (libreoffice-help-7.1.2.2.tar.xz.asc) = 9c7c8cee35bc451ac3a00e082d81b3a0db8fe9682352357f20f57db4d929b115db426868d08092229bb5d0f480508096f960127098c91b76a89fe1c5695cc105
|
||||
SHA512 (libreoffice-translations-7.1.2.2.tar.xz) = 804d389374df10c011b8637ddd124b809198172a9adeb2a50c7e9d7ed6e9f40eed0bcdcb4e2c3497756d953038e24665260d2fa3f312acdd9709046d93cf18e0
|
||||
SHA512 (libreoffice-translations-7.1.2.2.tar.xz.asc) = 132189ee9612830f911dc8613c5f23b034bfdac6f0a9745e620ec78a4d2ce0e484197fbcd0e4fea9ea99707ffac40ab8c554836ba6b8ab76acc5aa9b10971dfe
|
||||
SHA512 (libreoffice-7.1.3.2.tar.xz) = d7329475cad5bece9358b29bc590da1841c3c0b4aef511508d9398519c514fa176c90675857f1830925818f2dcc8b9c0986e5d34d3a33cce617e4ada23c60a72
|
||||
SHA512 (libreoffice-7.1.3.2.tar.xz.asc) = 9952bef51e851cd0b2601dce06304885cb9e53924641c5bf21f64ddd0c63c48c4be9223282640cb1fb84976be27e74e587781177c2155369017d3ad92147e4da
|
||||
SHA512 (libreoffice-help-7.1.3.2.tar.xz) = 576dbea391777a907275b630ed704dd3d9ad0627f8a18da1cbd23fe28df04c3a509583c2404f810df3aaac15ef0881e2c1e0a55c9f31618715586628873367eb
|
||||
SHA512 (libreoffice-help-7.1.3.2.tar.xz.asc) = 0c1a2280b855cc06d5698ff36448dbe9379bf84a2c3acbb755ff4f69de145b1909dd38ab7dc5498b29687841a101b9cd87e1a00f3abdc03b9015ebda8b28e454
|
||||
SHA512 (libreoffice-translations-7.1.3.2.tar.xz) = df320e5c41e94c08847b1f504461f6dcd11bc9c301ec0e219fead05a24982c0946e98263320c53357f89e8497e56871da071fff41f780f4ae8bf45859a88b34d
|
||||
SHA512 (libreoffice-translations-7.1.3.2.tar.xz.asc) = 7562148d64429a035c0d54973ed041e4623c181aa6f65a16448f14efa84b4ef36f3f8abb8cddf28cd47ba540f314d48d98f02a0fde2b0f269d180861c9c54637
|
||||
|
Loading…
x
Reference in New Issue
Block a user